gala crashed with SIGABRT in g_assertion_message()

Bug #1017168 reported by Sergey "Shnatsel" Davidoff on 2012-06-24
408
This bug affects 89 people
Affects Status Importance Assigned to Milestone
Gala
Fix Released
High
Unassigned

Bug Description

Automated crash report from Apport.

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: gala 0.1-0~r107+pkg7~precise1 [origin: LP-PPA-elementary-os-daily]
ProcVersionSignature: Ubuntu 3.2.0-25.40-generic 3.2.18
Uname: Linux 3.2.0-25-generic x86_64
ApportVersion: 2.0.1-0ubuntu8
Architecture: amd64
CrashCounter: 1
CrashDB: gala
Date: Sun Jun 24 18:36:06 2012
ExecutablePath: /usr/bin/gala
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64 (20120303)
ProcCmdline: gala
ProcEnviron:
 PATH=(custom, no user)
 LANG=ru_RU.UTF-8
 SHELL=/usr/bin/fish
Signal: 6
SourcePackage: gala
StacktraceTop:
 raise () from /lib/x86_64-linux-gnu/libc.so.6
 abort () from /lib/x86_64-linux-gnu/libc.so.6
 g_assertion_message (domain=<optimized out>, file=<optimized out>, line=<optimized out>, func=0x7f3cc109c900 "gee_linked_list_real_get", message=0x1ce2fd0 "assertion failed: (_tmp1_ < _tmp2_)") at /build/buildd/glib2.0-2.32.3/./glib/gtestutils.c:1861
 g_assertion_message_expr (domain=0x0, file=0x7f3cc109c6df "linkedlist.c", line=679, func=0x7f3cc109c900 "gee_linked_list_real_get", expr=<optimized out>) at /build/buildd/glib2.0-2.32.3/./glib/gtestutils.c:1872
 ?? () from /usr/lib/x86_64-linux-gnu/libgee.so.2
SuspiciousXErrors:

Title: gala crashed with SIGABRT in raise()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

StacktraceTop:
 g_assertion_message (domain=<optimized out>, file=<optimized out>, line=<optimized out>, func=0x7f3cc109c900 "gee_linked_list_real_get", message=0x1ce2fd0 "assertion failed: (_tmp1_ < _tmp2_)") at /build/buildd/glib2.0-2.32.3/./glib/gtestutils.c:1861
 g_assertion_message_expr (domain=0x0, file=0x7f3cc109c6df "linkedlist.c", line=679, func=0x7f3cc109c900 "gee_linked_list_real_get", expr=<optimized out>) at /build/buildd/glib2.0-2.32.3/./glib/gtestutils.c:1872
 gee_linked_list_real_get (base=0x197cd90, index=<optimized out>) at linkedlist.c:679
 ?? ()
 ?? ()

summary: - gala crashed with SIGABRT in raise()
+ gala crashed with SIGABRT in g_assertion_message()
Changed in gala:
status: New → Confirmed
importance: Undecided → High
milestone: none → luna-beta1

This may be still not enough info to fix the bug

Tom Beckmann (tombeckmann) wrote :

That's already a very good hint, the animations are causing this problem apparently.

Tristan Cormier (tristanc) wrote :

I think the animations are causing the problem as well. The bug happens when switching from window to window, opening a new one or closing one. Will try to post terminal output on error.

tags: removed: need-amd64-retrace
Tom Beckmann (tombeckmann) wrote :

I'm pretty sure this crash won't happen anymore. Reopen if I'm wrong.

Changed in gala:
status: Confirmed → Fix Released
Israel (isra1998isra) wrote :

Just happened to me again, Freya beta 1 i386 all up to date, using wine on fullscreen

This is also occurring again under Freya, especially when using Wine with fullscreen apps. Once gala crashes and recovers, text seems to get very blurry and the desktop becomes very ugly to look at.

Evan Langlois (uudruid74) wrote :

I'm not getting any blurry/ugliness. Everything came back normally. I am not running wine, but it did happen while running a java app (actually Cisco ADSM running IcedTea's javaws for jnlp access). So .. running network software is a big deal - supposed to be a Linux strength!

Reproduced in Freya amd64 with updates after Remmina crached.

Adam B. (gonzo-graphics) wrote :

I'm not using wine, but I am using guake and chrome

CruelAngel (hendricha) wrote :

Gala crashed with multiple screens, one having a maximized media player and tried to move windows between screens in multi-tasking view.

Thomas Citharel (tcit) wrote :

Crashing again, even with latest updates.

Paulo Pavačić (pavacic-p) wrote :

It is happening again.

Thomas Citharel (tcit) wrote :

Still happening.

quequotion (quequotion) wrote :

Is it the same crash?

I've opened a new report for crashing with segfaults that have been happening lately, bug 1410373.

Paulo Molina (polochamps2004) wrote :

Just had this bug today.

Charles Kramer (cvkramer) wrote :

I was using a virtual desktop. I do not think it was using wine technology. I was going through citrix anyconnect, closed a window and it crashed gala. i386 computer

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers