Alt+Tabbing while a window opens makes everything miniature

Bug #1011699 reported by Cassidy James Blaede on 2012-06-11
36
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Gala
Fix Released
Critical
Tom Beckmann

Bug Description

When a window opens while I'm alt+tabbing, Gala will flip out and throw a tantrum in which it looks as if my display has been miniaturized in the middle of my physical display, with a large white border around it. Mousing around shows that everything is in its proper (larger) place, but is getting drawn smaller. Alt+tabbing makes windows show at the proper size, but once you're out of the window switcher, everything is miniature again. The only way I've found to restore things is a quick gala --replace.

I realize this is complicated and confusing, but at the same time it's pretty severe; no ordinary user would be able to recover and it makes things feel extremely broken. I'm uploading a video to demonstrate the bug and will try to do more research/experimenting to track down the cause.

Notable info:
- Resolution: 1366 x 768
- Number of displays: 1
- OS: elementary OS Luna daily build 32-bit (Ubuntu 12.04)

Figured out how to reproduce!

1. Open at least two windows.
2. Open an app that takes a bit to show a window (Minecraft worked for me, but I also got it to happen with Dexter and some other apps).
3. Before the window appears, start alt+tabbing a bunch.

BAM, when the window appears, Gala flips out.

That white padding is shown on the display, btw.

Changed in gala:
importance: Undecided → Critical
summary: - Gala flips out and makes everything miniature
+ Alt+Tabbing when a window opens makes everything miniature
description: updated
Changed in gala:
milestone: none → luna-beta1
Daniel Fore (danrabbit) on 2012-06-14
Changed in gala:
status: New → Confirmed
Download full text (3.4 KiB)

It happened the same to me when a notification popped up while alt-tabbing
Il giorno 14/giu/2012 05.35, "Cassidy James" <email address hidden> ha scritto:

> That white padding is shown on the display, btw.
>
> ** Changed in: gala
> Importance: Undecided => Critical
>
> ** Summary changed:
>
> - Gala flips out and makes everything miniature
> + Alt+Tabbing when a window opens makes everything miniature
>
> ** Description changed:
>
> - Occasionally when I do something apparently Gala doesn't like (such as
> - fullscreening Winecraft or alt+tabbing a bunch of times between tiled
> - windows), Gala will flip out and throw a tantrum in which it looks as if
> - my display has been miniaturized in the middle of my physical display,
> - with a large white border around it. Mousing around shows that
> - everything is in its proper (larger) place, but is getting drawn
> - smaller. Alt+tabbing makes windows show at the proper size, but once
> - you're out of the window switcher, everything is miniature again. The
> - only way I've found to restore things is a quick gala --replace.
> + When a window opens while I'm alt+tabbing, Gala will flip out and throw
> + a tantrum in which it looks as if my display has been miniaturized in
> + the middle of my physical display, with a large white border around it.
> + Mousing around shows that everything is in its proper (larger) place,
> + but is getting drawn smaller. Alt+tabbing makes windows show at the
> + proper size, but once you're out of the window switcher, everything is
> + miniature again. The only way I've found to restore things is a quick
> + gala --replace.
>
> I realize this is complicated and confusing, but at the same time it's
> pretty severe; no ordinary user would be able to recover and it makes
> things feel extremely broken. I'm uploading a video to demonstrate the
> bug and will try to do more research/experimenting to track down the
> cause.
>
> Notable info:
> - Resolution: 1366 x 768
> - Number of displays: 1
> - OS: elementary OS Luna daily build 32-bit (Ubuntu 12.04)
>
> ** Changed in: gala
> Milestone: None => luna-beta1
>
> --
> You received this bug notification because you are a member of Gala
> developers, which is subscribed to Gala.
> https://bugs.launchpad.net/bugs/1011699
>
> Title:
> Alt+Tabbing when a window opens makes everything miniature
>
> Status in Gala Window Manager:
> New
>
> Bug description:
> When a window opens while I'm alt+tabbing, Gala will flip out and
> throw a tantrum in which it looks as if my display has been
> miniaturized in the middle of my physical display, with a large white
> border around it. Mousing around shows that everything is in its
> proper (larger) place, but is getting drawn smaller. Alt+tabbing makes
> windows show at the proper size, but once you're out of the window
> switcher, everything is miniature again. The only way I've found to
> restore things is a quick gala --replace.
>
> I realize this is complicated and confusing, but at the same time it's
> pretty severe; no ordinary user would be able to recover and it makes
> things feel extremely broken. I'm uploading a video to demonstrate the
> bug and will try t...

Read more...

summary: - Alt+Tabbing when a window opens makes everything miniature
+ Alt+Tabbing while a window opens makes everything miniature
FM5 (pvmhoang) wrote :

I have met the same problem from last saturday

Tom Beckmann (tombeckmann) wrote :

This should finally be solved. We're now not accessing the actual window directly anymore, but creating a clone of it.
Reopen if you still can reproduce it (please don't!!) ;)

Changed in gala:
assignee: nobody → Tom Beckmann (tombeckmann)
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers