always give focus to a window

Bug #1008234 reported by Daniel Fore on 2012-06-03
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Gala
Fix Released
Medium
Tom Beckmann

Bug Description

When a window is closed, give focus to the next highest window in the stack.

If there are windows on the display, one of them should always be focused.

Daniel Fore (danrabbit) on 2012-06-03
Changed in gala:
milestone: none → luna-beta1
importance: Undecided → Medium
Daniel Fore (danrabbit) on 2012-06-03
Changed in gala:
status: New → Confirmed
tags: added: focus

This is not Gala's bug; in fact it happens to Compiz too. The problem is Plank adores grabbing focus and that prevents Compiz key combos from working and causes this "no window seems to be focused" bug in Gala.

Tom Beckmann (tombeckmann) wrote :

I made sure to always focus a toplevel window now after a window is destroyed, so it should work fine now.

Changed in gala:
status: Confirmed → Fix Committed
assignee: nobody → Tom Beckmann (tombeckmann)
Changed in gala:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers