gala crashed with SIGSEGV in meta_window_move_frame()

Bug #1008184 reported by Sergey "Shnatsel" Davidoff on 2012-06-03
170
This bug affects 33 people
Affects Status Importance Assigned to Milestone
Gala
Fix Released
Critical
Unassigned

Bug Description

I got this crash on opening Google Chrome and closing a tab in it

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: gala 0.1-0~r47+pkg4~precise1 [origin: LP-PPA-elementary-os-daily]
ProcVersionSignature: Ubuntu 3.2.0-24.39-generic 3.2.16
Uname: Linux 3.2.0-24-generic x86_64
ApportVersion: 2.0.1-0ubuntu8
Architecture: amd64
CrashCounter: 1
CrashDB: gala
Date: Sun Jun 3 22:25:53 2012
ExecutablePath: /usr/bin/gala
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64 (20120303)
ProcCmdline: gala --replace
ProcEnviron:
 PATH=(custom, no user)
 LANG=ru_RU.UTF-8
 SHELL=/usr/bin/fish
SegvAnalysis:
 Segfault happened at: 0x7f07c5c43e67 <meta_window_move_frame+71>: add 0x28(%rax),%ecx
 PC (0x7f07c5c43e67) ok
 source "0x28(%rax)" (0x00000028) not located in a known VMA region (needed readable region)!
 destination "%ecx" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: gala
StacktraceTop:
 meta_window_move_frame () from /usr/lib/libmutter.so.0
 ?? ()
 meta_plugin_manager_event_simple () from /usr/lib/libmutter.so.0
 ?? () from /usr/lib/libmutter.so.0
 meta_window_actor_show () from /usr/lib/libmutter.so.0
SuspiciousXErrors:

Title: gala crashed with SIGSEGV in meta_window_move_frame()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

description: updated

StacktraceTop:
 meta_window_move_frame (window=0x1c94d50, user_op=1, root_x_nw=0, root_y_nw=<optimized out>) at core/window.c:5121
 ?? ()
 meta_plugin_manager_event_simple (plugin_mgr=0x17cae10, actor=0x1ce0fd0, event=8) at compositor/meta-plugin-manager.c:287
 start_simple_effect (self=0x1ce0fd0, event=<optimized out>) at compositor/meta-window-actor.c:1080
 meta_window_actor_show (self=0x1ce0fd0, effect=META_COMP_EFFECT_CREATE) at compositor/meta-window-actor.c:1392

visibility: private → public
Changed in gala:
importance: Undecided → Critical
status: New → Confirmed
milestone: none → luna-beta1

This is an upstream bug and has been fixed:
git commit 2012-05-01 meta_window_move_frame(): fix crash when frame is NULL

Looks like we need a newer libmutter.

Garden Gnome (gardengnome85) wrote :

This bug is in the main mutter code and has been fixed in git trunk
http://git.gnome.org/browse/mutter/commit/?h=wip/wayland&id=c669a3892e377daaf31a574618a4f8566bd9df61

We have two choices here distribute our own mutter debs or wait until the code has reached ubuntu debs

Ben Lyn (ben-lyn) on 2012-06-07
Changed in gala:
status: Confirmed → Fix Committed
Ben Lyn (ben-lyn) wrote :

oops

Changed in gala:
status: Fix Committed → Confirmed

I get this same crash when choosing a custom draw area for Eidete.

Saurabh Rawat (eklavya) wrote :

I was not using chrome and I got this crash message. In fact, I dodn't even notice anything wrong at all.

I get this when running office 2007 with playonlinux.

Tom Beckmann (tombeckmann) wrote :

It would be great if you could compile and install libmutter from git, I use it and it doesn't happen to me.
Installation:

$ sudo apt-get build-dep libmutter-dev
$ git clone git://git.gnome.org/mutter
$ cd mutter
$ ./autogen.sh
$ make
$ sudo make install

and then try to reprocude what caused the crashes earlier.

Fixed by cherrypicking the fix from upstream libmutter.

Changed in gala:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers