Maximized and tiled windows flash when grabbable areas are clicked

Bug #1008121 reported by Jonathan Moerman on 2012-06-03
34
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Gala
Fix Released
High
Tom Beckmann
Mutter
New
Undecided
Unassigned

Bug Description

When a grabbable area of a tiled window is left-clicked, the entire window flashes (becomes invisible for about 0.1 sec). This happens in windows that have been tiled or maximized in the same manner as tiling. The window flashes when clicking the title bar and anywhere else that's grabbable, like empty spots on the toolbar or menu bar.

This doesn't happen if you maximized the window by clicking the maximize button, double-clicking the titlebar, or right-clicking and choosing maximized.

other information:
GPU: Nvia GT 440
OS: x86-64, Ubuntu 12.04
DE: Pantheon

Daniel Fore (danrabbit) on 2012-06-03
Changed in gala:
milestone: none → luna-beta1
importance: Undecided → High
Changed in gala:
status: New → Confirmed
Tom Beckmann (tombeckmann) wrote :

Seems to happen in "raw" mutter too, so probably not really our bug..

Happens any time a part of the window that can move the window is grabbed. This means clicks on empty parts of a toolbar make the whole app flash.

summary: - Tiled windows disappear for an instant when titlebar is clicked. is
- clicked
+ Tiled windows flash when grabbable areas are clicked
description: updated

Also happens with maximized windows. This means if a user misclicks anywhere on a toolbar in a maximized app, the whole window flashes. Pretty jarring.

summary: - Tiled windows flash when grabbable areas are clicked
+ Maximized and tiled windows flash when grabbable areas are clicked
description: updated

Confirming on Radeon r600

jmikelf (jmikelf) wrote :

it doesn't happen anymore for me. was it fixed?

Doesn't happen for me on i915, marking fix released.

Changed in gala:
status: Confirmed → Fix Released

This bug happens to me on r600 as of revision 126

Changed in gala:
status: Fix Released → Confirmed

But I still cannot reproduce on i915; probably driver-related issue

And it still happens on r600. Definitely driver-related.

Okay, I have it now on i915 too. Must be happening selectively...

Tom Beckmann (tombeckmann) wrote :

It was a problem related to the animation not being able to play correctly when the window is already maximized, so it's disabled now. You'll only notice that it's missing, when you double click on a tiled window's titlebar, but I guess that's not that much of a problem.

Changed in gala:
status: Confirmed → Fix Released
assignee: nobody → Tom Beckmann (tombeckmann)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers