Switch focus with switch workspace

Bug #1007667 reported by Daniel Fore on 2012-06-02
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Gala
Fix Released
Medium
Tom Beckmann

Bug Description

When switching workspaces, focus needs to be assign to the topmost window.

This is especially a problem when you switch to a workspace with a fullscreen app (like Audience) and the panel and dock appear above the movie.

Daniel Fore (danrabbit) on 2012-06-02
Changed in gala:
importance: Undecided → Medium
Daniel Fore (danrabbit) on 2012-06-02
Changed in gala:
milestone: none → luna-beta1
Cody Garver (codygarver) on 2012-06-02
Changed in gala:
status: New → Confirmed
Tom Beckmann (tombeckmann) wrote :

I think plank always grabbed the focus, I made sure it's a normal window now.

Changed in gala:
status: Confirmed → Fix Committed
assignee: nobody → Tom Beckmann (tombeckmann)
Daniel Fore (danrabbit) wrote :

Is it possible to switch the focus before the animation starts, or to give focus to both workspaces during the animation?

Currently you see apps on another workspace go from the :backdrop state to focused during the animation and the dock is also shown hiding (sometimes re-appearing since it's already hidden on the first workspace)

Changed in gala:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers