invoke workspace manager on D-bus request or from command line

Bug #1007665 reported by Daniel Fore on 2012-06-01
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Gala
Fix Released
Wishlist
Unassigned

Bug Description

You should be able to invoke the workspace manager from the command line. This would allow us to create a .desktop shortcut.

Daniel Fore (danrabbit) on 2012-06-02
Changed in gala:
importance: Undecided → Wishlist

A d-bus request is probably better.

/me is not familiar. Would a D-Bus interface allow us to create a .desktop shortcut?

Changed in gala:
status: New → Confirmed

Sure it will.

Keith Adair (kjzz12) wrote :

Workaround!

sudo apt-get xautomation

Then create a launcher that does this:

xte 'keydown Super_R' 'key s' 'keyup Super_R'

I have it on my plank, it works great until we get a legit fix.

Getting required key combos from dconf might work if we don't come up with a better alternative

Targeting to luna-beta1 because we need this for implementing Plank launcher that opens workspaces overview.

summary: - invoke workspace manager from command line
+ invoke workspace manager on D-bus request or from command line
Changed in gala:
milestone: none → luna-beta1
Daniel Fore (danrabbit) wrote :

I believe this has been fixed right?

Tom Beckmann (tombeckmann) wrote :

Oh, right, thanks :)

Changed in gala:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers