Support is broken for servers without Manufacturer name in BIOS

Bug #1643192 reported by Daniil Lapshin on 2016-11-19
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Fuel for OpenStack
High
Georgy Kibardin
Mitaka
High
Georgy Kibardin
Newton
High
Georgy Kibardin
Ocata
High
Georgy Kibardin

Bug Description

The changes introduced in this commit https://review.openstack.org/#/c/367786/ couldn't handle the empty string in the Manufacturer section of BIOS. Due to this, nailgun agent will report :
E, [2016-11-19T11:46:18.283280 #3554] ERROR -- : Error 'undefined method `upcase' for nil:NilClass' in metadata calculation: ["/usr/bin/nailgun-agent:1022:in `_manufacturer'", "/usr/bin/nailgun-agent:1050:in `_system_info'", "/usr/bin/nailgun-agent:582:in `_detailed'", "/usr/bin/nailgun-agent:1165:in `_data'", "/usr/bin/nailgun-agent:207:in `put'", "/usr/bin/nailgun-agent:1371:in `<main>'"]

There are servers that has empty string in manufacturer field, for example the Dell OEM variant servers. So, the nailgun agent should be able to handle such scenario.

Daniil Lapshin (dlapshin) wrote :

sla1 for 9.0-updates

tags: added: customer-found
Anton Matveev (amatveev) on 2016-11-21
Changed in fuel:
milestone: none → 9.2
importance: Undecided → High
Changed in fuel:
milestone: 9.2 → 11.0
assignee: nobody → Fuel Sustaining (fuel-sustaining-team)
status: New → Confirmed
tags: added: area-python
Changed in fuel:
assignee: Fuel Sustaining (fuel-sustaining-team) → Georgy Kibardin (gkibardin)
Changed in fuel:
status: Confirmed → In Progress

Fix proposed to branch: stable/newton
Review: https://review.openstack.org/402577

Changed in fuel:
status: In Progress → Fix Committed

Reviewed: https://review.openstack.org/400226
Committed: https://git.openstack.org/cgit/openstack/fuel-nailgun-agent/commit/?id=ac5c37be5c8f66d7eedaa514b539db5fa7feb1a6
Submitter: Jenkins
Branch: master

commit ac5c37be5c8f66d7eedaa514b539db5fa7feb1a6
Author: Georgy Kibardin <email address hidden>
Date: Mon Nov 21 15:30:19 2016 +0300

    Handle absent manufacturer field correctly

    The section can be absent on some BIOSes. Agent must not fail in this
    case.

    Change-Id: I931e4c7f3549fc82663f6a6ccfb51b5c4e912fe7
    Closes-Bug: #1643192

Reviewed: https://review.openstack.org/402575
Committed: https://git.openstack.org/cgit/openstack/fuel-nailgun-agent/commit/?id=28d792cdbd64c81a9b29d7869bd2d9a93eb8998a
Submitter: Jenkins
Branch: stable/mitaka

commit 28d792cdbd64c81a9b29d7869bd2d9a93eb8998a
Author: Georgy Kibardin <email address hidden>
Date: Mon Nov 21 15:30:19 2016 +0300

    Handle absent manufacturer field correctly

    The section can be absent on some BIOSes. Agent must not fail in this
    case.

    Change-Id: I931e4c7f3549fc82663f6a6ccfb51b5c4e912fe7
    Closes-Bug: #1643192
    (cherry picked from commit ac5c37be5c8f66d7eedaa514b539db5fa7feb1a6)

Reviewed: https://review.openstack.org/402577
Committed: https://git.openstack.org/cgit/openstack/fuel-nailgun-agent/commit/?id=0cfe06be939f92c3a8158a0e8a96a7ab8cf5403b
Submitter: Jenkins
Branch: stable/newton

commit 0cfe06be939f92c3a8158a0e8a96a7ab8cf5403b
Author: Georgy Kibardin <email address hidden>
Date: Mon Nov 21 15:30:19 2016 +0300

    Handle absent manufacturer field correctly

    The section can be absent on some BIOSes. Agent must not fail in this
    case.

    Change-Id: I931e4c7f3549fc82663f6a6ccfb51b5c4e912fe7
    Closes-Bug: #1643192
    (cherry picked from commit ac5c37be5c8f66d7eedaa514b539db5fa7feb1a6)

tags: added: on-verification
TatyanaGladysheva (tgladysheva) wrote :

Waiting for customer will verify the fix since we have no such servers without Manufacturer name in BIOS.

TatyanaGladysheva (tgladysheva) wrote :

Ticket for customer's check was created by dlapshin at 7-Dec. Customer requires some time for reproducing this bug.

Nastya Urlapova (aurlapova) wrote :

@Daniil Lapshin, please don't forget to update the issue status after customer's response. According to our rules issue was moved to "Fix Released", but we cannot verify the fix!

tags: removed: on-verification

This issue was fixed in the openstack/fuel-nailgun-agent 11.0.0.0rc1 release candidate.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers