Cleanup for old stuff from nailgun db in demo instance

Bug #1401898 reported by Igor Shishkin on 2014-12-12
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Fuel for OpenStack
Medium
Fuel Sustaining
Mitaka
Medium
Fuel Python (Deprecated)
Newton
Medium
Fuel Sustaining

Bug Description

Hi,

Please write a script could be ran from cron to cleanup clusters, nodes, etc. older than X seconds.
It's required to cleanup our demo.fuel-infra.org from old stuff automatically.

The best way to pass X number I think it's argument, so I suppose to see something like:

nailgun-demo-cleanup.py --ttl 86400

Thanks in advance

Dmitry Pyzhov (dpyzhov) on 2014-12-12
Changed in fuel:
importance: High → Medium
status: New → Confirmed
Dmitry Pyzhov (dpyzhov) on 2015-03-27
tags: added: feature-demo-site
removed: nailgun
Dmitry Pyzhov (dpyzhov) on 2015-04-01
Changed in fuel:
milestone: 6.1 → 7.0
tags: added: non-release qa-agree-7.0
Vladimir Sharshov (vsharshov) wrote :

Non-release. Can be safely moving to 8.0

Changed in fuel:
status: Confirmed → Won't Fix
Igor Shishkin (teran) on 2015-10-06
tags: added: devops
Dmitry Pyzhov (dpyzhov) on 2015-10-12
no longer affects: fuel/8.0.x
Changed in fuel:
status: Won't Fix → Confirmed
milestone: 7.0 → 8.0
tags: added: tech-debt
Dmitry Pyzhov (dpyzhov) on 2015-10-22
tags: added: area-python
Dmitry Pyzhov (dpyzhov) wrote :

Moving medium bug to 9.0 because we have SCF in action for 8.0

Changed in fuel:
milestone: 8.0 → 9.0
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers