fuel-agent to use upper-constraints in stable branches

Bug #1691431 reported by Alexey Stupnikov
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Fuel for OpenStack
In Progress
High
Fuel Sustaining
8.0.x
Fix Released
High
Alexey Stupnikov
Mitaka
Fix Committed
Critical
Alexey Stupnikov

Bug Description

New python packages are constantly breaking our py27/py34 tests. Lets use upper-constraints to fix this issue.

Revision history for this message
Alexey Stupnikov (astupnikov) wrote :

A patch to use as a template to fix fuel-agent.

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to fuel-agent (stable/mitaka)

Fix proposed to branch: stable/mitaka
Review: https://review.openstack.org/465553

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to fuel-agent (stable/newton)

Fix proposed to branch: stable/newton
Review: https://review.openstack.org/465562

Changed in fuel:
status: Confirmed → In Progress
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to fuel-agent (stable/8.0)

Fix proposed to branch: stable/8.0
Review: https://review.openstack.org/465573

tags: added: non-release
Revision history for this message
Alexey Stupnikov (astupnikov) wrote :

Increased importance as CI tests are broken for this branches.

Changed in fuel:
importance: Medium → High
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to fuel-agent (stable/mitaka)

Reviewed: https://review.openstack.org/465553
Committed: https://git.openstack.org/cgit/openstack/fuel-agent/commit/?id=2f024bb3f02592d202c9b8726ec7ae53288d3594
Submitter: Jenkins
Branch: stable/mitaka

commit 2f024bb3f02592d202c9b8726ec7ae53288d3594
Author: Alexey Stupnikov <email address hidden>
Date: Wed May 17 16:13:20 2017 +0300

    Use upper constraints

    This commit is used to exclude new python packages from being
    installed during tox tests and protect our CI from sporadical
    failures caused by new packages.

    Change-Id: If83bed2a282e9303cb72bfc419ba7e5abebb17f5
    Closes-bug: #1691431

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to fuel-agent (stable/8.0)

Reviewed: https://review.openstack.org/465573
Committed: https://git.openstack.org/cgit/openstack/fuel-agent/commit/?id=0e32b548d6341d507d65e7df250223ddb8e84c6f
Submitter: Jenkins
Branch: stable/8.0

commit 0e32b548d6341d507d65e7df250223ddb8e84c6f
Author: Alexey Stupnikov <email address hidden>
Date: Wed May 17 16:42:12 2017 +0300

    Use upper constraints

    This commit is used to exclude new python packages from being
    installed during tox tests and protect our CI from sporadical
    failures caused by new packages.

    NOTE. I have used mitaka constraints intentionally, since we
    need newere packages than specified in liberty's
    upper-constraints.

    Change-Id: I7042dcfb2d561819fd8098f53036aa6cc045dc56
    Closes-bug: #1691431

Revision history for this message
Alexey Stupnikov (astupnikov) wrote :

We don't have essential rights to merge anything to stable/newton. Assigning this patch to fuel-sustaining.

Changed in fuel:
assignee: Alexey Stupnikov (astupnikov) → Fuel Sustaining (fuel-sustaining-team)
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Change abandoned on fuel-agent (stable/newton)

Change abandoned by Alexey Stupnikov (<email address hidden>) on branch: stable/newton
Review: https://review.opendev.org/465562

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers