[vCenter] CA file is not uploaded

Bug #1623478 reported by Ilya Bumarskov on 2016-09-14
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Fuel for OpenStack
Critical
Alexander Arzhanov
Mitaka
Critical
Alexander Arzhanov
Newton
Critical
Alexander Arzhanov

Bug Description

Fuel 9.1 (snapshot-id#258)

Steps to reproduce:
   - Create env
   - Add following nodes:
         * Controller
         * Compute-vmware, Cinder-vmware
         * Ceph-osd
         * Ceph-osd
         * Ceph-osd
   - Configure VMware vCenter Settings. Add 2 vSphere clusters and configure Nova Compute instances on controller and compute-vmware.
   - Uncheck the "Bypass vCenter certificate verification" option and upload CA file for vCenter
   - Deploy env

Observed behavior:
Error
Deployment has failed. All nodes are finished. Failed tasks: Task[vcenter_compute_zones_create/3], Task[vcenter_compute_zones_create/4] Stopping the deployment process!

CA file wasn't uploaded and configured for cinder and nova services

Ilya Bumarskov (ibumarskov) wrote :
Changed in fuel:
assignee: nobody → Alexander Arzhanov (aarzhanov)
importance: Undecided → Critical
milestone: none → 9.1
tags: added: area-pce-vcenter
summary: - [vCenter] CA file are not uploaded
+ [vCenter] CA file is not uploaded
Changed in fuel:
status: New → Confirmed

Fix proposed to branch: master
Review: https://review.openstack.org/370119

Changed in fuel:
status: Confirmed → In Progress
tags: added: blocker-for-qa

Reviewed: https://review.openstack.org/370119
Committed: https://git.openstack.org/cgit/openstack/fuel-web/commit/?id=0df751c75efb938e25aef4b1263331f1c9d8c333
Submitter: Jenkins
Branch: master

commit 0df751c75efb938e25aef4b1263331f1c9d8c333
Author: Alexander Arzhanov <email address hidden>
Date: Wed Sep 14 16:29:43 2016 +0300

    Fix typos vc_ca_file -> vcenter_ca_file

    CA file is not uploaded because we made a mistake
    in name vc_ca_file.

    Fix typos vc_ca_file -> vcenter_ca_file to get correct
    certificate files for cinder and compute item in
    orchestrator serializer.

    Change-Id: I531a1d6fb7d8cf28df644f8d2301cec4f437a996
    Closes-bug: #1623478

Changed in fuel:
status: In Progress → Fix Committed

Reviewed: https://review.openstack.org/370371
Committed: https://git.openstack.org/cgit/openstack/fuel-web/commit/?id=064cb5bda6db404b2c8fc8c60ee37bfe881b01ee
Submitter: Jenkins
Branch: stable/mitaka

commit 064cb5bda6db404b2c8fc8c60ee37bfe881b01ee
Author: Alexander Arzhanov <email address hidden>
Date: Wed Sep 14 16:29:43 2016 +0300

    Fix typos vc_ca_file -> vcenter_ca_file

    CA file is not uploaded because we made a mistake
    in name vc_ca_file.

    Fix typos vc_ca_file -> vcenter_ca_file to get correct
    certificate files for cinder and compute item in
    orchestrator serializer.

    Change-Id: I531a1d6fb7d8cf28df644f8d2301cec4f437a996
    Closes-bug: #1623478
    (cherry picked from commit 0df751c75efb938e25aef4b1263331f1c9d8c333)

Ilya Bumarskov (ibumarskov) wrote :

Verified on Fuel 9.1 (snapshot #281)

This issue was fixed in the openstack/fuel-web 10.0.0rc1 release candidate.

This issue was fixed in the openstack/fuel-web 10.0.0 release.

Nastya Urlapova (aurlapova) wrote :

We don't support vCenter since 10.0 version, moved to Fix Released.

Changed in fuel:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers