ImportError: No module named functools32

Bug #1662168 reported by Anton Chevychalov on 2017-02-06
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Fuel for OpenStack
Critical
Dmitry Kaigarodеsev
7.0.x
Critical
Anton Chevychalov
8.0.x
Critical
Anton Chevychalov
Mitaka
Critical
Anton Chevychalov

Bug Description

That look like we have incompatibility in https://pypi.python.org/pypi/jsonschema/2.6.0 that has been release 5th February.

We have a tests that fails for all version of MOS.

Example:

https://ci.fuel-infra.org/job/gate-fuel-library-tasks/3228/console

https://ci.fuel-infra.org/job/7.0.verify-fuel-library-tasks/766/console

  File "/home/jenkins/workspace/7.0.verify-fuel-library-tasks_VENV/lib/python2.6/site-packages/jsonschema/compat.py", line 35, in <module>
    from functools32 import lru_cache
ImportError: No module named functools32

Changed in fuel:
milestone: none → 10.x-updates
milestone: 10.x-updates → 10.1
assignee: nobody → Fuel Sustaining (fuel-sustaining-team)

Fix proposed to branch: stable/newton
Review: https://review.openstack.org/429760

Changed in fuel:
assignee: Fuel Sustaining (fuel-sustaining-team) → Dmitry Kaigarodеsev (dkaiharodsev)
status: New → In Progress
Changed in fuel:
importance: Undecided → Critical

Reviewed: https://review.openstack.org/429717
Committed: https://git.openstack.org/cgit/openstack/fuel-library/commit/?id=520ff0ba9291c16283ac59c4f60c504d24551c3c
Submitter: Jenkins
Branch: stable/mitaka

commit 520ff0ba9291c16283ac59c4f60c504d24551c3c
Author: Anton Chevychalov <email address hidden>
Date: Mon Feb 6 17:08:01 2017 +0300

    Restrict python-jsonscema for testing

    There is incompatibility in jsonschema 2.6 that cause
    ImportError: No module named functools32

    Change-Id: I8c86e897a6d693e4bc9e5c57006ce71b6bad40d2
    Closes-Bug: #1662168

Reviewed: https://review.openstack.org/429686
Committed: https://git.openstack.org/cgit/openstack/fuel-library/commit/?id=9450c56304a51e65959f5a6687747929aef17a31
Submitter: Jenkins
Branch: stable/7.0

commit 9450c56304a51e65959f5a6687747929aef17a31
Author: Anton Chevychalov <email address hidden>
Date: Mon Feb 6 19:12:47 2017 +0300

    Restrict python-jsonscema for testing

    There is incompatibility in jsonschema 2.6 that cause
    ImportError: No module named functools32

    Change-Id: I8c86e897a6d693e4bc9e5c57006ce71b6bad40d2
    Closes-Bug: #1662168

Reviewed: https://review.openstack.org/429763
Committed: https://git.openstack.org/cgit/openstack/fuel-library/commit/?id=6dae4ff79360dccfc63ecb2ed2e9596867a347ce
Submitter: Jenkins
Branch: stable/8.0

commit 6dae4ff79360dccfc63ecb2ed2e9596867a347ce
Author: Anton Chevychalov <email address hidden>
Date: Mon Feb 6 17:08:01 2017 +0300

    Restrict python-jsonscema for testing

    There is incompatibility in jsonschema 2.6 that cause
    ImportError: No module named functools32

    Change-Id: I8c86e897a6d693e4bc9e5c57006ce71b6bad40d2
    Closes-Bug: #1662168

Reviewed: https://review.openstack.org/429760
Committed: https://git.openstack.org/cgit/openstack/fuel-library/commit/?id=3ce37b120cc0f34b2830190991f4f9755eed1336
Submitter: Jenkins
Branch: stable/newton

commit 3ce37b120cc0f34b2830190991f4f9755eed1336
Author: Anton Chevychalov <email address hidden>
Date: Mon Feb 6 17:08:01 2017 +0300

    Restrict python-jsonscema for testing

    There is incompatibility in jsonschema 2.6 that cause
    ImportError: No module named functools32

    Change-Id: I8c86e897a6d693e4bc9e5c57006ce71b6bad40d2
    Closes-Bug: #1662168

tags: added: in-stable-newton
Changed in fuel:
status: In Progress → Fix Committed

Tasklib related test has been disabled in master. For additional information see https://bugs.launchpad.net/fuel/+bug/1662169

Change abandoned by Mykyta Karpin (<email address hidden>) on branch: stable/ocata
Review: https://review.openstack.org/445989
Reason: this is not needed because tasks job is disabled on ocata branch

Ekaterina Shutova (eshutova) wrote :

Verified on 10.0 #1568
Tests are passed, problem is gone.
https://ci.fuel-infra.org/job/gate-fuel-library-tasks/3328/

Changed in fuel:
status: Fix Committed → Fix Released
Harsh (harsh.v.singh) wrote :

Hi,
I still face this dependency issue after installing latest jsonschema (using pip install jsonschema). On doing import, it complains of missing functools32 dependency. Can you please check the same?

-bash-4.1$ pip --version
pip 7.1.0 from /usr/lib/python2.6/site-packages (python 2.6)

-bash-4.1$ python
Python 2.6.6 (r266:84292, Jul 23 2015, 05:13:40)
[GCC 4.4.7 20120313 (Red Hat 4.4.7-16)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import jsonschema
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "/usr/lib/python2.6/site-packages/jsonschema/__init__.py", line 12, in <module>
    from jsonschema.exceptions import (
  File "/usr/lib/python2.6/site-packages/jsonschema/exceptions.py", line 6, in <module>
    from jsonschema import _utils
  File "/usr/lib/python2.6/site-packages/jsonschema/_utils.py", line 6, in <module>
    from jsonschema.compat import str_types, MutableMapping, urlsplit
  File "/usr/lib/python2.6/site-packages/jsonschema/compat.py", line 35, in <module>
    from functools32 import lru_cache
ImportError: No module named functools32

Harsh (harsh.v.singh) wrote :

As a workaround, I have reverted to jsonschema 2.3.0. Let know once the issue is addressed for 2.6

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers