Multiple default provider for l2_port resources may be happens

Bug #1534596 reported by Andrey Volochay on 2016-01-15
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Fuel for OpenStack
High
Sergey Vasilenko
7.0.x
High
Sergey Vasilenko
8.0.x
High
Sergey Vasilenko
Mitaka
High
Sergey Vasilenko

Bug Description

When Fuel installs an environment with puppet 3.8, module L23network makes wrong choice between multiple default providers of L2_port

Sergey Vasilenko (xenolog) wrote :

This bug affect not only Puppet 3.8.
But it is heavy reproduced situation.

Changed in fuel:
assignee: nobody → Sergey Vasilenko (xenolog)
importance: Undecided → High
summary: - Wrong choosing a provider when multiple default providers
+ Multiple default provider for l2_port resources may be happens
tags: added: l23network

Reviewed: https://review.openstack.org/268155
Committed: https://git.openstack.org/cgit/openstack/fuel-library/commit/?id=da30a48ca5c82e6b3b2a2161cc139876efd634fa
Submitter: Jenkins
Branch: stable/7.0

commit da30a48ca5c82e6b3b2a2161cc139876efd634fa
Author: Sergey Vasilenko <email address hidden>
Date: Fri Jan 15 17:11:03 2016 +0300

    Puppet has Multiple default providers for l2_port resource

    while prefetch. This patch fix wrong fact usage.

    Change-Id: I30177ad211ed155f7460574dc2f1efaa3b674033
    Related-bug: #1534596

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers