ohai on bootstrap throws traceback

Bug #1505709 reported by Sebastian Kalinowski on 2015-10-13
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Fuel for OpenStack
High
Artem Silenkov
6.0.x
High
Unassigned
6.1.x
High
Unassigned
7.0.x
High
Artem Silenkov
8.0.x
High
Artem Silenkov

Bug Description

[root@bootstrap ~]# ohai
/usr/lib/ruby/gems/1.8/gems/ohai-6.14.0/lib/ohai/system.rb:238:in `initialize': wrong number of arguments (1 for 0) (ArgumentError)
 from /usr/lib/ruby/gems/1.8/gems/ohai-6.14.0/lib/ohai/system.rb:238:in `new'
 from /usr/lib/ruby/gems/1.8/gems/ohai-6.14.0/lib/ohai/system.rb:238:in `json_pretty_print'
 from /usr/lib/ruby/gems/1.8/gems/ohai-6.14.0/lib/ohai/application.rb:104:in `run_application'
 from /usr/lib/ruby/gems/1.8/gems/ohai-6.14.0/lib/ohai/application.rb:75:in `run'
 from /usr/lib/ruby/gems/1.8/gems/ohai-6.14.0/bin/ohai:51
 from /usr/bin/ohai:19:in `load'
 from /usr/bin/ohai:19

Seems that gem resposible for data serialization is broken and ohai is not capable of printing data.

api: '1.0'
astute_sha: e99368bd77496870592781f4ba4fb0caacb9f3a7
auth_required: true
build_id: '140'
build_number: '140'
feature_groups:
- mirantis
fuel-agent_sha: 84335446172cc6a699252c184076a519ac791ca1
fuel-createmirror_sha: df6a93f7e2819d3dfa600052b0f901d9594eb0db
fuel-library_sha: 6579c3debf9f1e8832cc6714aca0125b66d2bd7d
fuel-nailgun-agent_sha: d66f188a1832a9c23b04884a14ef00fc5605ec6d
fuel-nailgun_sha: 46fbd9e21e91af057335cfa7e1f29159c1eb82ac
fuel-ostf_sha: 983d0e6fe64397d6ff3bd72311c26c44b02de3e8
fuelmain_sha: 4c58b6503fc780be117777182165fd7b037b1a96
openstack_version: 2015.1.0-8.0
production: docker
python-fuelclient_sha: 769df968e19d95a4ab4f12b1d2c76d385cf3168c
release: '8.0'
release_versions:
  2015.1.0-8.0:
    VERSION:
      api: '1.0'
      astute_sha: e99368bd77496870592781f4ba4fb0caacb9f3a7
      build_id: '140'
      build_number: '140'
      feature_groups:
      - mirantis
      fuel-agent_sha: 84335446172cc6a699252c184076a519ac791ca1
      fuel-createmirror_sha: df6a93f7e2819d3dfa600052b0f901d9594eb0db
      fuel-library_sha: 6579c3debf9f1e8832cc6714aca0125b66d2bd7d
      fuel-nailgun-agent_sha: d66f188a1832a9c23b04884a14ef00fc5605ec6d
      fuel-nailgun_sha: 46fbd9e21e91af057335cfa7e1f29159c1eb82ac
      fuel-ostf_sha: 983d0e6fe64397d6ff3bd72311c26c44b02de3e8
      fuelmain_sha: 4c58b6503fc780be117777182165fd7b037b1a96
      openstack_version: 2015.1.0-8.0
      production: docker
      python-fuelclient_sha: 769df968e19d95a4ab4f12b1d2c76d385cf3168c
      release: '8.0'

@Sebastian, on which build bug was reproduced?

Changed in fuel:
status: New → Incomplete
Sebastian Kalinowski (prmtl) wrote :

Sorry, version added.

description: updated
Changed in fuel:
status: Incomplete → New
Changed in fuel:
status: New → Confirmed
Dmitry Tyzhnenko (dtyzhnenko) wrote :

reproduced on 7.0-301

[root@nailgun ~]# fuel nodes | grep 10.109.0.8
5 | discover | Untitled (4e:45) | None | 10.109.0.8 | 64:bb:b7:38:4e:45 | | | True | None

[root@nailgun ~]# ssh 10.109.0.8 ohai
Warning: Permanently added '10.109.0.8' (RSA) to the list of known hosts.
/usr/lib/ruby/gems/1.8/gems/ohai-6.14.0/lib/ohai/system.rb:238:in `initialize': wrong number of arguments (1 for 0) (ArgumentError)
        from /usr/lib/ruby/gems/1.8/gems/ohai-6.14.0/lib/ohai/system.rb:238:in `new'
        from /usr/lib/ruby/gems/1.8/gems/ohai-6.14.0/lib/ohai/system.rb:238:in `json_pretty_print'
        from /usr/lib/ruby/gems/1.8/gems/ohai-6.14.0/lib/ohai/application.rb:104:in `run_application'
        from /usr/lib/ruby/gems/1.8/gems/ohai-6.14.0/lib/ohai/application.rb:75:in `run'
        from /usr/lib/ruby/gems/1.8/gems/ohai-6.14.0/bin/ohai:51
        from /usr/bin/ohai:19:in `load'
        from /usr/bin/ohai:19

Fuel version:

api: '1.0'
astute_sha: 6c5b73f93e24cc781c809db9159927655ced5012
auth_required: true
build_id: '301'
build_number: '301'
feature_groups:
- mirantis
fuel-agent_sha: 50e90af6e3d560e9085ff71d2950cfbcca91af67
fuel-library_sha: 5d50055aeca1dd0dc53b43825dc4c8f7780be9dd
fuel-nailgun-agent_sha: d7027952870a35db8dc52f185bb1158cdd3d1ebd
fuel-ostf_sha: 2cd967dccd66cfc3a0abd6af9f31e5b4d150a11c
fuelmain_sha: a65d453215edb0284a2e4761be7a156bb5627677
nailgun_sha: 4162b0c15adb425b37608c787944d1983f543aa8
openstack_version: 2015.1.0-7.0
production: docker
python-fuelclient_sha: 486bde57cda1badb68f915f66c61b544108606f3
release: '7.0'
release_versions:
  2015.1.0-7.0:
    VERSION:
      api: '1.0'
      astute_sha: 6c5b73f93e24cc781c809db9159927655ced5012
      build_id: '301'
      build_number: '301'
      feature_groups:
      - mirantis
      fuel-agent_sha: 50e90af6e3d560e9085ff71d2950cfbcca91af67
      fuel-library_sha: 5d50055aeca1dd0dc53b43825dc4c8f7780be9dd
      fuel-nailgun-agent_sha: d7027952870a35db8dc52f185bb1158cdd3d1ebd
      fuel-ostf_sha: 2cd967dccd66cfc3a0abd6af9f31e5b4d150a11c
      fuelmain_sha: a65d453215edb0284a2e4761be7a156bb5627677
      nailgun_sha: 4162b0c15adb425b37608c787944d1983f543aa8
      openstack_version: 2015.1.0-7.0
      production: docker
      python-fuelclient_sha: 486bde57cda1badb68f915f66c61b544108606f3
      release: '7.0'

Dmitry Pyzhov (dpyzhov) on 2015-10-22
tags: added: area-python
Dmitry Pyzhov (dpyzhov) on 2015-10-23
Changed in fuel:
assignee: Fuel Python Team (fuel-python) → MOS Linux (mos-linux)

We do not deal with Ruby.

Changed in fuel:
assignee: MOS Linux (mos-linux) → Dmitry Pyzhov (dpyzhov)
Dmitry Pyzhov (dpyzhov) on 2015-10-23
Changed in fuel:
assignee: Dmitry Pyzhov (dpyzhov) → Fuel Python Team (fuel-python)
Dmitry Pyzhov (dpyzhov) wrote :

In 8.0 we'll have Centos 7 with updated version of ohai. Also we are going to use Ubuntu on bootstrap nodes. Let's check if we need backports for this bug.

Dmitry Pyzhov (dpyzhov) wrote :

I've found the root cause. For some reason we have broken rubygem-yajl-ruby package. In 6.1 we have 1.1.0-1.el6 and it works fine. In 7.0 and 8.0 we have 1.1.0-2~1.el6.mira3 and it is broken.

it should be "require 'yajl/yajl'" instead of "require 'yajl'" in the first line of the /usr/lib/ruby/gems/1.8/gems/yajl-ruby-1.1.0/lib/yajl.rb file. Ohai works fine with this fix.

Changed in fuel:
status: Confirmed → Triaged
Dmitry Pyzhov (dpyzhov) wrote :

Also /usr/lib/ruby/gems/1.8/gems/yajl-ruby-1.1.0/lib/yajl/yajl.so is missed

Changed in fuel:
assignee: Fuel Python Team (fuel-python) → Artem Silenkov (asilenkov)
tags: added: area-mos
removed: area-python
Changed in fuel:
milestone: 8.0 → 9.0
status: Triaged → New
no longer affects: fuel/future
Changed in fuel:
status: New → Confirmed
tags: added: area-packaging
removed: area-mos
Artem Silenkov (asilenkov) wrote :

Only 6.1, 7.0 is affected.
Versions greater then specified have updated gem.

Changed in fuel:
status: Confirmed → Won't Fix
status: Won't Fix → Invalid
Artem Silenkov (asilenkov) wrote :

Only 7.0 is affected.

Related fix proposed to branch: 7.0
Change author: Artem Silenkov <email address hidden>
Review: https://review.fuel-infra.org/16117

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers