[system-tests][staging]CentOS bvt tests: NTPd service failed to find time servers

Bug #1436373 reported by Timur Sufiev on 2015-03-25
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Fuel for OpenStack
High
Fuel QA Team
5.1.x
High
Ivan Kolodyazhny
6.0.x
High
Fuel QA Team

Bug Description

Thus prepare_slaves_3.prepare_slaves_3 test has failed

Full log can be seen at http://jenkins-product.srt.mirantis.net:8080/job/5.1.2.staging.centos.bvt_1/90/console

Changed in fuel:
milestone: none → 5.1.2
Timur Sufiev (tsufiev-x) on 2015-03-25
tags: added: staging
Timur Sufiev (tsufiev-x) on 2015-03-25
Changed in fuel:
assignee: nobody → Fuel DevOps (fuel-devops)
Igor Shishkin (teran) wrote :

Timur, please provide more details, why it's failed and clarify why you have assigned this bug to fuel-devops?

Changed in fuel:
assignee: Fuel DevOps (fuel-devops) → Timur Sufiev (tsufiev)
status: New → Incomplete
Timur Sufiev (tsufiev-x) wrote :

Igor,

sorry, the previous link in Description was incorrect, fixed it.

As for why I had chosen fuel-devops, I had 2 options either you, or fuel-osci (because it seemed neither library, nor ui teams responsibility). I flipped the coin and it pointed to you :).

By the way, my correct account is tsufiev-x.

description: updated
Changed in fuel:
status: Incomplete → New
assignee: Timur Sufiev (tsufiev) → Fuel OSCI Team (fuel-osci)
Roman Vyalov (r0mikiam) on 2015-03-30
Changed in fuel:
assignee: Fuel OSCI Team (fuel-osci) → Stanislaw Bogatkin (sbogatkin)
Changed in fuel:
milestone: 5.1.2 → 6.1
Changed in fuel:
importance: Undecided → High
status: New → Confirmed
summary: - [system tests] CentOS bvt tests: NTPd service failed to find timer
+ [system tests] CentOS bvt tests: NTPd service failed to find time
servers

Reviewed: https://review.openstack.org/171709
Committed: https://git.openstack.org/cgit/stackforge/fuel-library/commit/?id=09ba80fd931497fca2e4b82eec3b12116341b428
Submitter: Jenkins
Branch: master

commit 09ba80fd931497fca2e4b82eec3b12116341b428
Author: Stanislaw Bogatkin <email address hidden>
Date: Wed Apr 8 18:55:54 2015 +0300

    Change NTP module

    Change options:
    * panic - panic is not boolean, it is integer, actually

    Add options:
    * tinker - disable or enable tinker
    * minpoll - to change ntpd send packages frequency
    * maxpoll - to change ntpd send packages frequency
    * stepout - to change stepout interval

    Change-Id: I8da3a129227061bd436e5343dfcceb8eb7a3aca0
    Link to upstream fix: https://tickets.puppetlabs.com/browse/MODULES-1925
    Related-bug: #1430482
    Related-bug: #1436373

6.1 library-related fix: https://review.openstack.org/#/c/172011/

In older releases problem should be fixed by QA team, I think, cause tests failed due to nature of NTP itself - it cannot became into synced state too fast, it needs to add some sleep into tests.

Changed in fuel:
status: Confirmed → Fix Committed
Stanislaw Bogatkin (sbogatkin) wrote :

6.1 library-related fix: https://review.openstack.org/#/c/172011/

In older releases problem should be fixed by QA team, I think, cause tests failed due to nature of NTP itself - it cannot became into synced state too fast, it needs to add some sleep into tests.

Stanislaw Bogatkin (sbogatkin) wrote :
Changed in fuel:
assignee: Stanislaw Bogatkin (sbogatkin) → Fuel QA Team (fuel-qa)
status: Fix Committed → Confirmed

Looks like issue was fixed.

summary: - [system tests] CentOS bvt tests: NTPd service failed to find time
+ [system-tests] CentOS bvt tests: NTPd service failed to find time
servers
tags: added: system-tests
Changed in fuel:
status: Confirmed → Fix Committed
summary: - [system-tests] CentOS bvt tests: NTPd service failed to find time
- servers
+ [system-tests][staging]CentOS bvt tests: NTPd service failed to find
+ time servers
Changed in fuel:
status: Fix Committed → Fix Released
Tatyanka (tatyana-leontovich) wrote :

@Ivan actually here https://old-stable-ci.infra.mirantis.net/job/5.1.2.staging.centos.bvt_1/276/testReport/junit/%28root%29/deploy_neutron_vlan_ha/deploy_neutron_vlan_ha/ deployment is error status, so it is not related to Fuel-QA, please assign the issue to the correct team

Vitaly Sedelnik (vsedelnik) wrote :

Won't Fix for 5.1.1-updates as this issue doesn't affect customer deployments

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers