NTP fails during fuel 11 deployment

Bug #1735657 reported by Prerna Dembla on 2017-12-01
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Fuel for OpenStack
Undecided
Unassigned

Bug Description

Env used:
- Windows 8.1 PC, VirtualBox, fuel 11 community

Steps to reproduce:
- Install Fuel, 1 compute, 1 controller, 1 cinder.
- Deployment failed.

The network verification is successful.
Provisioning is stuck at 50% and times out after an hour, and gives the following error on master node..
Puppet agent took too long to run puppet task. Mark task as failed. Node master, task build_deploy_image, manifest /etc/puppet/modules/osnailyfacter/modular/provision/build_image.pp

The slave node (5f:b9) has the following logs..
2017-12-01 04:51:42 ERR ntpd[11322]: unable to bind to wildcard address :: - another process may be running - EXITING
2017-11-30 05:02:06 ERR ntpd[10110]: unable to bind to wildcard address :: - another process may be running - EXITING
2017-11-30 04:31:54 ERR ntpd[945]: unable to create socket on enp0s9 (9) for fe80::a00:27ff:febc:89ba%4#123
2017-11-30 04:31:54 ERR ntpd[945]: bind(28) AF_INET6 fe80::a00:27ff:febc:89ba%4#123 flags 0x11 failed: Cannot assign requested address
2017-11-30 04:22:27 ERR ntpd[943]: unable to bind to wildcard address :: - another process may be running - EXITING
2017-11-30 04:22:17 ERR kernel: [ 22.186069] intel_rapl: no valid rapl domains found in package 0
2017-11-30 04:22:17 ERR rsyslogd-2039: Could not open output pipe '/dev/xconsole':: No such file or directory [v8.16.0 try http://www.rsyslog.com/e/2039 ]
2017-11-30 04:22:17 ERR rsyslogd-2222: command 'KLogPermitNonKernelFacility' is currently not permitted - did you already set it via a RainerScript command (v6+ config)? [v8.16.0 try http://www.rsyslog.com/e/2222 ]

The slave node (b9:e1) has the following logs..
2017-12-01 05:10:50 ERR ntpdate[24085]: the NTP socket is in use, exiting
2017-12-01 05:10:50 ERR ntpdate[23958]: the NTP socket is in use, exiting
2017-12-01 05:10:50 ERR ntpdate[23683]: the NTP socket is in use, exiting
2017-12-01 05:10:50 ERR ntpdate[23370]: the NTP socket is in use, exiting
2017-12-01 05:10:50 ERR ntpdate[23204]: the NTP socket is in use, exiting
2017-12-01 04:53:25 ERR ntpd[11534]: unable to bind to wildcard address :: - another process may be running - EXITING
2017-11-30 04:32:52 ERR ntpd[957]: unable to create socket on enp0s9 (9) for fe80::a00:27ff:fe78:5431%4#123
2017-11-30 04:32:52 ERR ntpd[957]: bind(28) AF_INET6 fe80::a00:27ff:fe78:5431%4#123 flags 0x11 failed: Cannot assign requested address
2017-11-30 04:22:33 ERR ntpd[955]: unable to bind to wildcard address :: - another process may be running - EXITING
2017-11-30 04:22:23 ERR kernel: [ 22.208106] intel_rapl: no valid rapl domains found in package 0
2017-11-30 04:22:22 ERR rsyslogd-2039: Could not open output pipe '/dev/xconsole':: No such file or directory [v8.16.0 try http://www.rsyslog.com/e/2039 ]
2017-11-30 04:22:22 ERR rsyslogd-2222: command 'KLogPermitNonKernelFacility' is currently not permitted - did you already set it via a RainerScript command (v6+ config)? [v8.16.0 try http://www.rsyslog.com/e/2222 ]

The slave node (c2:16) has the following logs..
2017-12-01 05:10:49 ERR ntpdate[23048]: the NTP socket is in use, exiting
2017-11-30 04:30:47 ERR ntpd[955]: unable to create socket on enp0s8 (7) for fe80::a00:27ff:fe46:6089%3#123
2017-11-30 04:30:47 ERR ntpd[955]: bind(26) AF_INET6 fe80::a00:27ff:fe46:6089%3#123 flags 0x11 failed: Cannot assign requested address
2017-11-30 04:22:27 ERR ntpd[957]: unable to bind to wildcard address :: - another process may be running - EXITING
2017-11-30 04:22:24 ERR ntpdate[711]: 91.189.89.199 rate limit response from server.
2017-11-30 04:22:16 ERR kernel: [ 24.726162] intel_rapl: no valid rapl domains found in package 0
2017-11-30 04:22:16 ERR rsyslogd-2039: Could not open output pipe '/dev/xconsole':: No such file or directory [v8.16.0 try http://www.rsyslog.com/e/2039 ]
2017-11-30 04:22:16 ERR rsyslogd-2222: command 'KLogPermitNonKernelFacility' is currently not permitted - did you already set it via a RainerScript command (v6+ config)? [v8.16.0 try http://www.rsyslog.com/e/2222 ]

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers