Galera agent doesn't work when grastate.dat contains safe_to_bootstrap

Bug #1702720 reported by Alejandro Comisario on 2017-07-06
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Fuel for OpenStack
Undecided
Unassigned

Bug Description

As advertised here :

https://github.com/ClusterLabs/resource-agents/issues/915

If you use a newer version of galera that uses the safe-to-bootstrap feature:

http://galeracluster.com/2016/11/introducing-the-safe-to-bootstrap-feature-in-galera-cluster/

The mysql-wss agent on https://github.com/openstack/fuel-library/blob/master/files/fuel-ha-utils/ocf/mysql-wss doesnt work if by any reason safe_to_bootstrap on grastate.dat is equal to 0.

Witch renders the agent kinda useless, could this be fixed ?

thanks

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers