fuel-qa-pylint test doesn't work

Bug #1690410 reported by Alexey Stupnikov on 2017-05-12
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Fuel for OpenStack
High
Alexey Stupnikov
Newton
High
Alexey Stupnikov

Bug Description

Tests are broken and couldn't finish successfully for empty commit. It looks like and issue with updated python packages.

The thing is that for some reason we install the packages explicitly (not from requirements.txt):
pylint installdeps: -r/home/jenkins/workspace/gate-fuel-qa-pylint-ubuntu-trusty/fuelweb_test/requirements-devops-source.txt, -r/home/jenkins/workspace/gate-fuel-qa-pylint-ubuntu-trusty/fuelweb_test/requirements.txt, mock>=1.2, pytest>=3.0, pytest-cov, pylint

Example review: https://review.openstack.org/#/c/464228/1

Alexey Stupnikov (astupnikov) wrote :
Changed in fuel:
status: Confirmed → In Progress
Alexey Stupnikov (astupnikov) wrote :
summary: - [9.0] fuel-qa-pylint tests doesn't work
+ fuel-qa-pylint tests doesn't work
summary: - fuel-qa-pylint tests doesn't work
+ fuel-qa-pylint test doesn't work

Reviewed: https://review.openstack.org/464600
Committed: https://git.openstack.org/cgit/openstack/fuel-qa/commit/?id=9643b3035737a261ab74d8a193134096b2d91396
Submitter: Jenkins
Branch: stable/newton

commit 9643b3035737a261ab74d8a193134096b2d91396
Author: Alexey Stupnikov <email address hidden>
Date: Fri May 12 18:49:55 2017 +0300

    Set maximum pylint version

    It turns out that pylint 1.7 introduced additional checks that
    are failing against fuel-qa code. It is reasonable to prevent
    new checks for stable branches and the best way to do so is to
    pin pylint version.

    Change-Id: Iae7506dacd93be9a76e1800ab3091dc715fb8ed5
    Closes-bug: #1690410

Reviewed: https://review.openstack.org/464228
Committed: https://git.openstack.org/cgit/openstack/fuel-qa/commit/?id=dcaa7b11a86dd79eac5e88884bdb7a06a380468a
Submitter: Jenkins
Branch: stable/mitaka

commit dcaa7b11a86dd79eac5e88884bdb7a06a380468a
Author: Alexey Stupnikov <email address hidden>
Date: Fri May 12 18:49:55 2017 +0300

    Set maximum pylint version

    It turns out that pylint 1.7 introduced additional checks that
    are failing against fuel-qa code. It is reasonable to prevent
    new checks for stable branches and the best way to do so is to
    pin pylint version.

    Change-Id: Iae7506dacd93be9a76e1800ab3091dc715fb8ed5
    Closes-bug: #1690410

tags: added: in-stable-mitaka
Changed in fuel:
status: In Progress → Fix Committed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers