fuel-plugin-external-zabbix fails to build

Bug #1688371 reported by James Hayner on 2017-05-04
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Fuel for OpenStack
High
Olivier Bourdon
StackLight
Low
Olivier Bourdon

Bug Description

Detailed bug description:
When I try to build the latest version of the plugin I receive this error:

2017-05-04 16:17:58 DEBUG 8739 (utils) + FILE=libmysqlclient18_5.5.54-0ubuntu0.14.04.1_amd64.deb
2017-05-04 16:17:58 DEBUG 8739 (utils) + wget -qO /root/plugins/fuel-plugin-external-zabbix/repositories/ubuntu/xenial/libmysqlclient18_5.5.54-0ubuntu0.14.04.1_amd64.deb http://archive.ubuntu.com/ubuntu/pool/main/m/mysql-5.5/libmysqlclient18_5.5.54-0ubuntu0.14.04.1_amd64.deb
2017-05-04 16:17:58 ERROR 8739 (cli) Shell command executed with "8" exit code: ./pre_build_hook
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/fuel_plugin_builder/cli.py", line 126, in main
    perform_action(args)
  File "/usr/lib/python2.7/site-packages/fuel_plugin_builder/cli.py", line 106, in perform_action
    actions.make_builder(args.build).run()
  File "/usr/lib/python2.7/site-packages/fuel_plugin_builder/actions/build.py", line 73, in run
    self.run_pre_build_hook()
  File "/usr/lib/python2.7/site-packages/fuel_plugin_builder/actions/build.py", line 86, in run_pre_build_hook
    utils.exec_cmd(self.pre_build_hook_cmd, self.plugin_path)
  File "/usr/lib/python2.7/site-packages/fuel_plugin_builder/utils.py", line 95, in exec_cmd
    'exit code: {1} '.format(exit_code, cmd))
Steps to reproduce:
1. Download latest version of plugin from master:
https://github.com/openstack/fuel-plugin-external-zabbix.git
2. Build it:
fpb --debug --build fuel-plugin-external-zabbix/

Expected results:
plugin builds successfully

Actual result:
it fails

Reproducability:
always

Workaround:
This is because the package libmysqlclient18_5.5.54-0ubuntu0.14.04.1_amd64.deb does not exist. When you update the package url to http://archive.ubuntu.com/ubuntu/pool/main/m/mysql-5.5/libmysqlclient18_5.5.55-0ubuntu0.14.04.1_i386.deb I get:

+ shift
+ '[' 0 -gt 0 ']'
+ http://archive.ubuntu.com/ubuntu/pool/main/m/mysql-5.5/libmysqlclient18_5.5.55-0ubuntu0.14.04.1_i386.deb http://archive.ubuntu.com/ubuntu/pool/main/libg/libgcrypt11/libgcrypt11_1.5.3-2ubuntu4.4_amd64.deb http://archive.ubuntu.com/ubuntu/pool/main/g/gnutls26/libgnutls26_2.12.23-12ubuntu2.7_amd64.deb http://archive.ubuntu.com/ubuntu/pool/main/s/systemd/libsystemd-daemon0_204-5ubuntu20.24_amd64.deb
./pre_build_hook: line 74: http://archive.ubuntu.com/ubuntu/pool/main/m/mysql-5.5/libmysqlclient18_5.5.55-0ubuntu0.14.04.1_i386.deb: No such file or directory

When you add the packages added in commit 5379a37 to a new variable and use it in the download_package function it works:

MISC_XENIAL_PACKAGES="http://archive.ubuntu.com/ubuntu/pool/main/m/mysql-5.5/libmysqlclient18_5.5.55-0ubuntu0.14.04.1_i386.deb \
                      http://archive.ubuntu.com/ubuntu/pool/main/libg/libgcrypt11/libgcrypt11_1.5.3-2ubuntu4.4_amd64.deb \
                      http://archive.ubuntu.com/ubuntu/pool/main/g/gnutls26/libgnutls26_2.12.23-12ubuntu2.7_amd64.deb \
                      http://archive.ubuntu.com/ubuntu/pool/main/s/systemd/libsystemd-daemon0_204-5ubuntu20.24_amd64.deb"

download_package "$DEB_XENIAL_REPO" $ZABBIX_PACKAGES \
             $PHP5_XENIAL_PACKAGES \
             $COMMON_PACKAGES \
             $MISC_XENIAL_PACKAGES

James Hayner (jhayner) on 2017-05-05
description: updated
Changed in fuel:
assignee: nobody → Fuel Plugin Zabbix (fuel-plugin-zabbix)
importance: Undecided → High
milestone: none → 12.0
status: New → Confirmed
Changed in lma-toolchain:
status: New → Triaged
importance: Undecided → Low
assignee: nobody → LMA-Toolchain Fuel Plugins (mos-lma-toolchain)
Changed in fuel:
status: Confirmed → Invalid

I makes no sense to replace a 64 bits package by a 32 bits one
Fix available
https://review.openstack.org/#/c/464153/

Changed in fuel:
assignee: Fuel Plugin Zabbix (fuel-plugin-zabbix) → Olivier Bourdon (olivierbourdon38)
status: Invalid → Fix Committed
Changed in lma-toolchain:
assignee: LMA-Toolchain Fuel Plugins (mos-lma-toolchain) → Olivier Bourdon (olivierbourdon38)
status: Triaged → Fix Released
Changed in fuel:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers