[Fuel Library] puppet4 syntax gate jobs are broken

Bug #1661200 reported by Nikita Karpin on 2017-02-02
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Fuel for OpenStack
Critical
Nikita Karpin
Mitaka
Critical
Nikita Karpin
Newton
Critical
Nikita Karpin
Nikita Karpin (mkarpin) on 2017-02-02
Changed in fuel:
milestone: none → 11.0
assignee: nobody → Nikita Karpin (mkarpin)
importance: Undecided → Critical
status: New → Confirmed

Fix proposed to branch: master
Review: https://review.openstack.org/428078

Changed in fuel:
status: Confirmed → In Progress

Reviewed: https://review.openstack.org/428078
Committed: https://git.openstack.org/cgit/openstack/fuel-library/commit/?id=49ee82dc151386f5d154e37d1c2f180b10dec7e8
Submitter: Jenkins
Branch: master

commit 49ee82dc151386f5d154e37d1c2f180b10dec7e8
Author: Mykyta Karpin <email address hidden>
Date: Thu Feb 2 12:32:50 2017 +0200

    Disable the deprecation warnings as errors for puppet-syntax

    Recently puppet4 started deprecating ruby 2.0
    with the following commit: https://github.com/puppetlabs/puppet/commit/e9eda7ed56fddcf185fc155d7e0ae054ea327504

    One way to work-around this (in the absence of a more recent ruby version) is to
    not treat this deprecation warnings as fatal when doing the puppet syntax check

    Change-Id: I8575064411ed54a29adb181375fc822a672ea6c3
    Closes-Bug: #1661200

Changed in fuel:
status: In Progress → Fix Committed

Reviewed: https://review.openstack.org/428231
Committed: https://git.openstack.org/cgit/openstack/fuel-library/commit/?id=af4d0aa90f0581a32449dc354917fd8d0448780a
Submitter: Jenkins
Branch: stable/mitaka

commit af4d0aa90f0581a32449dc354917fd8d0448780a
Author: Mykyta Karpin <email address hidden>
Date: Thu Feb 2 12:32:50 2017 +0200

    Disable the deprecation warnings as errors for puppet-syntax

    Recently puppet4 started deprecating ruby 2.0
    with the following commit: https://github.com/puppetlabs/puppet/commit/e9eda7ed56fddcf185fc155d7e0ae054ea327504

    One way to work-around this (in the absence of a more recent ruby version) is to
    not treat this deprecation warnings as fatal when doing the puppet syntax check

    Change-Id: I8575064411ed54a29adb181375fc822a672ea6c3
    Closes-Bug: #1661200
    (cherry picked from commit 49ee82dc151386f5d154e37d1c2f180b10dec7e8)

Reviewed: https://review.openstack.org/428229
Committed: https://git.openstack.org/cgit/openstack/fuel-library/commit/?id=21e6b1945d50ae06865d9cfa53d9e5fdf6c30bc2
Submitter: Jenkins
Branch: stable/newton

commit 21e6b1945d50ae06865d9cfa53d9e5fdf6c30bc2
Author: Mykyta Karpin <email address hidden>
Date: Thu Feb 2 12:32:50 2017 +0200

    Disable the deprecation warnings as errors for puppet-syntax

    Recently puppet4 started deprecating ruby 2.0
    with the following commit: https://github.com/puppetlabs/puppet/commit/e9eda7ed56fddcf185fc155d7e0ae054ea327504

    One way to work-around this (in the absence of a more recent ruby version) is to
    not treat this deprecation warnings as fatal when doing the puppet syntax check

    Change-Id: I8575064411ed54a29adb181375fc822a672ea6c3
    Closes-Bug: #1661200
    (cherry picked from commit 49ee82dc151386f5d154e37d1c2f180b10dec7e8)

This issue was fixed in the openstack/fuel-library 11.0.0.0rc1 release candidate.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers