[1.2.0][detach-murano] environment creation with default network has failed

Bug #1659293 reported by Ruslan Khozinov on 2017-01-25
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Fuel for OpenStack
Undecided
Ruslan Khozinov
fuel-plugin-murano
Undecided
Unassigned

Bug Description

Steps to reproduce:
1. Deploy an env with stacklight and murano plugins
2. Update Fuel up to 9.2 ( by mos-playbooks )
3. Update the env
4. Create an murano env with Environment Default Network=admin_internal_network (existing network)

Env description:

Fuel 9.2 #801:
 - controller
 - murano_node
 - compute + cinder
 - kibana + grafana

Actual result:

400 Bad Request: The server could not comply with the request since it is either malformed or otherwise incorrect. (HTTP 400)

Detailed bug description:

2017-01-25 12:44:16.463 20203 DEBUG murano.api.v1.environments [req-7d9378c4-8cb4-4bb2-aebb-a0c2e0e9d87c c7554c2d0153429f8cfa79ec12d50958 b3e1639e8b914c7ab823e964e5c46531 - - -] Environments:Create <Body {u'defaultNetworks': {u'environment': {u'internalSubnetworkName': u'fe33f598-dfe2-48fa-8e30-56509aeaf4c0', u'internalNetworkName': u'ba35d302-1b6a-48d2-b141-52f6e3112953', u'?': {u'type': u'io.murano.resources.ExistingNeutronNetwork', u'id': u'fd25ca7f11854839983ac9c9fdaa451f'}}, u'flat': None}, u'name': u'test'}> create /usr/lib/python2.7/dist-packages/murano/api/v1/environments.py:71
2017-01-25 12:44:16.464 20203 DEBUG murano.common.policy [req-7d9378c4-8cb4-4bb2-aebb-a0c2e0e9d87c c7554c2d0153429f8cfa79ec12d50958 b3e1639e8b914c7ab823e964e5c46531 - - -] Policy check succeeded for rule create_environment on target {} check /usr/lib/python2.7/dist-packages/murano/common/policy.py:84
2017-01-25 12:44:16.464 20203 ERROR murano.api.v1.request_statistics [req-7d9378c4-8cb4-4bb2-aebb-a0c2e0e9d87c c7554c2d0153429f8cfa79ec12d50958 b3e1639e8b914c7ab823e964e5c46531 - - -] API Environments method Create raised an exception
2017-01-25 12:44:16.464 20203 ERROR murano.api.v1.request_statistics Traceback (most recent call last):
2017-01-25 12:44:16.464 20203 ERROR murano.api.v1.request_statistics File "/usr/lib/python2.7/dist-packages/murano/api/v1/request_statistics.py", line 57, in wrap
2017-01-25 12:44:16.464 20203 ERROR murano.api.v1.request_statistics result = func(*args, **kwargs)
2017-01-25 12:44:16.464 20203 ERROR murano.api.v1.request_statistics File "/usr/lib/python2.7/dist-packages/murano/api/v1/environments.py", line 94, in create
2017-01-25 12:44:16.464 20203 ERROR murano.api.v1.request_statistics ks_client = auth_utils._create_keystone_admin_client(True)
2017-01-25 12:44:16.464 20203 ERROR murano.api.v1.request_statistics TypeError: _create_keystone_admin_client() takes no arguments (1 given)
2017-01-25 12:44:16.464 20203 ERROR murano.api.v1.request_statistics
2017-01-25 12:44:16.469 20203 DEBUG murano.api.v1.request_statistics [req-7d9378c4-8cb4-4bb2-aebb-a0c2e0e9d87c c7554c2d0153429f8cfa79ec12d50958 b3e1639e8b914c7ab823e964e5c46531 - - -] Updating count stats for Environments, Create on object <murano.api.v1.request_statistics.RequestStatisticsCollection object at 0x7fd948a79850> update_error_count /usr/lib/python2.7/dist-packages/murano/api/v1/request_statistics.py:84
2017-01-25 12:44:16.470 20203 ERROR murano.common.wsgi [req-7d9378c4-8cb4-4bb2-aebb-a0c2e0e9d87c c7554c2d0153429f8cfa79ec12d50958 b3e1639e8b914c7ab823e964e5c46531 - - -] Exception handling resource: _create_keystone_admin_client() takes no arguments (1 given)
2017-01-25 12:44:16.470 20203 ERROR murano.common.wsgi Traceback (most recent call last):
2017-01-25 12:44:16.470 20203 ERROR murano.common.wsgi File "/usr/lib/python2.7/dist-packages/murano/common/wsgi.py", line 441, in __call__
2017-01-25 12:44:16.470 20203 ERROR murano.common.wsgi action_result = self.execute_action(action, request, **action_args)
2017-01-25 12:44:16.470 20203 ERROR murano.common.wsgi File "/usr/lib/python2.7/dist-packages/murano/common/wsgi.py", line 456, in execute_action
2017-01-25 12:44:16.470 20203 ERROR murano.common.wsgi return self.dispatch(self.controller, action, request, **action_args)
2017-01-25 12:44:16.470 20203 ERROR murano.common.wsgi File "/usr/lib/python2.7/dist-packages/murano/common/wsgi.py", line 465, in dispatch
2017-01-25 12:44:16.470 20203 ERROR murano.common.wsgi return method(*args, **kwargs)
2017-01-25 12:44:16.470 20203 ERROR murano.common.wsgi File "/usr/lib/python2.7/dist-packages/murano/api/v1/request_statistics.py", line 57, in wrap
2017-01-25 12:44:16.470 20203 ERROR murano.common.wsgi result = func(*args, **kwargs)
2017-01-25 12:44:16.470 20203 ERROR murano.common.wsgi File "/usr/lib/python2.7/dist-packages/murano/api/v1/environments.py", line 94, in create
2017-01-25 12:44:16.470 20203 ERROR murano.common.wsgi ks_client = auth_utils._create_keystone_admin_client(True)
2017-01-25 12:44:16.470 20203 ERROR murano.common.wsgi TypeError: _create_keystone_admin_client() takes no arguments (1 given)
2017-01-25 12:44:16.470 20203 ERROR murano.common.wsgi

Changed in fuel-plugin-murano:
assignee: nobody → Ruslan Khozinov (rkhozinov)
assignee: Ruslan Khozinov (rkhozinov) → nobody
Changed in fuel:
milestone: none → 9.2
description: updated
description: updated
description: updated
description: updated
Ruslan Khozinov (rkhozinov) wrote :

It seems the issue is related to insufficient resources.
I've rechecked the issue again with doubled resources (ram, cpu) for compute nodes and an murano env created successfully, a murano application deployed properly.

So I think the issue is invalid.

Changed in fuel-plugin-murano:
status: New → Invalid
Changed in fuel:
status: New → Invalid
Changed in fuel-plugins:
status: New → Invalid
Ruslan Khozinov (rkhozinov) wrote :

Sorry, it's reproduced again on #822 (rc2) snapshot

Changed in fuel:
status: Invalid → New
Changed in fuel-plugin-murano:
status: Invalid → New
Changed in fuel-plugins:
status: Invalid → New
no longer affects: fuel-plugins
Oleksiy Molchanov (omolchanov) wrote :

Please provide full diagnostic snapshot or env with reproduce to debug.

Changed in fuel:
assignee: nobody → Ruslan Khozinov (rkhozinov)
status: New → Incomplete
Changed in fuel-plugin-murano:
status: New → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers