Fuel-agent does not create partition with fs without mountpoint

Bug #1650622 reported by Evgeniy L on 2016-12-16
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Fuel for OpenStack
High
Evgeniy L
Mitaka
High
Evgeniy L
Newton
High
Evgeniy L

Bug Description

Detailed bug description:
 Fuel-agent does not create partition with file system if mountpoint is not specified, it may be mandatory in same cases such as swift installation.
Steps to reproduce:
 Add new partition for a role with `file_system: xfs` and `mountpoint: none`.
Expected results:
 Partition is created with fs.
Actual result:
 Partition is not created.
Reproducibility:
 100%
Workaround:
 Do partitioning on deployment stage (with tasks).
Impact:
 Many users who add new roles with plugins, e.g. swift plugin.
Description of the environment:
 All versions of Fuel since image based provisioning was introduced.

Reviewed: https://review.openstack.org/411915
Committed: https://git.openstack.org/cgit/openstack/fuel-agent/commit/?id=d9f9f377e4c281fbbb070dda36952938e9dfa825
Submitter: Jenkins
Branch: master

commit d9f9f377e4c281fbbb070dda36952938e9dfa825
Author: Evgeny L <email address hidden>
Date: Fri Dec 16 16:50:27 2016 +0000

    Allow fs creation if mountpoint is not specified

    Such services as Swift-storage require partition with file
    system without mountpoints, currently fuel-agent prevents
    to do that.

    Change-Id: Id9e90f81098de3736e0d9b1ca82e434122efd4e8
    Closes-bug: #1650622

Changed in fuel:
status: In Progress → Fix Committed
Dmitry Pyzhov (dpyzhov) on 2016-12-20
Changed in fuel:
milestone: 9.2 → 11.0

Reviewed: https://review.openstack.org/413191
Committed: https://git.openstack.org/cgit/openstack/fuel-agent/commit/?id=8c1b78368d708145b3877cc8a8d4753e67a8e08e
Submitter: Jenkins
Branch: stable/mitaka

commit 8c1b78368d708145b3877cc8a8d4753e67a8e08e
Author: Evgeny L <email address hidden>
Date: Fri Dec 16 16:50:27 2016 +0000

    Allow fs creation if mountpoint is not specified

    Such services as Swift-storage require partition with file
    system without mountpoints, currently fuel-agent prevents
    to do that.

    Change-Id: Id9e90f81098de3736e0d9b1ca82e434122efd4e8
    Closes-bug: #1650622

Reviewed: https://review.openstack.org/413172
Committed: https://git.openstack.org/cgit/openstack/fuel-agent/commit/?id=08d578a81eeb84aa7d38344b2673c5e64c8bfa43
Submitter: Jenkins
Branch: stable/newton

commit 08d578a81eeb84aa7d38344b2673c5e64c8bfa43
Author: Evgeny L <email address hidden>
Date: Fri Dec 16 16:50:27 2016 +0000

    Allow fs creation if mountpoint is not specified

    Such services as Swift-storage require partition with file
    system without mountpoints, currently fuel-agent prevents
    to do that.

    Change-Id: Id9e90f81098de3736e0d9b1ca82e434122efd4e8
    Closes-bug: #1650622
    (cherry picked from commit d9f9f377e4c281fbbb070dda36952938e9dfa825)

tags: added: on-verification
TatyanaGladysheva (tgladysheva) wrote :

As per information from Evgeniy L, for verification of this bug needs to build your own plugin with such partition: `file_system: xfs` and `mountpoint: none`. We don't know how to create such plugin therefore we can not verify this bug.

tags: removed: on-verification
Nastya Urlapova (aurlapova) wrote :

Moved to "Fix released" due to Tatyana's comment, if you find plugin or way for verification, please ping me.

This issue was fixed in the openstack/fuel-agent 11.0.0.0rc1 release candidate.

Vladimir Khlyunev (vkhlyunev) wrote :

There is still no plugin that can help test this fix. Marking as "released" but please notify us if there is smth new

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers