Installation of example plugin failed on task setup_repositories

Bug #1650551 reported by Nastya Urlapova on 2016-12-16
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Fuel for OpenStack
High
Georgy Kibardin
Mitaka
High
Georgy Kibardin

Bug Description

Installation of example plugin failed with error:
Deployment has failed. All nodes are finished. Failed tasks: Task[plugins_setup_repositories/1], Task[plugins_setup_repositories/3], Task[plugins_setup_repositories/2] Stopping the deployment process!

Scenario:
        1. Upload plugin to the master node
        2. Install plugin
        3. Create cluster
        4. Add 1 node with controller role
        5. Add 2 nodes with compute role
        >>>> 6. Deploy the cluster <<< Failed here
        7. Run network verification
        8. Check plugin health
        9. Run OSTF

Version: 9.x.snapshot #638

Nastya Urlapova (aurlapova) wrote :
tags: added: swarm-blocker
Nastya Urlapova (aurlapova) wrote :
description: updated
Changed in fuel:
milestone: none → 10.1
status: New → Confirmed
Changed in fuel:
assignee: Fuel Sustaining (fuel-sustaining-team) → Georgy Kibardin (gkibardin)
Georgy Kibardin (gkibardin) wrote :

This change has broken the test https://review.openstack.org/#/c/373230. Plugins of v1 have no Release file in their ubuntu repo directory.

tags: added: area-library
Changed in fuel:
assignee: Georgy Kibardin (gkibardin) → Vladimir Kuklin (vkuklin)
Georgy Kibardin (gkibardin) wrote :

In case you decide to fix plugin package generation here is the code which needs to be moved to the base class https://github.com/openstack/fuel-plugins/blob/master/fuel_plugin_builder/actions/build.py#L231
However, I would first figured out why it has been done this way in the first place.

Vladimir Kuklin (vkuklin) wrote :

There cannot be any good reason to generate broken Ubuntu repositories. If a plugin provides repositories, those repositories MUST be valid.

Changed in fuel:
status: Confirmed → Invalid
Changed in fuel:
assignee: Vladimir Kuklin (vkuklin) → Georgy Kibardin (gkibardin)
status: Invalid → In Progress
status: In Progress → Invalid

Fix proposed to branch: master
Review: https://review.openstack.org/415677

Changed in fuel:
status: Invalid → In Progress

Reviewed: https://review.openstack.org/415677
Committed: https://git.openstack.org/cgit/openstack/fuel-plugins/commit/?id=57476f32d3cc436dcd32d2ec0215aca371870cb0
Submitter: Jenkins
Branch: master

commit 57476f32d3cc436dcd32d2ec0215aca371870cb0
Author: Georgy Kibardin <email address hidden>
Date: Thu Dec 29 14:34:41 2016 +0300

    Make ubuntu repo similar for all plugin versions

    Release file began to present in a plugin ubuntu repository only since
    version 2. This now conflicts with our new repo pinning code which
    expects Release file to be in place.

    Related-Bug: #1650551

    Change-Id: I09b956555c3a6ab0944216d866739fb7f6dc66a0

Alexey Shtokolov (ashtokolov) wrote :

Remove swarm-blocker tag due to the fix for freshly built plugins was merged and it unlocked Swarm testing

tags: removed: swarm-blocker
Changed in fuel:
status: In Progress → Fix Committed
tags: added: on-verification

Verified on 9.2 snapshot #724.

Latest runs #171, #172 with fix are passed:
https://product-ci.infra.mirantis.net/job/9.x.system_test.ubuntu.plugins.fuel_plugin_example/171/

tags: removed: on-verification
Georgy Kibardin (gkibardin) wrote :

Dmitry, have you bumped the tag from which the plugin builder is checked out?

Georgy Kibardin (gkibardin) wrote :

Guys, how can I ensure correct version of fuel-plugin-builder is used. There is nothing in logs about that.

Changed in fuel:
status: Confirmed → Incomplete
Nastya Urlapova (aurlapova) wrote :

@Georgy, please use link to job comment #13 and revert env for investigation, it is absolutely normal workflow for developers.

Changed in fuel:
status: Incomplete → Confirmed
Georgy Kibardin (gkibardin) wrote :

@Nastya, reverting env doesn't help - the plugin is built somewhere else, not on env nodes.

Georgy Kibardin (gkibardin) wrote :

https://product-ci.infra.mirantis.net/job/9.x.system_test.ubuntu.plugins.fuel_plugin_example
 doesn't fail anymore, while 10.0 does. This makes me think plugin builder is checked out from the wrong tag.

Changed in fuel:
assignee: Georgy Kibardin (gkibardin) → Fuel QA Team (fuel-qa)
Nastya Urlapova (aurlapova) wrote :

@Georgiy, if you would open job console, you can find there:
EXAMPLE_PLUGIN_URL=https://product-ci.infra.mirantis.net/job/10.0.build-fuel-plugins/lastSuccessfulBuild/artifact/built_plugins/fuel_plugin_example-1.0.0.fp
EXAMPLE_PLUGIN_V3_URL=https://product-ci.infra.mirantis.net/job/10.0.build-fuel-plugins/lastSuccessfulBuild/artifact/built_plugins/fuel_plugin_example_v3-3.0-3.0.0-1.noarch.rpm
EXAMPLE_PLUGIN_V4_URL=https://product-ci.infra.mirantis.net/job/10.0.build-fuel-plugins/lastSuccessfulBuild/artifact/built_plugins/fuel_plugin_example_v4_hotpluggable-4.0-4.0.0-1.noarch.rpm
SEPARATE_SERVICE_DB_PLUGIN_URL=https://product-ci.infra.mirantis.net/job/10.0.build-fuel-plugins/lastSuccessfulBuild/artifact/built_plugins/detach-database-1.1-1.1.0-1.noarch.rpm
SEPARATE_SERVICE_RABBIT_PLUGIN_URL=https://product-ci.infra.mirantis.net/job/10.0.build-fuel-plugins/lastSuccessfulBuild/artifact/built_plugins/detach-rabbitmq-1.1-1.1.2-1.noarch.rpm
SEPARATE_SERVICE_KEYSTONE_PLUGIN_URL=https://product-ci.infra.mirantis.net/job/10.0.build-fuel-plugins/lastSuccessfulBuild/artifact/built_plugins/detach-keystone-1.0-1.0.2-1.noarch.rpm
SEPARATE_SERVICE_HAPROXY_PLUGIN_URL=https://product-ci.infra.mirantis.net/job/10.0.build-fuel-plugins/lastSuccessfulBuild/artifact/built_plugins/detach_haproxy-2.0-2.0.0-1.noarch.rpm
SEPARATE_SERVICE_BALANCER_PLUGIN_URL=https://product-ci.infra.mirantis.net/job/10.0.build-fuel-plugins/lastSuccessfulBuild/artifact/built_plugins/external_loadbalancer-2.0-2.0.0-1.noarch.rpm

so these jobs build our plugins.

Changed in fuel:
assignee: Fuel QA Team (fuel-qa) → Georgy Kibardin (gkibardin)
Georgy Kibardin (gkibardin) wrote :

https://product-ci.infra.mirantis.net/job/10.0.build-fuel-plugins/

This job succeeded just yesterday - before that it has been failing for more than a month.

Changed in fuel:
status: Confirmed → Fix Committed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers