Horizon renders improperly when deployed with MOS9 on Ubuntu+UCA 14.04

Bug #1632131 reported by Matthew Roark on 2016-10-10
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Fuel for OpenStack
High
Fuel Sustaining
Mirantis OpenStack
High
Anton Chevychalov

Bug Description

Detailed bug description:
 By default, the following package is installed for Horizon when deploying MOS9 w/ Mitaka on Ubuntu+UCA 14.04. For MOS 9 downstream we should disable UCA as it's not commercially supported by Mirantis.

# dpkg -l | grep horizon
ii python-django-horizon 2:9.1.0-0ubuntu1~cloud0 all Django module providing web based interaction with OpenStack

This causes Horizon to render its UI improperly (e.g. it appears as if the CSS/JS isn't loaded).

Steps to reproduce:
 - Deploy Mirantis OpenStack 9.0 w/ Mitaka on Ubuntu+UCA 14.04.
 - Access Horizon, and you will see that it appears to be "broken".
Expected results:
 Disable ability to use UCA from the UI in downstream MOS 9.x.

 In upstream the package that should be installed is python-django-horizon_9.0.1-2~u14.04+mos22_all.deb or the installed package should be compatible w/ other MOS packages.

Actual result:
 python-django-horizon_9.1.0-0ubuntu1~cloud0_all.deb is installed, causing the UI to break.
Reproducibility:
 - This occurs on every deployment w/ the UCA option selected.
Workaround:
 - Set the UCA repository to a lower priority than that of the MOS repos, in order to install the appropriate python-django-horizon package.
Impact:
 Horizon becomes difficult to utilize, none of the CSS appears to be loaded.
Description of the environment:
- Operation system: Ubuntu 14.04.5 LTS
- Versions of components: Mirantis OpenStack 9.0
- Reference architecture: 1 controller, 2 compute (3 nodes) on KVM.
- Network model: Neutron with VLAN segmentation
Additional information:
 N/A

Matthew Roark (mroark) wrote :

Here's a screenshot of the broken UI, for reference.

tags: added: customer-found
Vitaly Sedelnik (vsedelnik) wrote :

MOS 9.0 doesn't support Ubuntu 14.04+UCA, so setting to Invalid in MOS project.

Changed in mos:
status: New → Invalid
Matthew Roark (mroark) wrote :

@vsedelnik How do you mean it's not supported? It's an option when deploying with Fuel. If we don't support it, I don't see why we'd include it as an option.

Changed in mos:
status: Invalid → New
Vitaly Sedelnik (vsedelnik) wrote :

I double checked with product management, below is the official statement about UCA support:

Mirantis provides Ubuntu UCA support as part of our upstream community strategy. The UCA packages differ significantly from time to time and are not controlled by Mirantis, so Mirantis can't make promises about the stability of those packages. As a result we do not provide support for UCA packages. All Mirantis paid support customers should use the Mirantis OpenStack packages which we control and to which we can provide Maintenance Updates.

So I am confirming this bug for MOS 9.2, an option to deploy UCA packages should be disabled.
Nominating for Fuel project to fix the issue in upstream.

Changed in fuel:
status: New → Confirmed
Changed in mos:
status: New → Confirmed
Changed in fuel:
importance: Undecided → High
Changed in mos:
importance: Undecided → High
Changed in fuel:
assignee: nobody → Fuel Sustaining (fuel-sustaining-team)
Changed in mos:
assignee: nobody → Fuel Sustaining (fuel-sustaining-team)
milestone: none → 9.2
Changed in fuel:
milestone: none → 10.0
Sam Stoelinga (sammiestoel) wrote :

I've updated description to state that expected result for MOS 9.x is to disable UCA packages in UI.

description: updated
description: updated
description: updated
tags: added: low-hanging-fruit
Changed in mos:
assignee: Fuel Sustaining (fuel-sustaining-team) → Anton Chevychalov (achevychalov)
Changed in mos:
status: Confirmed → In Progress

Change abandoned by Anton Chevychalov (<email address hidden>) on branch: stable/mitaka
Review: https://review.openstack.org/391887
Reason: Have to be done in downstream

Fix proposed to branch: stable/mitaka
Change author: Anton Chevychalov <email address hidden>
Review: https://review.fuel-infra.org/28121

Changed in fuel:
status: Confirmed → In Progress
Changed in fuel:
assignee: Fuel Sustaining (fuel-sustaining-team) → Anton Chevychalov (achevychalov)

Change abandoned by Anton Chevychalov <email address hidden> on branch: stable/mitaka
Review: https://review.fuel-infra.org/28121
Reason: After conversation with core developers we move that change to update tool.

UCA had been disabled in MOS 9.2 via upgrade tool. https://github.com/aepifanov/mos_mu/commit/e71a0342e034af8dae4bbb4e8cf02ac0448015cb

And merged to mos-playbooks packet https://review.fuel-infra.org/#/c/29775/

Changed in mos:
status: In Progress → Won't Fix

Won't Fix in MOS 9 because we are not supporting UCA anymore.

Vitaly Sedelnik (vsedelnik) wrote :

Reassigned to Fuel team to make sure UCA support is disabled in MOS 10

Changed in fuel:
status: In Progress → Confirmed
assignee: Anton Chevychalov (achevychalov) → Fuel Sustaining (fuel-sustaining-team)
Changed in mos:
status: Won't Fix → Fix Committed
tags: added: on-verification
Ekaterina Shutova (eshutova) wrote :

Verified on 9.2 snapshot #750. No possibility to select Mitaka on Ubuntu+UCA 14.04 in UI anymore.

tags: removed: on-verification
Changed in mos:
status: Fix Committed → Fix Released

Related fix proposed to branch: master
Change author: Vladimir Khlyunev <email address hidden>
Review: https://review.fuel-infra.org/29913

Changed in fuel:
status: Confirmed → In Progress

Reviewed: https://review.fuel-infra.org/29913
Submitter: Dmitry Kaigarodsev <email address hidden>
Branch: master

Commit: 441946d4adad4b4794f803b606a12e5301e757a7
Author: Vladimir Khlyunev <email address hidden>
Date: Wed Jan 18 09:18:00 2017

[prod-ci] Disable UCA thread for 9.x acceptance

Related-bug:1632131
Change-Id: I85261d2737181baa785fe4864bcf1d5d721f9d4e

Reviewed: https://review.openstack.org/421762
Committed: https://git.openstack.org/cgit/openstack/fuel-qa/commit/?id=0a9da6142bb64074f05c8e2cfcae484b2b158bdb
Submitter: Jenkins
Branch: stable/mitaka

commit 0a9da6142bb64074f05c8e2cfcae484b2b158bdb
Author: Vladimir Khlyunev <email address hidden>
Date: Wed Jan 18 13:21:31 2017 +0400

    Disable UCA tests

    Starting from 9.2 its impossible to deploy openstack from UCA
    properly. Its time to disable it.

    Change-Id: I3e67d823b8a699fb65ebf4ca6276a578aef547d4
    Related-bug:1632131

tags: added: in-stable-mitaka
Dmitry Pyzhov (dpyzhov) on 2017-02-03
Changed in fuel:
milestone: 10.0 → 10.1
Dmitry Pyzhov (dpyzhov) on 2017-02-14
Changed in fuel:
status: In Progress → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers