Glance installation not successful when deploying OPNFV-Brahmaputra by FUEL-8.0

Bug #1625554 reported by ck tsai on 2016-09-20
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Fuel for OpenStack
Undecided
Fuel Sustaining

Bug Description

Error installing Glance when deploying opnfv by FUEL-8.0.

There I established 3 nodes:
  Fuel Master Node
  1 Control Node
  1 Compute Node

These nodes are all virtual machines which created in VMWare Workstation 12.
For Fuel Master Node there is a NAT environment: 10.20.0.0/24.
And for both Control & Compute Node there are 2 NAT environments connected: 10.20.0.0/24 & 172.16.0.0/24.

I have executed
1. fuel-createmirror
2. fuel-bootstrap build --activate
before creating a OPNFV environment.

Deployment stops at "Installing Openstack 100%" stage, astute log with err level is as following:
---------------------------------------------------------------------------------------------------
2016-09-20 09:23:53 ERROR [14094] Error running RPC method granular_deploy: Deployment failed on nodes 6, trace:
["/usr/share/gems/gems/astute-8.0.0/lib/astute/deployment_engine.rb:68:in `block (3 levels) in deploy'",
 "/usr/share/gems/gems/astute-8.0.0/lib/astute/deployment_engine.rb:51:in `each_slice'",
 "/usr/share/gems/gems/astute-8.0.0/lib/astute/deployment_engine.rb:51:in `block (2 levels) in deploy'",
 "/usr/share/gems/gems/astute-8.0.0/lib/astute/deployment_engine.rb:49:in `each'",
 "/usr/share/gems/gems/astute-8.0.0/lib/astute/deployment_engine.rb:49:in `block in deploy'",
 "/usr/share/gems/gems/astute-8.0.0/lib/astute/deployment_engine.rb:45:in `each'",
 "/usr/share/gems/gems/astute-8.0.0/lib/astute/deployment_engine.rb:45:in `deploy'",
 "/usr/share/gems/gems/astute-8.0.0/lib/astute/orchestrator.rb:216:in `deploy_cluster'",
 "/usr/share/gems/gems/astute-8.0.0/lib/astute/orchestrator.rb:52:in `granular_deploy'",
 "/usr/share/gems/gems/astute-8.0.0/lib/astute/server/dispatcher.rb:92:in `granular_deploy'",
 "/usr/share/gems/gems/astute-8.0.0/lib/astute/server/server.rb:189:in `dispatch_message'",
 "/usr/share/gems/gems/astute-8.0.0/lib/astute/server/server.rb:146:in `block in dispatch'",
 "/usr/share/gems/gems/astute-8.0.0/lib/astute/server/task_queue.rb:64:in `call'",
 "/usr/share/gems/gems/astute-8.0.0/lib/astute/server/task_queue.rb:64:in `block in each'",
 "/usr/share/gems/gems/astute-8.0.0/lib/astute/server/task_queue.rb:56:in `each'",
 "/usr/share/gems/gems/astute-8.0.0/lib/astute/server/task_queue.rb:56:in `each'",
 "/usr/share/gems/gems/astute-8.0.0/lib/astute/server/server.rb:144:in `each_with_index'",
 "/usr/share/gems/gems/astute-8.0.0/lib/astute/server/server.rb:144:in `dispatch'",
 "/usr/share/gems/gems/astute-8.0.0/lib/astute/server/server.rb:123:in `block in perform_main_job'"]
2016-09-20 09:23:53 ERROR [14094] No more tasks will be executed on the node 6
2016-09-20 09:23:53 ERROR [14094] Task '{"priority"=>5200, "type"=>"puppet", "id"=>"glance", "parameters"=>{"puppet_modules"=>"/etc/puppet/modules", "puppet_manifest"=>"/etc/puppet/modules/osnailyfacter/modular/glance/glance.pp", "timeout"=>3600, "cwd"=>"/"}, "uids"=>["6"]}' failed on node 6
---------------------------------------------------------------------------------------------------

And puppet log with err level is as following:
---------------------------------------------------------------------------------------------------
2016-09-20 09:23:51 ERR (/Stage[main]/Glance::Api/Package[glance-api]/ensure) E: There are problems and -y was used without --force-yes
2016-09-20 09:23:51 ERR (/Stage[main]/Glance::Api/Package[glance-api]/ensure) After this operation, 133 MB of additional disk space will be used.
2016-09-20 09:23:51 ERR (/Stage[main]/Glance::Api/Package[glance-api]/ensure) Need to get 32.0 MB of archives.
2016-09-20 09:23:51 ERR (/Stage[main]/Glance::Api/Package[glance-api]/ensure) 0 upgraded, 99 newly installed, 1 downgraded, 0 to remove and 5 not upgraded.
2016-09-20 09:23:51 ERR (/Stage[main]/Glance::Api/Package[glance-api]/ensure) libxml2
2016-09-20 09:23:51 ERR (/Stage[main]/Glance::Api/Package[glance-api]/ensure) The following packages will be DOWNGRADED:
2016-09-20 09:23:51 ERR (/Stage[main]/Glance::Api/Package[glance-api]/ensure) python-swiftclient python-taskflow python-tk python-wsme python-xattr
2016-09-20 09:23:51 ERR (/Stage[main]/Glance::Api/Package[glance-api]/ensure) python-semantic-version python-simplegeneric python-support
2016-09-20 09:23:51 ERR (/Stage[main]/Glance::Api/Package[glance-api]/ensure) python-pygraphviz python-pymongo python-pymongo-ext python-scipy
2016-09-20 09:23:51 ERR (/Stage[main]/Glance::Api/Package[glance-api]/ensure) python-networkx python-numpy python-osprofiler python-psycopg2
2016-09-20 09:23:51 ERR (/Stage[main]/Glance::Api/Package[glance-api]/ensure) python-ipaddr python-kazoo python-matplotlib python-matplotlib-data
2016-09-20 09:23:51 ERR (/Stage[main]/Glance::Api/Package[glance-api]/ensure) python-glance-store python-gridfs python-gtk2 python-httplib2 python-imaging
2016-09-20 09:23:51 ERR (/Stage[main]/Glance::Api/Package[glance-api]/ensure) python-egenix-mxdatetime python-egenix-mxtools python-glade2 python-glance
2016-09-20 09:23:51 ERR (/Stage[main]/Glance::Api/Package[glance-api]/ensure) python-bson python-bson-ext python-cairo python-castellan
2016-09-20 09:23:51 ERR (/Stage[main]/Glance::Api/Package[glance-api]/ensure) libxpm4 libxrandr2 libxslt1-dev libxss1 libxt6 python-automaton python-boto
2016-09-20 09:23:51 ERR (/Stage[main]/Glance::Api/Package[glance-api]/ensure) libxcursor1 libxdamage1 libxfixes3 libxft2 libxinerama1 libxml2-dev libxmu6
2016-09-20 09:23:51 ERR (/Stage[main]/Glance::Api/Package[glance-api]/ensure) libumfpack5.6.2 libvpx1 libxaw7 libxcb-render0 libxcb-shm0 libxcomposite1
2016-09-20 09:23:51 ERR (/Stage[main]/Glance::Api/Package[glance-api]/ensure) libpixman-1-0 libpq5 libsm6 libtcl8.6 libthai-data libthai0 libtk8.6
2016-09-20 09:23:51 ERR (/Stage[main]/Glance::Api/Package[glance-api]/ensure) liblapack3 libpango-1.0-0 libpangocairo-1.0-0 libpangoft2-1.0-0 libpathplan4
2016-09-20 09:23:51 ERR (/Stage[main]/Glance::Api/Package[glance-api]/ensure) libgtk2.0-common libgvc6 libgvpr2 libharfbuzz0b libice6 libjasper1
2016-09-20 09:23:51 ERR (/Stage[main]/Glance::Api/Package[glance-api]/ensure) libgfortran3 libglade2-0 libgraphite2-3 libgtk2.0-0 libgtk2.0-bin
2016-09-20 09:23:51 ERR (/Stage[main]/Glance::Api/Package[glance-api]/ensure) libcolamd2.8.0 libdatrie1 libgd3 libgdk-pixbuf2.0-0 libgdk-pixbuf2.0-common
2016-09-20 09:23:51 ERR (/Stage[main]/Glance::Api/Package[glance-api]/ensure) libcamd2.3.1 libccolamd2.8.0 libcdt5 libcgraph6 libcholmod2.1.2
2016-09-20 09:23:51 ERR (/Stage[main]/Glance::Api/Package[glance-api]/ensure) hicolor-icon-theme libamd2.3.1 libatk1.0-0 libatk1.0-data libblas3 libcairo2
2016-09-20 09:23:51 ERR (/Stage[main]/Glance::Api/Package[glance-api]/ensure) blt fontconfig fonts-liberation fonts-lyx glance-api glance-common graphviz
2016-09-20 09:23:51 ERR (/Stage[main]/Glance::Api/Package[glance-api]/ensure) The following NEW packages will be installed:
2016-09-20 09:23:51 ERR (/Stage[main]/Glance::Api/Package[glance-api]/ensure) python-tk-dbg
2016-09-20 09:23:51 ERR (/Stage[main]/Glance::Api/Package[glance-api]/ensure) python-psycopg2-doc python-pymongo-doc python-semantic-version-doc tix
2016-09-20 09:23:51 ERR (/Stage[main]/Glance::Api/Package[glance-api]/ensure) ttf-staypuft gfortran python-dev python-numpy-dbg python-numpy-doc
2016-09-20 09:23:51 ERR (/Stage[main]/Glance::Api/Package[glance-api]/ensure) python-traits python-wxgtk2.8 texlive-extra-utils texlive-latex-extra
2016-09-20 09:23:51 ERR (/Stage[main]/Glance::Api/Package[glance-api]/ensure) python-matplotlib-doc python-nose python-qt4 python-sip python-tornado
2016-09-20 09:23:51 ERR (/Stage[main]/Glance::Api/Package[glance-api]/ensure) gir1.2-gtk-3.0 ghostscript inkscape ipython python-excelerator
2016-09-20 09:23:51 ERR (/Stage[main]/Glance::Api/Package[glance-api]/ensure) python-egenix-mxtools-doc python-gtk2-doc python-kazoo-doc dvipng
2016-09-20 09:23:51 ERR (/Stage[main]/Glance::Api/Package[glance-api]/ensure) python-egenix-mxdatetime-doc python-egenix-mxtools-dbg
2016-09-20 09:23:51 ERR (/Stage[main]/Glance::Api/Package[glance-api]/ensure) python-automaton-doc python-castellan-doc python-egenix-mxdatetime-dbg
2016-09-20 09:23:51 ERR (/Stage[main]/Glance::Api/Package[glance-api]/ensure) ttf-arphic-gkai00mp ttf-arphic-bkai00mp tcl8.6 tk8.6 pkg-config
2016-09-20 09:23:51 ERR (/Stage[main]/Glance::Api/Package[glance-api]/ensure) libjasper-runtime ttf-baekmuk ttf-arphic-gbsn00lp ttf-arphic-bsmi00lp
2016-09-20 09:23:51 ERR (/Stage[main]/Glance::Api/Package[glance-api]/ensure) blt-demo gsfonts graphviz-doc libgd-tools librsvg2-common gvfs
2016-09-20 09:23:51 ERR (/Stage[main]/Glance::Api/Package[glance-api]/ensure) Suggested packages:
2016-09-20 09:23:51 ERR (/Stage[main]/Glance::Api/Package[glance-api]/ensure) python-swiftclient python-taskflow python-tk python-wsme python-xattr
2016-09-20 09:23:51 ERR (/Stage[main]/Glance::Api/Package[glance-api]/ensure) python-semantic-version python-simplegeneric python-support
2016-09-20 09:23:51 ERR (/Stage[main]/Glance::Api/Package[glance-api]/ensure) python-pygraphviz python-pymongo python-pymongo-ext python-scipy
2016-09-20 09:23:51 ERR (/Stage[main]/Glance::Api/Package[glance-api]/ensure) python-networkx python-numpy python-osprofiler python-psycopg2
2016-09-20 09:23:51 ERR (/Stage[main]/Glance::Api/Package[glance-api]/ensure) python-ipaddr python-kazoo python-matplotlib python-matplotlib-data
2016-09-20 09:23:51 ERR (/Stage[main]/Glance::Api/Package[glance-api]/ensure) python-glance-store python-gridfs python-gtk2 python-httplib2 python-imaging
2016-09-20 09:23:51 ERR (/Stage[main]/Glance::Api/Package[glance-api]/ensure) python-egenix-mxdatetime python-egenix-mxtools python-glade2 python-glance
2016-09-20 09:23:51 ERR (/Stage[main]/Glance::Api/Package[glance-api]/ensure) python-boto python-bson python-bson-ext python-cairo python-castellan
2016-09-20 09:23:51 ERR (/Stage[main]/Glance::Api/Package[glance-api]/ensure) libxmu6 libxpm4 libxrandr2 libxslt1-dev libxss1 libxt6 python-automaton
2016-09-20 09:23:51 ERR (/Stage[main]/Glance::Api/Package[glance-api]/ensure) libxcursor1 libxdamage1 libxfixes3 libxft2 libxinerama1 libxml2 libxml2-dev
2016-09-20 09:23:51 ERR (/Stage[main]/Glance::Api/Package[glance-api]/ensure) libumfpack5.6.2 libvpx1 libxaw7 libxcb-render0 libxcb-shm0 libxcomposite1
2016-09-20 09:23:51 ERR (/Stage[main]/Glance::Api/Package[glance-api]/ensure) libpixman-1-0 libpq5 libsm6 libtcl8.6 libthai-data libthai0 libtk8.6
2016-09-20 09:23:51 ERR (/Stage[main]/Glance::Api/Package[glance-api]/ensure) liblapack3 libpango-1.0-0 libpangocairo-1.0-0 libpangoft2-1.0-0 libpathplan4
2016-09-20 09:23:51 ERR (/Stage[main]/Glance::Api/Package[glance-api]/ensure) libgtk2.0-common libgvc6 libgvpr2 libharfbuzz0b libice6 libjasper1
2016-09-20 09:23:51 ERR (/Stage[main]/Glance::Api/Package[glance-api]/ensure) libgfortran3 libglade2-0 libgraphite2-3 libgtk2.0-0 libgtk2.0-bin
2016-09-20 09:23:51 ERR (/Stage[main]/Glance::Api/Package[glance-api]/ensure) libcolamd2.8.0 libdatrie1 libgd3 libgdk-pixbuf2.0-0 libgdk-pixbuf2.0-common
2016-09-20 09:23:51 ERR (/Stage[main]/Glance::Api/Package[glance-api]/ensure) libcamd2.3.1 libccolamd2.8.0 libcdt5 libcgraph6 libcholmod2.1.2
2016-09-20 09:23:51 ERR (/Stage[main]/Glance::Api/Package[glance-api]/ensure) hicolor-icon-theme libamd2.3.1 libatk1.0-0 libatk1.0-data libblas3 libcairo2
2016-09-20 09:23:51 ERR (/Stage[main]/Glance::Api/Package[glance-api]/ensure) blt fontconfig fonts-liberation fonts-lyx glance-common graphviz
2016-09-20 09:23:51 ERR (/Stage[main]/Glance::Api/Package[glance-api]/ensure) The following extra packages will be installed:
2016-09-20 09:23:51 ERR (/Stage[main]/Glance::Api/Package[glance-api]/ensure) Use 'apt-get autoremove' to remove them.
2016-09-20 09:23:51 ERR (/Stage[main]/Glance::Api/Package[glance-api]/ensure) python3-software-properties software-properties-common unattended-upgrades
2016-09-20 09:23:51 ERR (/Stage[main]/Glance::Api/Package[glance-api]/ensure) cloud-guest-utils eatmydata python-oauth python-serial python3-pycurl
2016-09-20 09:23:51 ERR (/Stage[main]/Glance::Api/Package[glance-api]/ensure) The following packages were automatically installed and are no longer required:
2016-09-20 09:23:51 ERR (/Stage[main]/Glance::Api/Package[glance-api]/ensure) Reading state information...
2016-09-20 09:23:51 ERR (/Stage[main]/Glance::Api/Package[glance-api]/ensure) Building dependency tree...
2016-09-20 09:23:51 ERR (/Stage[main]/Glance::Api/Package[glance-api]/ensure) change from purged to present failed: Execution of '/usr/bin/apt-get -q -y -o DPkg::Options::=--force-confold install glance-api' returned 100: Reading package lists...
2016-09-20 09:23:51 ERR /usr/bin/puppet:8:in `<main>'
2016-09-20 09:23:51 ERR /usr/lib/ruby/vendor_ruby/puppet/util/command_line.rb:92:in `execute'
2016-09-20 09:23:51 ERR /usr/lib/ruby/vendor_ruby/puppet/util/command_line.rb:146:in `run'
2016-09-20 09:23:51 ERR /usr/lib/ruby/vendor_ruby/puppet/application.rb:381:in `run'
2016-09-20 09:23:51 ERR /usr/lib/ruby/vendor_ruby/puppet/util.rb:496:in `exit_on_fail'
2016-09-20 09:23:51 ERR /usr/lib/ruby/vendor_ruby/puppet/application.rb:381:in `block in run'
2016-09-20 09:23:51 ERR /usr/lib/ruby/vendor_ruby/puppet/application.rb:507:in `plugin_hook'
2016-09-20 09:23:51 ERR /usr/lib/ruby/vendor_ruby/puppet/application.rb:381:in `block (2 levels) in run'
2016-09-20 09:23:51 ERR /usr/lib/ruby/vendor_ruby/puppet/application/apply.rb:159:in `run_command'
2016-09-20 09:23:51 ERR /usr/lib/ruby/vendor_ruby/puppet/application/apply.rb:198:in `main'
2016-09-20 09:23:51 ERR /usr/lib/ruby/vendor_ruby/puppet.rb:244:in `override'
2016-09-20 09:23:51 ERR /usr/lib/ruby/vendor_ruby/puppet/context.rb:64:in `override'
2016-09-20 09:23:51 ERR /usr/lib/ruby/vendor_ruby/puppet/application/apply.rb:236:in `block in main'
2016-09-20 09:23:51 ERR /usr/lib/ruby/vendor_ruby/puppet/application/apply.rb:302:in `apply_catalog'
2016-09-20 09:23:51 ERR /usr/lib/ruby/vendor_ruby/puppet.rb:244:in `override'
2016-09-20 09:23:51 ERR /usr/lib/ruby/vendor_ruby/puppet/context.rb:64:in `override'
2016-09-20 09:23:51 ERR /usr/lib/ruby/vendor_ruby/puppet/configurer.rb:134:in `block in run'
2016-09-20 09:23:51 ERR /usr/lib/ruby/vendor_ruby/puppet/configurer.rb:227:in `run_internal'
2016-09-20 09:23:51 ERR /usr/lib/ruby/vendor_ruby/puppet/configurer.rb:119:in `apply_catalog'
2016-09-20 09:23:51 ERR /usr/lib/ruby/vendor_ruby/puppet/util.rb:160:in `benchmark'
2016-09-20 09:23:51 ERR /usr/lib/ruby/1.9.1/benchmark.rb:295:in `realtime'
2016-09-20 09:23:51 ERR /usr/lib/ruby/vendor_ruby/puppet/util.rb:161:in `block in benchmark'
2016-09-20 09:23:51 ERR /usr/lib/ruby/vendor_ruby/puppet/configurer.rb:120:in `block in apply_catalog'
2016-09-20 09:23:51 ERR /usr/lib/ruby/vendor_ruby/puppet/resource/catalog.rb:168:in `apply'
2016-09-20 09:23:51 ERR /usr/lib/ruby/vendor_ruby/puppet/transaction/report.rb:112:in `as_logging_destination'
2016-09-20 09:23:51 ERR /usr/lib/ruby/vendor_ruby/puppet/util/log.rb:149:in `with_destination'
2016-09-20 09:23:51 ERR /usr/lib/ruby/vendor_ruby/puppet/resource/catalog.rb:169:in `block in apply'
2016-09-20 09:23:51 ERR /usr/lib/ruby/vendor_ruby/puppet/transaction.rb:138:in `evaluate'
2016-09-20 09:23:51 ERR /usr/lib/ruby/vendor_ruby/puppet/graph/relationship_graph.rb:118:in `traverse'
2016-09-20 09:23:51 ERR /usr/lib/ruby/vendor_ruby/puppet/transaction.rb:147:in `block in evaluate'
2016-09-20 09:23:51 ERR /usr/lib/ruby/vendor_ruby/puppet/util.rb:334:in `thinmark'
2016-09-20 09:23:51 ERR /usr/lib/ruby/1.9.1/benchmark.rb:295:in `realtime'
2016-09-20 09:23:51 ERR /usr/lib/ruby/vendor_ruby/puppet/util.rb:335:in `block in thinmark'
2016-09-20 09:23:51 ERR /usr/lib/ruby/vendor_ruby/puppet/transaction.rb:147:in `block (2 levels) in evaluate'
2016-09-20 09:23:51 ERR /usr/lib/ruby/vendor_ruby/puppet/transaction.rb:147:in `call'
2016-09-20 09:23:51 ERR /usr/lib/ruby/vendor_ruby/puppet/transaction.rb:217:in `eval_resource'
2016-09-20 09:23:51 ERR /usr/lib/ruby/vendor_ruby/puppet/transaction.rb:204:in `apply'
2016-09-20 09:23:51 ERR /usr/lib/ruby/vendor_ruby/puppet/transaction/resource_harness.rb:20:in `evaluate'
2016-09-20 09:23:51 ERR /usr/lib/ruby/vendor_ruby/puppet/transaction/resource_harness.rb:81:in `perform_changes'
2016-09-20 09:23:51 ERR /usr/lib/ruby/vendor_ruby/puppet/transaction/resource_harness.rb:128:in `sync_if_needed'
2016-09-20 09:23:51 ERR /usr/lib/ruby/vendor_ruby/puppet/transaction/resource_harness.rb:204:in `sync'
2016-09-20 09:23:51 ERR /usr/lib/ruby/vendor_ruby/puppet/property.rb:581:in `sync'
2016-09-20 09:23:51 ERR /usr/lib/ruby/vendor_ruby/puppet/property.rb:498:in `set'
2016-09-20 09:23:51 ERR /usr/lib/ruby/vendor_ruby/puppet/property.rb:197:in `call_valuemethod'
2016-09-20 09:23:51 ERR /usr/lib/ruby/vendor_ruby/puppet/type/package.rb:73:in `block (3 levels) in <module:Puppet>'
2016-09-20 09:23:51 ERR /etc/puppet/modules/osnailyfacter/lib/puppet/provider/package/apt_fuel.rb:49:in `install'
2016-09-20 09:23:51 ERR /usr/lib/ruby/vendor_ruby/puppet/provider/package/apt.rb:73:in `install'
2016-09-20 09:23:51 ERR /usr/lib/ruby/vendor_ruby/puppet/provider.rb:463:in `block in create_class_and_instance_method'
2016-09-20 09:23:51 ERR /usr/lib/ruby/vendor_ruby/puppet/provider.rb:237:in `block in has_command'
2016-09-20 09:23:51 ERR /usr/lib/ruby/vendor_ruby/puppet/provider/command.rb:23:in `execute'
2016-09-20 09:23:51 ERR /usr/lib/ruby/vendor_ruby/puppet/util/execution.rb:219:in `execute'
2016-09-20 09:23:51 ERR E: There are problems and -y was used without --force-yes
2016-09-20 09:23:51 ERR After this operation, 133 MB of additional disk space will be used.
2016-09-20 09:23:51 ERR Need to get 32.0 MB of archives.
2016-09-20 09:23:51 ERR 0 upgraded, 99 newly installed, 1 downgraded, 0 to remove and 5 not upgraded.
2016-09-20 09:23:51 ERR libxml2
2016-09-20 09:23:51 ERR The following packages will be DOWNGRADED:
2016-09-20 09:23:51 ERR python-swiftclient python-taskflow python-tk python-wsme python-xattr
2016-09-20 09:23:51 ERR python-semantic-version python-simplegeneric python-support
2016-09-20 09:23:51 ERR python-pygraphviz python-pymongo python-pymongo-ext python-scipy
2016-09-20 09:23:51 ERR python-networkx python-numpy python-osprofiler python-psycopg2
2016-09-20 09:23:51 ERR python-ipaddr python-kazoo python-matplotlib python-matplotlib-data
2016-09-20 09:23:51 ERR python-glance-store python-gridfs python-gtk2 python-httplib2 python-imaging
2016-09-20 09:23:51 ERR python-egenix-mxdatetime python-egenix-mxtools python-glade2 python-glance
2016-09-20 09:23:51 ERR python-bson python-bson-ext python-cairo python-castellan
2016-09-20 09:23:51 ERR libxpm4 libxrandr2 libxslt1-dev libxss1 libxt6 python-automaton python-boto
2016-09-20 09:23:51 ERR libxcursor1 libxdamage1 libxfixes3 libxft2 libxinerama1 libxml2-dev libxmu6
2016-09-20 09:23:51 ERR libumfpack5.6.2 libvpx1 libxaw7 libxcb-render0 libxcb-shm0 libxcomposite1
2016-09-20 09:23:51 ERR libpixman-1-0 libpq5 libsm6 libtcl8.6 libthai-data libthai0 libtk8.6
2016-09-20 09:23:51 ERR liblapack3 libpango-1.0-0 libpangocairo-1.0-0 libpangoft2-1.0-0 libpathplan4
2016-09-20 09:23:51 ERR libgtk2.0-common libgvc6 libgvpr2 libharfbuzz0b libice6 libjasper1
2016-09-20 09:23:51 ERR libgfortran3 libglade2-0 libgraphite2-3 libgtk2.0-0 libgtk2.0-bin
2016-09-20 09:23:51 ERR libcolamd2.8.0 libdatrie1 libgd3 libgdk-pixbuf2.0-0 libgdk-pixbuf2.0-common
2016-09-20 09:23:51 ERR libcamd2.3.1 libccolamd2.8.0 libcdt5 libcgraph6 libcholmod2.1.2
2016-09-20 09:23:51 ERR hicolor-icon-theme libamd2.3.1 libatk1.0-0 libatk1.0-data libblas3 libcairo2
2016-09-20 09:23:51 ERR blt fontconfig fonts-liberation fonts-lyx glance-api glance-common graphviz
2016-09-20 09:23:51 ERR The following NEW packages will be installed:
2016-09-20 09:23:51 ERR python-tk-dbg
2016-09-20 09:23:51 ERR python-psycopg2-doc python-pymongo-doc python-semantic-version-doc tix
2016-09-20 09:23:51 ERR ttf-staypuft gfortran python-dev python-numpy-dbg python-numpy-doc
2016-09-20 09:23:51 ERR python-traits python-wxgtk2.8 texlive-extra-utils texlive-latex-extra
2016-09-20 09:23:51 ERR python-matplotlib-doc python-nose python-qt4 python-sip python-tornado
2016-09-20 09:23:51 ERR gir1.2-gtk-3.0 ghostscript inkscape ipython python-excelerator
2016-09-20 09:23:51 ERR python-egenix-mxtools-doc python-gtk2-doc python-kazoo-doc dvipng
2016-09-20 09:23:51 ERR python-egenix-mxdatetime-doc python-egenix-mxtools-dbg
2016-09-20 09:23:51 ERR python-automaton-doc python-castellan-doc python-egenix-mxdatetime-dbg
2016-09-20 09:23:51 ERR ttf-arphic-gkai00mp ttf-arphic-bkai00mp tcl8.6 tk8.6 pkg-config
2016-09-20 09:23:51 ERR libjasper-runtime ttf-baekmuk ttf-arphic-gbsn00lp ttf-arphic-bsmi00lp
2016-09-20 09:23:51 ERR blt-demo gsfonts graphviz-doc libgd-tools librsvg2-common gvfs
2016-09-20 09:23:51 ERR Suggested packages:
2016-09-20 09:23:51 ERR python-swiftclient python-taskflow python-tk python-wsme python-xattr
2016-09-20 09:23:51 ERR python-semantic-version python-simplegeneric python-support
2016-09-20 09:23:51 ERR python-pygraphviz python-pymongo python-pymongo-ext python-scipy
2016-09-20 09:23:51 ERR python-networkx python-numpy python-osprofiler python-psycopg2
2016-09-20 09:23:51 ERR python-ipaddr python-kazoo python-matplotlib python-matplotlib-data
2016-09-20 09:23:51 ERR python-glance-store python-gridfs python-gtk2 python-httplib2 python-imaging
2016-09-20 09:23:51 ERR python-egenix-mxdatetime python-egenix-mxtools python-glade2 python-glance
2016-09-20 09:23:51 ERR python-boto python-bson python-bson-ext python-cairo python-castellan
2016-09-20 09:23:51 ERR libxmu6 libxpm4 libxrandr2 libxslt1-dev libxss1 libxt6 python-automaton
2016-09-20 09:23:51 ERR libxcursor1 libxdamage1 libxfixes3 libxft2 libxinerama1 libxml2 libxml2-dev
2016-09-20 09:23:51 ERR libumfpack5.6.2 libvpx1 libxaw7 libxcb-render0 libxcb-shm0 libxcomposite1
2016-09-20 09:23:51 ERR libpixman-1-0 libpq5 libsm6 libtcl8.6 libthai-data libthai0 libtk8.6
2016-09-20 09:23:51 ERR liblapack3 libpango-1.0-0 libpangocairo-1.0-0 libpangoft2-1.0-0 libpathplan4
2016-09-20 09:23:51 ERR libgtk2.0-common libgvc6 libgvpr2 libharfbuzz0b libice6 libjasper1
2016-09-20 09:23:51 ERR libgfortran3 libglade2-0 libgraphite2-3 libgtk2.0-0 libgtk2.0-bin
2016-09-20 09:23:51 ERR libcolamd2.8.0 libdatrie1 libgd3 libgdk-pixbuf2.0-0 libgdk-pixbuf2.0-common
2016-09-20 09:23:51 ERR libcamd2.3.1 libccolamd2.8.0 libcdt5 libcgraph6 libcholmod2.1.2
2016-09-20 09:23:51 ERR hicolor-icon-theme libamd2.3.1 libatk1.0-0 libatk1.0-data libblas3 libcairo2
2016-09-20 09:23:51 ERR blt fontconfig fonts-liberation fonts-lyx glance-common graphviz
2016-09-20 09:23:51 ERR The following extra packages will be installed:
2016-09-20 09:23:51 ERR /usr/lib/ruby/vendor_ruby/puppet/configurer.rb:133:in `run'
2016-09-20 09:23:51 ERR cloud-guest-utils eatmydata python-oauth python-serial python3-pycurl
2016-09-20 09:23:51 ERR The following packages were automatically installed and are no longer required:
2016-09-20 09:23:51 ERR Reading state information...
2016-09-20 09:23:51 ERR Building dependency tree...
2016-09-20 09:23:51 ERR Execution of '/usr/bin/apt-get -q -y -o DPkg::Options::=--force-confold install glance-api' returned 100: Reading package lists...
2016-09-20 09:23:51 ERR Use 'apt-get autoremove' to remove them.
2016-09-20 09:23:51 ERR python3-software-properties software-properties-common unattended-upgrades
---------------------------------------------------------------------------------------------------

Also warning messages like:
---------------------------------------------------------------------------------------------------
2016-09-20 09:23:51 WARNING (/Stage[main]/Glance::Cache::Cleaner/Cron[glance-cache-cleaner]) Skipping because of failed dependencies
---------------------------------------------------------------------------------------------------
keeps showing up.

Please help me with this, thanks.

ck tsai (hotsizle) wrote :
description: updated
Oleksiy Molchanov (omolchanov) wrote :

Diagnostic snapshot doesn't contain information for debugging this issue. Can you please provide output:

apt-cache policy libxml2
and archive with /var/log/apt/

Marking as Incomplete

Changed in fuel:
assignee: nobody → Fuel Sustaining (fuel-sustaining-team)
status: New → Incomplete
ck tsai (hotsizle) wrote :

1. Output of "apt-cache policy libxml2":

libxml2:
  Installed: 2.9.1+dfsg1-3ubuntu4.8
  Candidate: 2.9.1+dfsg1-3ubuntu4.7
  Version table:
 *** 2.9.1+dfsg1-3ubuntu4.8 0
        500 http://10.20.0.3:8080/mirrors/ubuntu/ trusty-security/main amd64 Packages
        500 http://10.20.0.3:8080/mirrors/ubuntu/ trusty-updates/main amd64 Packages
        100 /var/lib/dpkg/status
     2.9.1+dfsg1-3ubuntu4.7 0
       1100 http://10.20.0.3:8080/plugins/fuel-plugin-ovsnfv-0.0/repositories/ubuntu/ Packages
        500 http://10.20.0.3:8080/mirrors/ubuntu/ trusty-security/main amd64 Packages
     2.9.1+dfsg1-3ubuntu4 0
        500 http://10.20.0.3:8080/mirrors/ubuntu/ trusty/main amd64 Packages

2. Content of /var/log/apt/history.log as attached.

ck tsai (hotsizle) wrote :

Btw, just out of curiosity, what if I execute:

apt-get purge glance glance-registry glance-api
rm /usr/local/bin/glance-*
apt-get install glance glance-registry glance-api

as
https://bugs.launchpad.net/ubuntu/+source/glance/+bug/1085595
suggests?

Is this applicable in FUEL deploy scenario? I'm afraid that this would ruin follow-up deployment..

ck tsai (hotsizle) on 2016-09-22
Changed in fuel:
status: Incomplete → New
Oleksiy Molchanov (omolchanov) wrote :

The issue is that puppet tries to downgrade libxml to 4.7, that comes from ovsnfv repo, please remove it from there and try again.

Changed in fuel:
status: New → Incomplete
ck tsai (hotsizle) wrote :

Hello, I have removed libxml2 related part in
/var/www/nailgun/plugins/fuel-plugin-ovsnfv-0.0/ovs_package/ubuntu/dependencies.txt
&
/var/www/nailgun/plugins/fuel-plugin-ovsnfv-0.0/deployment_scripts/puppet/modules/ovsdpdk/manifests/install_ovs_dpdk.pp

I also delete the libxml2_2.9.1+dfsg1-3ubuntu4.7_amd64.deb & libxml2-dev_2.9.1+dfsg1-3ubuntu4.7_amd64.deb in /var/www/nailgun/plugins/fuel-plugin-ovsnfv-0.0.
But everything stays the same.

What do you suggest? Or am I doing it wrong?

Changed in fuel:
status: Incomplete → New
status: New → Incomplete
status: Incomplete → New
Oleksiy Molchanov (omolchanov) wrote :

AFAIK you should not only to delete this package from repo, but update index file Packages.gz. Also you should run apt-get update on slave node.

If you did this and the problem persist - please share 'apt-cache policy libxml2' again

Changed in fuel:
status: New → Incomplete
ck tsai (hotsizle) wrote :

The problem is solved after I removed the libxml2-4.7 related part in /var/www/nailgun/plugins/fuel-plugin-ovsnfv-0.0/repositories/ubuntu/Package.gz.

Thanks for the help Oleksiy!

Oleksiy Molchanov (omolchanov) wrote :

You are welcome. Marking as Invalid.

Changed in fuel:
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers