ExampleV4 plugin: failed to install custom-defined role: The following packages cannot be authenticated! fuel-simple-service

Bug #1622506 reported by Vladimir Khlyunev on 2016-09-12
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Fuel for OpenStack
High
Maksim Malchuk

Bug Description

9.1 snapshot 249

https://product-ci.infra.mirantis.net/view/upgrades/job/9.x.backup-restore.ubuntu.upgrade_plugin_tests/22/testReport/(root)/upgrade_plugin_backup/upgrade_plugin_backup/

Steps to repro:
1 - grab or build example_v4 plugin (e.g. from https://product-ci.infra.mirantis.net/view/All/job/9.0.build-fuel-plugins/ )
2 - install the plugin to the fuel
3 - create cluster - any config;
4 - enable the plugin, add at least one plugin's role (fuel_plugin_example_v4)
5 - deploy cluster

Result:
node with custom role fails to deploy:

http://paste.openstack.org/show/572162/

diag snapshot is not available due to https://bugs.launchpad.net/fuel/+bug/1618965

This issue now affects 3 tests for backup-restore feature and will affects at lease 4 tests after applying of the fix on it.

Changed in fuel:
status: New → Confirmed
importance: Undecided → High
assignee: Fuel Sustaining (fuel-sustaining-team) → Maksim Malchuk (mmalchuk)
tags: added: area-library area-plugins

Fix proposed to branch: master
Review: https://review.openstack.org/368822

Changed in fuel:
status: Confirmed → In Progress

Reviewed: https://review.openstack.org/368822
Committed: https://git.openstack.org/cgit/openstack/fuel-plugins/commit/?id=4983c5c7d0552580898b0321664528b3dddbdb70
Submitter: Jenkins
Branch: master

commit 4983c5c7d0552580898b0321664528b3dddbdb70
Author: Maksim Malchuk <email address hidden>
Date: Mon Sep 12 15:52:50 2016 +0300

    Allow unauthenticated packages in the deployment scripts

    DocImpact
    Change-Id: Ib9464781fefd958d7ef4dfb5c9bf36aa7adcc663
    Closes-Bug: #1622506
    Signed-off-by: Maksim Malchuk <email address hidden>

Changed in fuel:
status: In Progress → Fix Committed
tags: added: on-verification

Verified on 9.1 snapshot #284

tags: removed: on-verification
Changed in fuel:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers