Need to add restriction for using CA certificate verification mode only if Bypass verification is disabled

Bug #1616438 reported by Elena Kosareva on 2016-08-24
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Fuel for OpenStack
Medium
Alexander Arzhanov
Nominated for Ocata by Alexander Arzhanov
Newton
Medium
Alexander Arzhanov

Bug Description

CA certificate verification should be availiable only if Bypass verification is disabled. Need to make checks on UI side and backend side before deployment.

Steps to reproduce:
 1. Create cluster with vmware hypervisor
 2. goto Vmware settings tab and turn on "Bypass vCenter certificate verification"
 3. Upload CA file
 4. Start deployment

Actual result:
 Deployment starts. No errors shown.

Expected:
 Error should be shown, deployment not started

Changed in fuel:
milestone: none → 10.0
Changed in fuel:
assignee: nobody → Elena Kosareva (ekosareva)
status: New → In Progress
tags: added: area-pce-vcenter area-ui
tags: removed: area-ui

Reviewed: https://review.openstack.org/354015
Committed: https://git.openstack.org/cgit/openstack/fuel-ui/commit/?id=5ce3ca33df8bdee0b4c7da549dbfb8bdccff174e
Submitter: Jenkins
Branch: master

commit 5ce3ca33df8bdee0b4c7da549dbfb8bdccff174e
Author: Anton Zemlyanov <email address hidden>
Date: Thu Aug 11 15:16:46 2016 +0300

    UI for user upload CA bundle file for VMware

    Add support of CA certificates and restrictions
    that enable/disable certificate upload field

    Change-Id: Id38bf7c74869fa60852ca1cb2ccaa9c63412cf64
    Partial-Bug: 1616438

Reviewed: https://review.openstack.org/361322
Committed: https://git.openstack.org/cgit/openstack/fuel-web/commit/?id=7f02c12ed9cd45b76343fc0b014bc5a6defe10a6
Submitter: Jenkins
Branch: master

commit 7f02c12ed9cd45b76343fc0b014bc5a6defe10a6
Author: Elena Kosareva <email address hidden>
Date: Fri Aug 26 18:34:09 2016 +0300

    Add restriction for using CA certificate verification

    CA certificate verification should be available only if
    Bypass verification is disabled.

    Partial-Bug: 1616438
    Change-Id: Ib83210f52c7874398fcb1791e51091e05151273f
    Depends-On: Id38bf7c74869fa60852ca1cb2ccaa9c63412cf64

Reviewed: https://review.openstack.org/370071
Committed: https://git.openstack.org/cgit/openstack/fuel-ui/commit/?id=b0dc8f854141ba562f2e24374cb3f1db2edbb78b
Submitter: Jenkins
Branch: stable/mitaka

commit b0dc8f854141ba562f2e24374cb3f1db2edbb78b
Author: Anton Zemlyanov <email address hidden>
Date: Thu Aug 11 15:16:46 2016 +0300

    UI for user upload CA bundle file for VMware

    Add support of CA certificates and restrictions
    that enable/disable certificate upload field

    Change-Id: Id38bf7c74869fa60852ca1cb2ccaa9c63412cf64
    Partial-Bug: 1616438
    (cherry picked from commit 5ce3ca33df8bdee0b4c7da549dbfb8bdccff174e)

tags: added: in-stable-mitaka

Reviewed: https://review.openstack.org/370086
Committed: https://git.openstack.org/cgit/openstack/fuel-web/commit/?id=7e2015f73c50ba63cbc2a51e374f9975c9010340
Submitter: Jenkins
Branch: stable/mitaka

commit 7e2015f73c50ba63cbc2a51e374f9975c9010340
Author: Elena Kosareva <email address hidden>
Date: Fri Aug 26 18:34:09 2016 +0300

    Add restriction for using CA certificate verification

    CA certificate verification should be available only if
    Bypass verification is disabled.

    Partial-Bug: 1616438
    Change-Id: Ib83210f52c7874398fcb1791e51091e05151273f
    Depends-On: Id38bf7c74869fa60852ca1cb2ccaa9c63412cf64
    (cherry picked from commit 7f02c12ed9cd45b76343fc0b014bc5a6defe10a6)

no longer affects: fuel/mitaka
Changed in fuel:
milestone: 10.0 → 9.2
assignee: Elena Kosareva (ekosareva) → Alexander Arzhanov (aarzhanov)

Reviewed: https://review.openstack.org/393003
Committed: https://git.openstack.org/cgit/openstack/fuel-web/commit/?id=3360d2fdecc6cbd749d412982b9bdd1d0045a9d0
Submitter: Jenkins
Branch: stable/mitaka

commit 3360d2fdecc6cbd749d412982b9bdd1d0045a9d0
Author: Alexander Arzhanov <email address hidden>
Date: Thu Nov 3 02:28:16 2016 +0300

    Add restriction for using CA certificate verification

    CA certificate verification should be available only if
    Bypass verification is disabled.

    Some changes were made in vmware_attributes_metadata
    since 9.1 in openstack.yaml so we have to update releases
    table accordingly during upgrade.

    Change-Id: I96d1326ac24b761d8efbcdad23656fd375f7edf8
    Closes-bug: #1616438

Reviewed: https://review.openstack.org/396608
Committed: https://git.openstack.org/cgit/openstack/fuel-qa/commit/?id=9e8958a65da0f5584dae864897470fa1165f0a1d
Submitter: Jenkins
Branch: stable/mitaka

commit 9e8958a65da0f5584dae864897470fa1165f0a1d
Author: ibumarskov <email address hidden>
Date: Fri Nov 11 15:16:17 2016 +0300

    vCenter_insecure parameter was changed

    Change-Id: Ie9a07714abc6e6f275c4e0423813ce86bc9e2947
    Related-bug: #1616438
    Closes-bug: #1641061

Reviewed: https://review.openstack.org/395507
Committed: https://git.openstack.org/cgit/openstack/fuel-web/commit/?id=20b81913423209343a5520df070cf084248c1907
Submitter: Jenkins
Branch: stable/newton

commit 20b81913423209343a5520df070cf084248c1907
Author: Alexander Arzhanov <email address hidden>
Date: Wed Nov 9 13:16:16 2016 +0300

    Add restriction for using CA certificate verification

    CA certificate verification should be available only if
    Bypass verification is disabled.

    Some changes were made in vmware_attributes_metadata
    in openstack.yaml so we have to update releases table
    accordingly during upgrade.

    Change-Id: Iaeb20b3614ff846b26001f366c2720459cd10bef
    Closes-bug: #1616438

Changed in fuel:
status: In Progress → Fix Committed

Reviewed: https://review.openstack.org/395496
Committed: https://git.openstack.org/cgit/openstack/fuel-web/commit/?id=1f323f5898b4889f9e9456a6f23f5b4abab3f779
Submitter: Jenkins
Branch: master

commit 1f323f5898b4889f9e9456a6f23f5b4abab3f779
Author: Alexander Arzhanov <email address hidden>
Date: Wed Nov 9 12:53:26 2016 +0300

    Add restriction for using CA certificate verification

    CA certificate verification should be available only if
    Bypass verification is disabled.

    Some changes were made in vmware_attributes_metadata
    in openstack.yaml so we have to update releases table
    accordingly during upgrade.

    Change-Id: Ibc1da57cfda4e732210e5eddb821856f72770dda
    Closes-bug: #1616438

Reviewed: https://review.openstack.org/398206
Committed: https://git.openstack.org/cgit/openstack/fuel-qa/commit/?id=d362aed222dc5c7332709133cfa3b278b8cbce1c
Submitter: Jenkins
Branch: stable/mitaka

commit d362aed222dc5c7332709133cfa3b278b8cbce1c
Author: ibumarskov <email address hidden>
Date: Wed Nov 16 11:52:09 2016 +0300

    Fix vcenter_insecure parameter
    vcenter_insecure parameter was changed to
    vcenter_security_disabled

    Change-Id: I4c0fac1ac12f1af97509f0cca712a65816b7ef51
    Related-bug: #1616438
    Closes-bug: #1642194

Ilya Bumarskov (ibumarskov) wrote :

Verified on snapshot-id #574

Changed in fuel:
status: Fix Committed → Fix Released

This issue was fixed in the openstack/fuel-web 11.0.0.0rc1 release candidate.

Change abandoned by Nastya Urlapova (<email address hidden>) on branch: master
Review: https://review.openstack.org/400049

Change abandoned by Nastya Urlapova (<email address hidden>) on branch: stable/newton
Review: https://review.openstack.org/400050

Change abandoned by Nastya Urlapova (<email address hidden>) on branch: stable/newton
Review: https://review.openstack.org/400048

Change abandoned by Ilya Bumarskov (<email address hidden>) on branch: master
Review: https://review.openstack.org/400047
Reason: vCenter was removed from MOS 10

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers