[fuel-plugins] Ubuntu repos ignore repeating packages

Bug #1599896 reported by Alexandru Avadanii on 2016-07-07
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Fuel for OpenStack
Medium
Michal Skalski

Bug Description

Some plugins may have repeating packages, which are filtered by dpkg-scanpackages.

Steps to reproduce (ODL example):
1. Build ODL plugin for multiarch (amd64 + arm64), which includes arch-specific DEBs (see [1])
2. Analyze plugin repo's Packages.gz contents

Expected results:
All packages built and shipped with ODL plugin should be listed in Packages.gz (see [2]).

Actual results:
Only one of the arch-specific DEBs will be listed (see [3]).

Description of the environment:
 Operation system: Ubuntu Trusty 14.04 (arm64)
 Versions of components: stable/mitaka
 Related projects installed: Fuel@OPNFV + Armband patches to build ODL for multiarch [4]

Proposed changes:
Add "-m, --multiversion (allow multiple versions of a single package)" flag to dpkg-scanpackages call.

[1] http://paste.openstack.org/show/526978/
[2] http://paste.openstack.org/show/526980/
[3] http://paste.openstack.org/show/526979/
[4] https://git.opnfv.org/cgit/armband/tree/patches/fuel-plugin-opendaylight

Fix proposed to branch: master
Review: https://review.openstack.org/339069

Changed in fuel:
assignee: nobody → Alexandru Avadanii (alexandru-avadanii)
status: New → In Progress
Changed in fuel:
assignee: Alexandru Avadanii (alexandru-avadanii) → Michal Skalski (mskalski)
Changed in fuel:
importance: Undecided → Medium
milestone: none → 10.0

Change abandoned by Alexandru Avadanii (<email address hidden>) on branch: master
Review: https://review.openstack.org/339069
Reason: Perfect! Thank you for updating the existing patch with the bug report! :)

Reviewed: https://review.openstack.org/311031
Committed: https://git.openstack.org/cgit/openstack/fuel-plugins/commit/?id=a3f9289478e9f9f9706d7166f072d77385e7cecf
Submitter: Jenkins
Branch: master

commit a3f9289478e9f9f9706d7166f072d77385e7cecf
Author: Guo Ruijing <email address hidden>
Date: Fri Apr 29 13:40:27 2016 +0800

    Support multi versions of package in fuel plugin

    Some plugins may have repeating packages, which are currently filtered
    by dpkg-scanpackages. This is the case for multiarch builds of some Fuel
    plugins like ODL, which build and ship both amd64 and arm64 DEBs for ODL
    prereqs. Allow multiple versions of a single package, by passing the
    `-m` flag to dpkg-scanpackages when building local Ubuntu repo.

    Closes-Bug: #1599896

    Change-Id: Iba6442d2f21b252769ae30b2af01bbb04e16fd4c
    Signed-off-by: Guo Ruijing <email address hidden>

Changed in fuel:
status: In Progress → Fix Committed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers