Update FPB version on PyPi

Bug #1594949 reported by Eugene Korekin on 2016-06-21
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Fuel for OpenStack
Medium
Ihor Kalnytskyi

Bug Description

As of now the latest FPB version is 4.0.0, but since this release there was several important bugfixes (for example https://github.com/openstack/fuel-plugins/commit/2d24a9dbe317c0a7308fc9050e302f8cb84e9503).

There was a suggestion from Igor Kalnitsky: "I think we can make a fix "4.0.1" release in order to refer users to install via pip."

Please create this release and ensure that it is uploaoded to PyPi.

Changed in fuel:
status: New → Confirmed
importance: Undecided → Medium
milestone: none → 10.0
tags: added: area-plugins
Changed in fuel:
assignee: nobody → Fuel Sustaining (fuel-sustaining-team)

(This check performed automatically)
Please, make sure that bug description contains the following sections filled in with the appropriate data related to the bug you are describing:

actual result

expected result

steps to reproduce

For more detailed information on the contents of each of the listed sections see https://wiki.openstack.org/wiki/Fuel/How_to_contribute#Here_is_how_you_file_a_bug

tags: added: need-info
Dmitry Pyzhov (dpyzhov) on 2016-06-22
tags: added: area-python
tags: added: non-release
tags: removed: need-info
Ilya Kutukov (ikutukov) on 2016-06-23
Changed in fuel:
assignee: Fuel Sustaining (fuel-sustaining-team) → Ilya Kutukov (ikutukov)
Changed in fuel:
status: Confirmed → In Progress
Changed in fuel:
assignee: Ilya Kutukov (ikutukov) → Igor Kalnitsky (ikalnitsky)

Change abandoned by Ilya Kutukov (<email address hidden>) on branch: master
Review: https://review.openstack.org/333396

Reviewed: https://review.openstack.org/334366
Committed: https://git.openstack.org/cgit/openstack/fuel-plugins/commit/?id=ce8a0b3598404055a3c9921571fbed763475620d
Submitter: Jenkins
Branch: master

commit ce8a0b3598404055a3c9921571fbed763475620d
Author: Igor Kalnitsky <email address hidden>
Date: Mon Jun 27 12:25:20 2016 +0300

    Version 4.1.0

    It's a bugfix version that includes the following fixes:

    - `tasks.yaml` is now optional for package version "4.0.0"
    - Fuel Mitaka (9.0) is supported by default in package version "4.0.0"
    - Use more reliable way to check for `fpm` Ruby GEM
    - Add ability for role to conflict with all roles by using `*` sign
    - Do not execute `uninstall.sh` on plugin upgrade
    - Add possiblity to use generators in `environment_config.yaml`
    - Don't put any code to PREUN section if `uninstall.sh` doesn't exist or empty
    - Allow a user to specify any arbitrary string as role name for cross-deps
    - Add deployment tasks v2.1 validation support

    Related-Bug: #1594949
    Change-Id: I9ce3b85ab9ac9516def24c15d1cb20ab69350ce2

Ihor Kalnytskyi (ikalnytskyi) wrote :

Fuel plugin builder 4.1.0 is available through PyPI:

  https://pypi.io/project/fuel-plugin-builder/4.1.0/

Move to fix released.

Changed in fuel:
status: In Progress → Fix Committed
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers