Add newer version of python-pymysql package

Bug #1589927 reported by Ivan Udovichenko on 2016-06-07
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Fuel for OpenStack
Low
Andrii Kroshchenko

Bug Description

We need newer version of python-pymysql package, at least 0.7.3.
Currently Ubuntu Xenial repository contains [1] 0.7.2 version.

Latest changes:
"""
## 0.7.4

Release date: 2016-05-26

* Fix AttributeError may happen while Connection.__del__ (#463)
* Fix SyntaxError in test_cursor. (#464)
* frozenset support for query value. (#461)
* Start using readthedocs.io

## 0.7.3

Release date: 2016-05-19

* Add read_timeout and write_timeout option.
* Support serialization customization by `conv` option.
* Unknown type is converted by `str()`, for MySQLdb compatibility.
* Support '%%' in `Cursor.executemany()`
* Support REPLACE statement in `Cursor.executemany()`
* Fix handling incomplete row caused by 'SHOW SLAVE HOSTS'.
* Fix decode error when use_unicode=False on PY3
* Fix port option in my.cnf file is ignored.
"""

Please add version 0.7.4 to our repository.
Package is already in Debian Unstable [2].

[1] http://packages.ubuntu.com/xenial/python-pymysql
[2] https://packages.debian.org/sid/python-pymysql

Changed in fuel:
assignee: MOS Packaging Team (mos-packaging) → Andrii Kroshchenko (akroshchenko)
Changed in fuel:
status: Confirmed → In Progress

Reviewed: https://review.fuel-infra.org/21787
Submitter: Aleksandra Fedorova <email address hidden>
Branch: master

Commit: b97ef0dc41f9b980d93a62bb8d36bbd5487fa55c
Author: Andrii Kroshchenko <email address hidden>
Date: Wed Jun 8 14:37:09 2016

Add new project:

  -- packages/xenial/python-pymysql

We need a higher version [1] than present in Xenial [2]

[1] https://github.com/openstack/requirements/blob/master/upper-constraints.txt#L19
[2] http://packages.ubuntu.com/xenial/python/python-pymysql

Related-Bug: #1589927
Change-Id: I70ee4b3b1211dbd3a7fe0c4bf772b5b5bdf25394

Reviewed: https://review.fuel-infra.org/21808
Submitter: Pkgs Jenkins <email address hidden>
Branch: master

Commit: 77b005f099239eca243b4acb3b2f2ca42d0fa7ca
Author: Andrii Kroshchenko <email address hidden>
Date: Thu Jun 9 10:43:44 2016

Add python-pymysql package to MOS 10.0 repository

Related-Bug: #1589927

Change-Id: Ie398d9d84c6439a9637ef28b34b5102447e6aac3

Reviewed: https://review.fuel-infra.org/21764
Submitter: Pkgs Jenkins <email address hidden>
Branch: master

Commit: c4c9461d63f7a2bc4f6a50a36a69c2f063258837
Author: Andrii Kroshchenko <email address hidden>
Date: Thu Jun 9 10:44:13 2016

Update python-pymysql:

  * Update version to 0.7.4
  * Update dependencies according to global requirements

Related-Bug: #1589927

Change-Id: I47e8aae56b2b194935aa6d85969676b9d7450791

Changed in fuel:
status: In Progress → Fix Committed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers