Network verification fails due to missing python-netifaces dependency in network-checker deb package

Bug #1587909 reported by Alexandr Kostrikov on 2016-06-01
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Fuel for OpenStack
Critical
MOS Packaging Team
Mitaka
Critical
MOS Packaging Team

Bug Description

During swarm run at jobs [0][1][2][3]

There were error:
Task 'verify_networks' has incorrect status. error != ready, ''

In astute logs:
2016-05-31 23:24:45 INFO [29474] Casting message to Nailgun:
{"method"=>"verify_networks_resp",
 "args"=>
  {"task_uuid"=>"fc80ee89-d0df-481e-bfae-82022af59500",
   "status"=>"ready",
   "progress"=>100,

But nailgun show status as:
17 | error | verify_networks | 1 | 100 | fc80ee89-d0df-481e-bfae-82022af59500

[0] https://product-ci.infra.mirantis.net/job/9.0.system_test.ubuntu.bonding_ha/126/console
[1] https://product-ci.infra.mirantis.net/job/9.0.system_test.ubuntu.plugins.fuel_plugin_example/129/console
[2] https://product-ci.infra.mirantis.net/job/9.0.system_test.ubuntu.network_templates/128/console
[3] https://product-ci.infra.mirantis.net/job/9.0.system_test.ubuntu.deploy_from_uca/9/console

(This check performed automatically)
Please, make sure that bug description contains the following sections filled in with the appropriate data related to the bug you are describing:

actual result

version

expected result

steps to reproduce

For more detailed information on the contents of each of the listed sections see https://wiki.openstack.org/wiki/Fuel/How_to_contribute#Here_is_how_you_file_a_bug

tags: added: need-info
summary: - Task verify networks reported 100/ready state, but nailgun reports it as
- failed
+ Network verification fails due to missing python-netifaces dependency in
+ network-checker deb package
Vladimir Kuklin (vkuklin) wrote :

RCA is simple - network checker has a dependency for python-netifaces, but it is not listed in deb package dependencies. It is also missing in 10.0 package

tags: removed: need-info
Bug Checker Bot (bug-checker) wrote :

(This check performed automatically)
Please, make sure that bug description contains the following sections filled in with the appropriate data related to the bug you are describing:

actual result

version

expected result

steps to reproduce

For more detailed information on the contents of each of the listed sections see https://wiki.openstack.org/wiki/Fuel/How_to_contribute#Here_is_how_you_file_a_bug

tags: added: need-info
tags: removed: area-python
no longer affects: fuel/newton

Related fix proposed to branch: master
Review: https://review.openstack.org/324031

Change abandoned by Igor Yozhikov (<email address hidden>) on branch: master
Review: https://review.openstack.org/324031
Reason: due same commit

Reviewed: https://review.openstack.org/324026
Committed: https://git.openstack.org/cgit/openstack/network-checker/commit/?id=bfbb77c50f37b79abf6784c74a77f5c48ad0abae
Submitter: Jenkins
Branch: master

commit bfbb77c50f37b79abf6784c74a77f5c48ad0abae
Author: Ivan Udovichenko <email address hidden>
Date: Wed Jun 1 20:10:33 2016 +0300

    Update network-checker package

    Version: 10.0.0-2

    * d/control: Add python-netifaces dependency.

    Change-Id: Id5602fc62b77b37028f9bf47e1f33259097cfa17
    Related-Bug: #1587909

tags: added: in-stable-mitaka

Reviewed: https://review.openstack.org/324066
Committed: https://git.openstack.org/cgit/openstack/network-checker/commit/?id=645117bbbc084fa736e29be4e40be4dac95ea243
Submitter: Jenkins
Branch: stable/mitaka

commit 645117bbbc084fa736e29be4e40be4dac95ea243
Author: Ivan Udovichenko <email address hidden>
Date: Wed Jun 1 22:16:06 2016 +0300

    Update network-checker package

    Version: 9.0.0-2

    * d/control: Add python-netifaces dependency.

    Change-Id: I5eb89a5eb20d3dd3dceb8fcab32bacb617e5dc05
    Related-Bug: #1587909

Changed in fuel:
status: Confirmed → Fix Committed

Now it works fine on MOs 9.0 #427 build, marked as Fix Released.

Changed in fuel:
status: Fix Committed → Fix Released
Vladimir Kuklin (vkuklin) wrote :

I think we should close this bug and open another one. This bug is essentially a duplicate of https://bugs.launchpad.net/fuel/+bug/1588022 which did not exist in 9.0

Changed in fuel:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers