[OSTF] Tests for network connectivity should be skipped if there are no computes w/o DPDK

Bug #1567447 reported by Artem Panchenko on 2016-04-07
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Fuel for OpenStack
High
Artem Panchenko
Mitaka
High
Artem Panchenko

Bug Description

Currently health checks which spawn Nova instances fail if there are no computes in cluster with disabled DPDK for private network NIC:

Failed 2 OSTF tests; should fail 0 tests. Names of failed tests:
  - Check network connectivity from instance via floating IP (failure) Instance is not reachable by IP. Please refer to OpenStack logs for more details.
  - Launch instance with file injection (failure) Execution command on Instance fails with unexpected result. Please refer to OpenStack logs for more details.

Such failures are expected because the tests are using default m1.micro flavor which doesn't allocate huge memory pages for instance RAM, but OVS+DPDK require it. So if there are no computes without enabled DPDK then OSTF should skip default Neutron tests.

Related bug #1566358 and bug #1567439

Artem Panchenko (apanchenko-8) wrote :
no longer affects: fuel
no longer affects: fuel/mitaka
Changed in fuel:
milestone: none → 10.0
no longer affects: fuel/mitaka
Changed in fuel:
assignee: nobody → Artem Panchenko (apanchenko-8)
importance: Undecided → High
Changed in fuel:
status: New → Confirmed
no longer affects: fuel/newton
Changed in fuel:
status: Confirmed → In Progress

Reviewed: https://review.openstack.org/310066
Committed: https://git.openstack.org/cgit/openstack/fuel-ostf/commit/?id=2bdaeafbb2c92fb85aa5b77e24128678fb96fff4
Submitter: Jenkins
Branch: master

commit 2bdaeafbb2c92fb85aa5b77e24128678fb96fff4
Author: Artem Panchenko <email address hidden>
Date: Tue Apr 26 00:36:25 2016 +0300

    Skip 2 health checks if no computes w/o DPDK

    If environment doesn't contain compute nodes
    without DPDK then it's impossible to run instance
    and access it over network using default flavor
    which doesn't use huge pages for RAM.

    Change-Id: Ic6daf95fb7380a4c9355a5a1e5c6a1e45de46f89
    Closes-bug: #1567447

Changed in fuel:
status: In Progress → Fix Committed

Reviewed: https://review.openstack.org/314469
Committed: https://git.openstack.org/cgit/openstack/fuel-ostf/commit/?id=3addfdd697dc2625c19c3070ebcb5adc135ca2d9
Submitter: Jenkins
Branch: stable/mitaka

commit 3addfdd697dc2625c19c3070ebcb5adc135ca2d9
Author: Artem Panchenko <email address hidden>
Date: Tue Apr 26 00:36:25 2016 +0300

    Skip 2 health checks if no computes w/o DPDK

    If environment doesn't contain compute nodes
    without DPDK then it's impossible to run instance
    and access it over network using default flavor
    which doesn't use huge pages for RAM.

    Change-Id: Ic6daf95fb7380a4c9355a5a1e5c6a1e45de46f89
    Closes-bug: #1567447
    (cherry picked from commit 2bdaeafbb2c92fb85aa5b77e24128678fb96fff4)

Reviewed: https://review.openstack.org/316683
Committed: https://git.openstack.org/cgit/openstack/fuel-qa/commit/?id=cef88047debab3cdcd0f1b1123bfa2ccf7e45d6e
Submitter: Jenkins
Branch: master

commit cef88047debab3cdcd0f1b1123bfa2ccf7e45d6e
Author: Artem Panchenko <email address hidden>
Date: Mon May 16 12:30:40 2016 +0300

    [DPDK] OSTF tests that won't pass are skipped now

    Tests that aren't compatible with DPDK are skipped
    by OSTF now. Other 4 tests were failing due to
    product bug(s), currently they are fixed.

    Change-Id: Ib2901d408c1318d6343047ab4e001d0cac5f85ba
    Related-bug: #1567447

Reviewed: https://review.openstack.org/316743
Committed: https://git.openstack.org/cgit/openstack/fuel-qa/commit/?id=6b4d78b7473e6b0e853e6843045a808abd9a5340
Submitter: Jenkins
Branch: stable/mitaka

commit 6b4d78b7473e6b0e853e6843045a808abd9a5340
Author: Artem Panchenko <email address hidden>
Date: Mon May 16 12:30:40 2016 +0300

    [DPDK] OSTF tests that won't pass are skipped now

    Tests that aren't compatible with DPDK are skipped
    by OSTF now. Other 4 tests were failing due to
    product bug(s), currently they are fixed.

    Change-Id: Ib2901d408c1318d6343047ab4e001d0cac5f85ba
    Related-bug: #1567447
    (cherry picked from commit cef88047debab3cdcd0f1b1123bfa2ccf7e45d6e)

tags: added: in-stable-mitaka
Maksym Strukov (unbelll) wrote :

Verified as fixed in 9.0-mos-364 and 10.0-224

Changed in fuel:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers