Deprecated options are used in nova conf

Bug #1562935 reported by Dmitry Mescheryakov on 2016-03-28
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Fuel for OpenStack
Low
Alexey Deryugin
Mitaka
Low
Alexey Deryugin
Newton
Low
Alexey Deryugin

Bug Description

Version: 9.0

Steps to reproduce:
1. Log into controller and here execute 'nova-manage service list'.

Expected result:
The command successfully completes, no warning is printed

Actual result:
The command successfully completes, a number of warning printed:
http://paste.openstack.org/show/492102/

Aside from the one suggesting to execute 'nova service-list' instead, other 3 warnings point out that deprecated parameters are used in nova.conf. They could and should be fixed eventually.

Changed in fuel:
importance: Undecided → Medium
assignee: nobody → MOS Puppet Team (mos-puppet)
milestone: none → 9.0
status: New → Confirmed
tags: added: area-mos
Changed in fuel:
status: Confirmed → New
description: updated
Changed in fuel:
assignee: MOS Puppet Team (mos-puppet) → Alexey Deryugin (velovec)
status: New → Confirmed
Ivan Berezovskiy (iberezovskiy) wrote :

These parameter are set by puppet-nova module:
https://github.com/openstack/puppet-nova/blob/stable/mitaka/manifests/logging.pp#L132
https://github.com/openstack/puppet-nova/blob/stable/mitaka/manifests/init.pp#L652
https://github.com/openstack/puppet-nova/blob/stable/mitaka/manifests/init.pp#L661

We can't propose update for parameters and sections because of low bug priority. It will be fixed for Fuel 10.0 (in puppet-nova module for Newton).

Changed in fuel:
status: Confirmed → Won't Fix
importance: Medium → Low
Dina Belova (dbelova) wrote :

Added move-to-10.0 tag to show this bug was moved from 9.0

tags: added: move-to-10.0
Alexey Deryugin (velovec) wrote :

Related upstream fix is on review: https://review.openstack.org/#/c/304734/

no longer affects: fuel/future
Alexey Deryugin (velovec) wrote :

Upstream patch is merged

Fix proposed to branch: master
Review: https://review.openstack.org/307411

Changed in fuel:
status: Won't Fix → In Progress

Reviewed: https://review.openstack.org/307411
Committed: https://git.openstack.org/cgit/openstack/fuel-library/commit/?id=ae2a34d1c8e4d2a1baf1adb08bb66c77e8f59145
Submitter: Jenkins
Branch: master

commit ae2a34d1c8e4d2a1baf1adb08bb66c77e8f59145
Author: Alexey Deryugin <email address hidden>
Date: Mon Apr 18 18:38:52 2016 +0000

    Remove deprecated parameters for nova

    Change-Id: Iff4b803076929c8253fcdd5b39c3fc440be5ed96
    Closes-Bug: #1562935

Changed in fuel:
status: In Progress → Fix Committed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers