[dpdk] serialization creates two add-port for dpdk

Bug #1559218 reported by Atsuko Ito
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Fuel for OpenStack
Fix Released
High
Fedor Zhadaev

Bug Description

1. Create VLAN cluster
2. Mark interface enp0s5 as DPDK and put Private net on it
3. Deploy cluster

Actual: Serialization contains two transformations for enp0s5

network_scheme:
  transformations:
  - action: add-br
    vendor_specific:
      datapath_type: netdev
    name: br-prv
    provider: ovs
  - action: add-port
    bridge: br-prv
    name: enp0s5
    provider: dpdkovs
  - action: add-port # incorrect one
    bridge: br-aux
    name: enp0s5

Atsuko Ito (yottatsa)
Changed in fuel:
milestone: none → 9.0
importance: Undecided → Critical
Changed in fuel:
importance: Critical → High
tags: added: area-python
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to fuel-web (master)

Fix proposed to branch: master
Review: https://review.openstack.org/295086

Changed in fuel:
status: New → In Progress
Revision history for this message
Aleksey Kasatkin (alekseyk-ru) wrote :

It is not a bug really. As related code is not merged yet.

Changed in fuel:
importance: High → Wishlist
Changed in fuel:
status: In Progress → Incomplete
importance: Wishlist → High
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Change abandoned on fuel-web (master)

Change abandoned by Fedor Zhadaev (<email address hidden>) on branch: master
Review: https://review.openstack.org/295086
Reason: Fixed in https://review.openstack.org/#/c/284283

Atsuko Ito (yottatsa)
Changed in fuel:
status: Incomplete → Fix Committed
Revision history for this message
Maksym Strukov (unbelll) wrote :

Verified as fixed in 9.0-mos-354

Changed in fuel:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers