Fuel generates different astute.yaml's when using fuel node --node-id N --deploy command

Bug #1557562 reported by Dmitriy Stremkovskiy on 2016-03-15
20
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Fuel Plugins
High
Arthur Svechnikov
Fuel for OpenStack
High
Arthur Svechnikov

Bug Description

steps to reproduce
1) Create fuel plugin
2) environment_config.yaml should contain:
attributes:
  metadata:
    pregenerated_password:
      generator: "password"
Plugin should create new role.
3) build plugin and install it on the fuel master
4) create environment
5) assign 2+ nodes to new role
6) do not assign openstack controller roles to any node.
Your deploy could not be run from WebUI, however it could be started from CLI

Now you have new envirnoment with 2+ nodes with plugin role.

If you run:
fuel deploy-changes --env N
you will be able to get equal astute.yaml files with the same pregenerated_password
If you reset environment and call tasks manualy, like:
fuel node --node-id A --provision
fuel node --node-id B --provision
fuel node --node-id C --provision
fuel node --node-id A --deploy
fuel node --node-id B --deploy
fuel node --node-id C --deploy

actual result
you will get different passwords in astute.yaml files within one environment
In that case services will fail to synchronise.

expected result
get same passwords for services in astute.yaml files for equal roles within one environment

Affected/tested fuel versions: fuel 9

Changed in fuel:
milestone: none → 9.0
assignee: nobody → Fuel Python Team (fuel-python)
Maciej Relewicz (rlu) on 2016-03-15
Changed in fuel:
importance: Undecided → High
Changed in fuel:
status: New → Confirmed
tags: added: area-python
Changed in fuel:
assignee: Fuel Python Team (fuel-python) → Arthur Svechnikov (asvechnikov)
Dmitry Pyzhov (dpyzhov) on 2016-03-18
tags: added: feature-plugins

(This check performed automatically)
Please, make sure that bug description contains the following sections filled in with the appropriate data related to the bug you are describing:

actual result

expected result

steps to reproduce

For more detailed information on the contents of each of the listed sections see https://wiki.openstack.org/wiki/Fuel/How_to_contribute#Here_is_how_you_file_a_bug

tags: added: need-info
description: updated
tags: removed: need-info

Fix proposed to branch: master
Review: https://review.openstack.org/302867

Changed in fuel:
status: Confirmed → In Progress
Arthur Svechnikov (asvechnikov) wrote :

Now it's possible to use generators in environment_config.yaml for example:

attributes:
  pregenerated_password
    label: ""
    description: ""
    weight: 60
    type: 'hidden'
    value:
      generator: 'password'

And don't use some generated values into metadata, it's generated every time without saving in db.

Reviewed: https://review.openstack.org/302867
Committed: https://git.openstack.org/cgit/openstack/fuel-plugins/commit/?id=e00d4bba5117b19a984140b6fd15f9cfe4b81983
Submitter: Jenkins
Branch: master

commit e00d4bba5117b19a984140b6fd15f9cfe4b81983
Author: Artur Svechnikov <email address hidden>
Date: Thu Apr 7 18:20:51 2016 +0300

    Add possiblity to use generator in environment config

    It should be possible to use generators in
    environment config. However validation schema
    doesn't allow it.
    Nailgun doesn't contain such scheme because
    validation take place after all values have been
    generated

    Change-Id: Iff2feb7357afff02793deee65b6c65072914739c
    Closes-Bug: #1557562

Changed in fuel:
status: In Progress → Fix Committed
tags: added: on-verification
Changed in fuel-plugins:
status: New → Fix Committed
Ksenia Svechnikova (kdemina) wrote :

This issue concerns Fuel Plugin Project. (Commit was made for pdb). Please reassign and mark it as Fix released, as I doesn't have permissions in Fuel Plugin Project.

tags: removed: on-verification
Changed in fuel:
status: Fix Committed → Invalid
Changed in fuel-plugins:
importance: Undecided → High
assignee: nobody → Arthur Svechnikov (asvechnikov)
status: Fix Committed → Fix Released
Ksenia Svechnikova (kdemina) wrote :

Change Invalid in Fuel project, as it was fixed in fpb

Changed in fuel-plugins:
milestone: none → 9.0
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers