Remove 'Mirantis' mentionings from fuel-qa repo

Bug #1547456 reported by Andrey Sledzinskiy on 2016-02-19
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Fuel for OpenStack
High
Andrey Sledzinskiy
Mitaka
High
Nastya Urlapova

Bug Description

Next things should be fixed in fuel-qa as part of removing 'Mirantis' names from our code base:

- our internal collector - https://github.com/openstack/fuel-qa/blob/944cb29e7e3165427940eeee4e03676bbd8e2bca/fuelweb_test/settings.py#L399, need to remove default and move export to jenkins job

- internal OSCI resource - https://github.com/openstack/fuel-qa/blob/944cb29e7e3165427940eeee4e03676bbd8e2bca/fuelweb_test/settings.py#L430 - just remove examples

- our testrail - https://github.com/openstack/fuel-qa/blob/944cb29e7e3165427940eeee4e03676bbd8e2bca/fuelweb_test/testrail/settings.py#L57 - move export to jenkins jobs

- name of testrail project - https://github.com/openstack/fuel-qa/blob/944cb29e7e3165427940eeee4e03676bbd8e2bca/fuelweb_test/testrail/settings.py#L60 - change default to neutral name

- https://github.com/openstack/fuel-qa/blob/master/fuelweb_test/tests/test_admin_node.py#L498 - remove mirantis from description

Changed in fuel:
status: New → Confirmed
Changed in fuel:
assignee: Fuel QA Team (fuel-qa) → Andrey Sledzinskiy (asledzinskiy)

Fix proposed to branch: master
Review: https://review.openstack.org/284729

Changed in fuel:
status: Confirmed → In Progress

Related fix proposed to branch: master
Change author: Andrey Sledzinskiy <email address hidden>
Review: https://review.fuel-infra.org/17452

Reviewed: https://review.openstack.org/287667
Committed: https://git.openstack.org/cgit/openstack/fuel-ostf/commit/?id=155450a648e6039e21a7ca1f14d8bff74647f40d
Submitter: Jenkins
Branch: master

commit 155450a648e6039e21a7ca1f14d8bff74647f40d
Author: asledzinskiy <email address hidden>
Date: Thu Mar 3 11:21:14 2016 +0200

    Change link to fuel documentation in OSTF

    - Due to making fuel repos community friendly
    change link from mirantis doc to https://www.fuel-infra.org/#fueldocs

    Change-Id: If77afba1bbcec08397eb5cd64f4991111d081aca
    Related-Bug: #1547456

Reviewed: https://review.fuel-infra.org/17452
Submitter: Aleksandra Fedorova <email address hidden>
Branch: master

Commit: f34b54ed7a142e6e85e30dce54faf28eb92bf7b4
Author: Andrey Sledzinskiy <email address hidden>
Date: Thu Mar 24 13:33:41 2016

Add export for mirantis resources

- Add export of testrail project name
- Add export of colector and analytics servers
- Add export of PERESTROIKA_REPO

Change-Id: Icaf6276f00ac624aa78991eec5e4d38a8b9ff761
Related-Bug: #1547456

Changed in fuel:
milestone: 9.0 → 10.0

Reviewed: https://review.openstack.org/284729
Committed: https://git.openstack.org/cgit/openstack/fuel-qa/commit/?id=f95e619609eb29e7853b2d00bb51554520fbc1a7
Submitter: Jenkins
Branch: master

commit f95e619609eb29e7853b2d00bb51554520fbc1a7
Author: asledzinskiy <email address hidden>
Date: Thu Feb 25 15:52:22 2016 +0200

    Remove Mirantis mentionings from fuel-qa

    - Remove collector, analytics defaults
    - Remove Testrail project names defaults
    - Remove 'Miranits' mentionings form tests description
    - Remove PERESTROIKA_REPO default value

    Change-Id: Id7484f4abb8b70b63a2981dc92abfe533318b2db
    Closes-Bug: #1547456

Changed in fuel:
status: In Progress → Fix Committed

Reviewed: https://review.openstack.org/308269
Committed: https://git.openstack.org/cgit/openstack/fuel-qa/commit/?id=1d43e9a3cad418bdee24cabaa425b669ead9a18b
Submitter: Jenkins
Branch: stable/mitaka

commit 1d43e9a3cad418bdee24cabaa425b669ead9a18b
Author: asledzinskiy <email address hidden>
Date: Thu Feb 25 15:52:22 2016 +0200

    Remove Mirantis mentionings from fuel-qa

    - Remove collector, analytics defaults
    - Remove Testrail project names defaults
    - Remove 'Miranits' mentionings form tests description
    - Remove PERESTROIKA_REPO default value

    Change-Id: Id7484f4abb8b70b63a2981dc92abfe533318b2db
    Closes-Bug: #1547456
    (cherry picked from commit f95e619609eb29e7853b2d00bb51554520fbc1a7)

Related fix proposed to branch: master
Change author: Artem Panchenko <email address hidden>
Review: https://review.fuel-infra.org/20362

Reviewed: https://review.fuel-infra.org/20362
Submitter: Artur Kaszuba <email address hidden>
Branch: master

Commit: 8d0f2c5a9bd966a7258d90dfb67954e7ea9fee55
Author: Artem Panchenko <email address hidden>
Date: Thu May 5 13:39:31 2016

Add missing variables for TestRail

Change-Id: Ia1392c7a4e461f08fcf38d41a49c7d60ec77f7ff
Related-bug: #1547456

Vladimir Khlyunev (vkhlyunev) wrote :

Verified by grep

Changed in fuel:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers