test_create_sample test failed with IndexError: list index out of range

Bug #1543050 reported by Andrey Sledzinskiy on 2016-02-08
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Fuel for OpenStack
High
Vitaly Gusev
8.0.x
High
Vitaly Gusev

Bug Description

iso - 8.0-536

Steps:
1. Create and deploy next cluster - Neutron tun, default storages, Ceilometer, 1 controller, 1 compute, 1 cinder+mongo
2. After deployment run OSTF test - 'Ceilometer test to create, check and list samples'

Actual result - test failed with:

fuel_health.common.test_mixins: DEBUG: Traceback (most recent call last): File "/usr/lib/python2.7/site-packages/fuel_health/common/test_mixins.py", line 177, in verify result = func(*args, **kwargs) File "/usr/lib/python2.7/site-packages/fuel_health/ceilometermanager.py", line 224, in get_samples_count meter_name=meter_name, q=query)[0].count IndexError: list index out of range

logs are attached

Changed in fuel:
assignee: MOS QA Team (mos-qa) → Vitaly Gusev (vgusev)
tags: added: ceilometer ostf
Changed in fuel:
status: New → Confirmed

Fix proposed to branch: master
Review: https://review.openstack.org/277367

Changed in fuel:
status: Confirmed → In Progress

Fix proposed to branch: stable/8.0
Review: https://review.openstack.org/277468

Changed in fuel:
status: In Progress → Fix Committed

Reviewed: https://review.openstack.org/277367
Committed: https://git.openstack.org/cgit/openstack/fuel-ostf/commit/?id=3e0ed718d69f8f6bd1809080ec27568312a7c630
Submitter: Jenkins
Branch: master

commit 3e0ed718d69f8f6bd1809080ec27568312a7c630
Author: vgusev <email address hidden>
Date: Mon Feb 8 15:50:49 2016 +0300

    [Ceilometer] Fix for test_create_sample

    Fixed test with sample creating

    Change-Id: Ib215d39db663c74677d7dafbd348744a780e66f5
    Closes-bug: #1543050

Vitaly Gusev (vgusev) wrote :

Test failed because there was no samples for 'image' metric. That's why statistic request for this metric returns empty list and test failed with such error. Samples are collected every polling interval (10 minutes by default in MOS 8.0) and looks like test was launched before samples for 'image' metric was collected. Test may fail only on newly deployed environments and will not be reproduced on long-living environments.
This bug didn't reproduce in the next swarm run for 8.0-541 ISO, so move this bug to 'Won't fix' for 8.0 milestone.

tags: added: release-notes

It is not a Critical issue. The issue reproduced only first 15 minutes after the deployment of OpenStack cluster.
15 minutes later this test will pass in 100% of cases without any issues.

It affects only one OSTF test (and not affects OpenStack functionality/configuration) and we have a simple workaround for the issue.

Priority changed to High (it is not Medium because it affects SWARM/OSTF).
Let's fix it in 8.0 updates

tags: added: area-ostf
removed: area-qa ostf
Vitaly Gusev (vgusev) wrote :

Verified on ISO:
cat /etc/fuel_build_id:
 224
cat /etc/fuel_build_number:
 224
cat /etc/fuel_release:
 9.0
cat /etc/fuel_openstack_version:
 mitaka-9.0
rpm -qa | egrep 'fuel|astute|network-checker|nailgun|packetary|shotgun':
 fuel-release-9.0.0-1.mos6339.noarch
 fuel-misc-9.0.0-1.mos8306.noarch
 fuel-mirror-9.0.0-1.mos131.noarch
 fuel-openstack-metadata-9.0.0-1.mos8657.noarch
 fuel-provisioning-scripts-9.0.0-1.mos8657.noarch
 python-fuelclient-9.0.0-1.mos312.noarch
 fuel-9.0.0-1.mos6339.noarch
 fuel-nailgun-9.0.0-1.mos8657.noarch
 rubygem-astute-9.0.0-1.mos738.noarch
 fuel-library9.0-9.0.0-1.mos8306.noarch
 network-checker-9.0.0-1.mos72.x86_64
 fuel-agent-9.0.0-1.mos273.noarch
 fuel-ui-9.0.0-1.mos2663.noarch
 fuel-setup-9.0.0-1.mos6339.noarch
 nailgun-mcagents-9.0.0-1.mos738.noarch
 python-packetary-9.0.0-1.mos131.noarch
 fuelmenu-9.0.0-1.mos269.noarch
 fuel-bootstrap-cli-9.0.0-1.mos273.noarch
 fuel-migrate-9.0.0-1.mos8306.noarch
 shotgun-9.0.0-1.mos88.noarch
 fuel-notify-9.0.0-1.mos8306.noarch
 fuel-ostf-9.0.0-1.mos924.noarch
 fuel-utils-9.0.0-1.mos8306.noarch

Changed in fuel:
status: Fix Committed → Fix Released

Related fix proposed to branch: master
Change author: Evgeny Konstantinov <email address hidden>
Review: https://review.fuel-infra.org/22326

Reviewed: https://review.fuel-infra.org/22326
Submitter: Evgeny Konstantinov <email address hidden>
Branch: master

Commit: dcd0ac5631e06625c76d2d62c17bc1fef67a7072
Author: Evgeny Konstantinov <email address hidden>
Date: Wed Jun 22 10:51:45 2016

Add resolved issues to relnotes 9.0

Change-Id: I87df13ac06921547312dd2165097d080528ec864
Related-Bug: #1587960
Related-Bug: #1544446
Related-Bug: #1478310
Related-Bug: #1543050
Related-Bug: #1495699

tags: added: release-notes-done
removed: release-notes

Change abandoned by Fuel DevOps Robot (<email address hidden>) on branch: stable/8.0
Review: https://review.openstack.org/277468
Reason: This review is > 4 weeks without comment, and failed Jenkins the last time it was checked. We are abandoning this for now. Feel free to reactivate the review by pressing the restore button and leaving a 'recheck' comment to get fresh test results.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers