Cluster has 'new' status after deployment

Bug #1542201 reported by Julia Aranovich on 2016-02-05
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Fuel for OpenStack
Medium
Bulat Gaifullin

Bug Description

STR:

1) create default environment and add some nodes
2) start 'provisioning' task for the environment (UI sends PUT /api/clusters/<cluster_id>/provision request with empty data to start the task). All the environment nodes will be provisioned.
3) start 'deployment' task for the environment (UI sends PUT /api/clusters/<cluster_id>/deploy request with empty data to start the task). All the environment nodes will be deployed.
4) check the environment status

Expected result: the environment status should be 'operational', as well as all nodes are deployed
Actual result: the environment status is 'new'. At the same time the environment has is_locked == true attribute.

Ihor Kalnytskyi (ikalnytskyi) wrote :

Hm.. I think it wasn't a bug. You see, by design we do not operate with cluster statuses on such low-level API calls like provision or deploy of selected nodes, and you use precisely them.

I think it should be discussed, because otherwise some use-cases may be broken.

Changed in fuel:
status: New → Confirmed
importance: Undecided → Medium
Evgeniy L (rustyrobot) wrote :

+1 to Igor, the thing is it mustn't be operational, because with separate provisioning/deployment you easily may get unoperational cluster, even if separate deploy/provision succeed.
From year to year we are coming to a conclusion that cluster status should be calculated based on statuses of the nodes in the cluster.
And we will probably need to introduce some different status, to show, that the env is not new, and at the same time it's not ready.

Changed in fuel:
assignee: Fuel Python Team (fuel-python) → Bulat Gaifullin (bgaifullin)
Dmitry Pyzhov (dpyzhov) wrote :

I guess there are other cases. For example when we remove nodes in 'Error' state from partially deployed cluster. I hope you take them into account.

Fix proposed to branch: master
Review: https://review.openstack.org/279404

Changed in fuel:
status: Confirmed → In Progress
Aleksey Kasatkin (alekseyk-ru) wrote :

We have a corresponding story already:

https://bugs.launchpad.net/fuel/+bug/1449086

http://lists.openstack.org/pipermail/openstack-dev/2015-May/064580.html

Should we mark current bug as duplicate of 1449086 ?

Changed in fuel:
assignee: Bulat Gaifullin (bgaifullin) → Alexey Shtokolov (ashtokolov)
Changed in fuel:
assignee: Alexey Shtokolov (ashtokolov) → Bulat Gaifullin (bgaifullin)

Reviewed: https://review.openstack.org/279404
Committed: https://git.openstack.org/cgit/openstack/fuel-web/commit/?id=72499871b7a0c89915d4fa5d91d12b332e0c9624
Submitter: Jenkins
Branch: master

commit 72499871b7a0c89915d4fa5d91d12b332e0c9624
Author: Bulat Gaifullin <email address hidden>
Date: Fri Feb 12 10:41:25 2016 +0300

    Fixed cluster state transitions

    Added new status for cluster:
    * partially_deployed - the nodes of cluster has different statuses.

    Change-Id: I5be8c4ed5f58e2c6545a7f06b8eab1ae37c8575f
    Closes-Bug: 1542201

Changed in fuel:
status: In Progress → Fix Committed

Change abandoned by Kate Pimenova (<email address hidden>) on branch: master
Review: https://review.openstack.org/284557
Reason: commit moved to fuel-ui repo

Reviewed: https://review.openstack.org/286538
Committed: https://git.openstack.org/cgit/openstack/fuel-ui/commit/?id=3caf308458b564ef9b0178b326fd7ac7bd85deb5
Submitter: Jenkins
Branch: master

commit 3caf308458b564ef9b0178b326fd7ac7bd85deb5
Author: Kate Pimenova <email address hidden>
Date: Tue Mar 1 15:19:14 2016 +0300

    UI changes for partially_deployed cluster status

    Related-bug: #1542201

    Change-Id: I52b4c0db59088b6518a79292d9737be83732adca

tags: added: on-verification
Mikhail Samoylov (msamoylov) wrote :

Verified on fuel ISO #490

tags: removed: on-verification
Changed in fuel:
status: Fix Committed → Fix Released
tags: added: release-notes
tags: added: release-notes-done
removed: release-notes
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers