MOS snapshots should be used for BVTs & system tests

Bug #1540476 reported by Ihor Kalnytskyi on 2016-02-01
34
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Fuel for OpenStack
Wishlist
Andrey Lavrentyev
Mitaka
Wishlist
Andrey Lavrentyev
Newton
Wishlist
Andrey Lavrentyev

Bug Description

When we run our tests, we use frozen snapshots for Ubuntu. We must use the same technique for our OpenStack repos. Otherwise, we got a lot of failed deployment during development cycle due to mirror are updated very often.

See such bugs:

- bug #1539025
- bug #1524855

Basically:

- Fuel QA must be able to replace repos for MOS repos in the same way it does for Ubuntu repos.
- CI must be able to pass such snapshots to Fuel QA
- Snapshots must be replaces not only in openstack.yaml, but in fuel-mirror / fuel-menu configs.

Setting High prio, since the close we to release, the often we encounter this issue and it stops development. I'd really appreciate if it'll be addressed as soon as possible.

Tatyanka (tatyana-leontovich) wrote :

1. Please provide more details what do you need exactly and where we can get data/repo exapmples for tests

Changed in fuel:
status: New → Incomplete
Nastya Urlapova (aurlapova) wrote :

@Igor, I think your issue is duplicate for https://bugs.launchpad.net/fuel/+bug/1540432

Changed in fuel:
status: Incomplete → Confirmed
tags: added: area-qa feature
Nastya Urlapova (aurlapova) wrote :

@Igor, issues was closed since packaging CI flow should cover cases that you provided. If you will see any gaps, please transform issue to US.

Changed in fuel:
status: Confirmed → Invalid
Roman Podoliaka (rpodolyaka) wrote :

Sergey Nikitin wrote a very good comment on what's happening now, but added it to the wrong bug:

https://bugs.launchpad.net/fuel/+bug/1556936/comments/2

Changed in fuel:
status: Invalid → Confirmed
Roman Podoliaka (rpodolyaka) wrote :

Fuel QA, please take a look at recent failures of CI jobs ^

Nastya Urlapova (aurlapova) wrote :

@Roma, my point was very simple, you you see gaps on CI please file dedicated issue and other thing we cannot use snapshot of MOS repos for mos testing.

Changed in fuel:
status: Confirmed → Invalid

Fix proposed to branch: master
Review: https://review.openstack.org/294608

Changed in fuel:
assignee: Fuel QA Team (fuel-qa) → Andrey Lavrentyev (alavrentyev)
status: Invalid → In Progress
Nastya Urlapova (aurlapova) wrote :

@Igor, Roman, first of all we already use mos snapshot while building ISO https://product-ci.infra.mirantis.net/job/9.0.all/93/artifact/artifacts/mos_centos_mirror_id.txt and https://product-ci.infra.mirantis.net/job/9.0.all/93/artifact/artifacts/mos_ubuntu_mirror_id.txt. Second point these original failures were related to ubuntu bootstrap, which doesn't support snapshots.
So if you you avoid such failures, please make sure that ubuntu bootstrap can work with snapshots.

Changed in fuel:
status: In Progress → Won't Fix
status: Won't Fix → Invalid
status: Invalid → Opinion
Changed in fuel:
importance: High → Wishlist
Roman Podoliaka (rpodolyaka) wrote :

@Nastya, https://bugs.launchpad.net/fuel/8.0.x/+bug/1524855 (building of ubuntu bootstrap image fails with 404) was marked as a duplicate of this bug.

I can't understand why this bug (based on the description) should not also cover building of the bootstrap image.

Ihor Kalnytskyi (ikalnytskyi) wrote :

@Nastya,

fuel-bootstrap does support snapshots, all you need is to pass snapshot to its config. See details in my response here:

    https://bugs.launchpad.net/fuel/8.0.x/+bug/1524855/comments/28

Still I filed this bug because at that moment fuel-qa was unable to:

* Pass OpenStack snapshots for deployment
* Pass OpenStack snapshots for fuel-bootstrap
* Pass OpenStack snapshots for fuel-mirror

Without those abilities

* We can't guarantee test reproducibility (repo is changed - test stop failing)
* We are affected by online repo updates which cause random failures with "No Release" file found during deployment.

If it's not the case anymore, and

* fuel-qa does support passing OpenStack snapshot to deployment, fuel-bootstrap and fuel-mirror
* fuel ci uses snapshots for tests

Feel free to close that ticket as Fix Committed. If there's something to be done by other team (e.g. infra team), please feel free to assign it to other team. Until then, I raise priority to High since it cause a lot of troubles in the end of Fuel 8.0 release cycle and I don't want to see them in the end of 9.0.

Changed in fuel:
importance: Wishlist → High
status: Opinion → Confirmed
Nastya Urlapova (aurlapova) wrote :

@Igor, yep i found that functionality in bootstrap. Nevertheless smoke/BVT and SWARM get MOS-repos from ISO, please find these in my comment above.
We shouldn't use MOS-repos snapshot for these tests because we don't use extra repos for prod testing.
Snapshot injection is useful only in one case - with extra repos testing.

Changed in fuel:
status: Confirmed → Won't Fix
status: Won't Fix → Opinion
importance: High → Medium
importance: Medium → Wishlist

Reproduced again on SWARM

HTTPError: 404 Client Error: Not Found for url: http://mirror.fuel-infra.org/mos-repos/ubuntu/9.0/dists/mos9.0-security/Release

Fix proposed to branch: master
Review: https://review.openstack.org/302275

Changed in fuel:
status: Opinion → In Progress
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers