Generating diagnostic snapshot is broken. exit code: 1 stderr:

Bug #1528815 reported by Anastasia Palkina on 2015-12-23
28
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Fuel for OpenStack
Critical
Oleg S. Gelbukh

Bug Description

1. Install ISO #338
2. Open Fuel UI
3. Open "Support" page and click "Generate snapshot" button
4. Error appears: exit code: 1 stderr:

VERSION:
  feature_groups:
    - mirantis
  production: "docker"
  release: "8.0"
  api: "1.0"
  build_number: "338"
  build_id: "338"
  fuel-nailgun_sha: "bad4d014df29beaf3708f1a050e808d20542b878"
  python-fuelclient_sha: "268847aa06e16f42bb3a3bf851a1869adfc36c46"
  fuel-agent_sha: "1d3a2b8d9e8961ebcdfa5db55e2e809f7dd404a8"
  fuel-nailgun-agent_sha: "92ebd5ade6fab60897761bfa084aefc320bff246"
  astute_sha: "c7ca63a49216744e0bfdfff5cb527556aad2e2a5"
  fuel-library_sha: "7a7c93e8b55d0e3e9ffd64b0b0e29451cdc0cfb0"
  fuel-ostf_sha: "d8cbc4f65361e034193479b19f84747d1c33894e"
  fuel-mirror_sha: "d15edd2128b9a4644f1db8089b0ecdf7954a2e57"
  fuelmenu_sha: "2942a85796d37f09ba8c8c6d762d8813292cf0d4"
  shotgun_sha: "bf79f1ac08a256160f2835a71808ec4f8d2bbf9e"
  network-checker_sha: "d443ef47abeda58d319bc8d33d5005dd09440a02"
  fuel-upgrade_sha: "616a7490ec7199f69759e97e42f9b97dfc87e85b"
  fuelmain_sha: "796125856c2325743124092a52f28e26c013c058"

Anastasia Palkina (apalkina) wrote :
Maciej Relewicz (rlu) on 2015-12-23
Changed in fuel:
assignee: nobody → Fuel UI Team (fuel-ui)
tags: added: area-ui
Vitaly Kramskikh (vkramskikh) wrote :

Seems to be nailgun issue

Changed in fuel:
assignee: Fuel UI Team (fuel-ui) → Fuel Python Team (fuel-python)
tags: added: area-python
removed: area-ui
slava valyavskiy (slava-val-al) wrote :

From astute log.

  {:stdout=>
    "2015-12-23 10:14:17 DEBUG 1159 (manager) Initializing snapshot manager\n2015-12-23 10:14:17 DEBUG 1159 (manager) Making snapshot\n2015-12-23 10:14:17 DEBUG 1159 (utils) Trying to execute command: rm -rf /var/www/nailgun/dump\n2015-12-23 10:14:17 DEBUG 1159 (manager) Dumping: {u'username': u'nailgun', u'dbhost': u'10.20.0.2', 'host': {}, u'password': u'K2Bbh65g', u'type': u'postgres', u'dbname': u'nailgun'}\n2015-12-23 10:14:17 DEBUG 1159 (driver) Initializing driver Postgres: host={}\n2015-12-23 10:14:17 DEBUG 1159 (driver) Running local command: mktemp\n2015-12-23 10:14:17 DEBUG 1159 (utils) Trying to execute command: mktemp\nTraceback (most recent call last):\n File \"/usr/bin/shotgun\", line 9, in <module>\n load_entry_point('shotgun==8.0.0', 'console_scripts', 'shotgun')()\n File \"/usr/lib/python2.7/site-packages/shotgun/cli.py\", line 71, in main\n make_snapshot(parse_args())\n File \"/usr/lib/python2.7/site-packages/shotgun/cli.py\", line 65, in make_snapshot\n snapshot_path = manager.snapshot()\n File \"/usr/lib/python2.7/site-packages/shotgun/manager.py\", line 37, in snapshot\n self.snapshot_single(obj_data)\n File \"/usr/lib/python2.7/site-packages/shotgun/manager.py\", line 52, in snapshot_single\n driver.snapshot()\n File \"/usr/lib/python2.7/site-packages/shotgun/driver.py\", line 224, in snapshot\n temp = self.command(\"mktemp\").output.strip()\nAttributeError: 'NoneType' object has no attribute 'strip'\n",
   :stderr=>"",
   :exit_code=>1}}

Changed in fuel:
status: New → Confirmed
Dmitry Pyzhov (dpyzhov) wrote :

Looks like regression after fix for bug #1526081

tags: added: team-bugfix

Fix proposed to branch: master
Review: https://review.openstack.org/260970

Changed in fuel:
assignee: Fuel Python Team (fuel-python) → Oleg S. Gelbukh (gelbuhos)
status: Confirmed → In Progress

Fix proposed to branch: stable/8.0
Review: https://review.openstack.org/261342

Changed in fuel:
status: In Progress → Fix Released

Reviewed: https://review.openstack.org/260970
Committed: https://git.openstack.org/cgit/openstack/shotgun/commit/?id=5663fb6b81d3b9e7f1b6117e35de7ef746797874
Submitter: Jenkins
Branch: master

commit 5663fb6b81d3b9e7f1b6117e35de7ef746797874
Author: Oleg Gelbukh <email address hidden>
Date: Wed Dec 23 12:51:11 2015 +0000

    Set output for local command

    Set 'output' property for local command. This is required for
    'mktemp' to work similarly in both cases (local and remote
    command).

    Change-Id: Ic4efe586683424c7145e811aa3495cf23e8f550e
    Closes-bug: 1528815

Changed in fuel:
status: Fix Released → Fix Committed

Reviewed: https://review.openstack.org/261106
Committed: https://git.openstack.org/cgit/openstack/fuel-qa/commit/?id=d216569f0ace89feea5831342e3d5b76eeb3fa6c
Submitter: Jenkins
Branch: master

commit d216569f0ace89feea5831342e3d5b76eeb3fa6c
Author: Artem Panchenko <email address hidden>
Date: Wed Dec 23 23:29:28 2015 +0200

    Check that snapshot is 'ready' before download

    Tests must skip snapshot downloading if the task
    for its generation failed.

    Change-Id: Ib8f0d47bd748415f3a1bcfa0b1c2217963519423
    Related-bug: #1528815

tags: added: on-verification

Reviewed: https://review.openstack.org/261342
Committed: https://git.openstack.org/cgit/openstack/shotgun/commit/?id=63645dea384a37dde5c01d4f8905566978e5d906
Submitter: Jenkins
Branch: stable/8.0

commit 63645dea384a37dde5c01d4f8905566978e5d906
Author: Oleg Gelbukh <email address hidden>
Date: Wed Dec 23 12:51:11 2015 +0000

    Set output for local command

    Set 'output' property for local command. This is required for
    'mktemp' to work similarly in both cases (local and remote
    command).

    Change-Id: Ic4efe586683424c7145e811aa3495cf23e8f550e
    Closes-bug: 1528815

Anastasia Palkina (apalkina) wrote :

Verified on ISO #362

VERSION:
  feature_groups:
    - mirantis
  production: "docker"
  release: "8.0"
  api: "1.0"
  build_number: "362"
  build_id: "362"
  fuel-nailgun_sha: "53c72a9600158bea873eec2af1322a716e079ea0"
  python-fuelclient_sha: "4f234669cfe88a9406f4e438b1e1f74f1ef484a5"
  fuel-agent_sha: "7463551bc74841d1049869aaee777634fb0e5149"
  fuel-nailgun-agent_sha: "92ebd5ade6fab60897761bfa084aefc320bff246"
  astute_sha: "c7ca63a49216744e0bfdfff5cb527556aad2e2a5"
  fuel-library_sha: "ba8063d34ff6419bddf2a82b1de1f37108d96082"
  fuel-ostf_sha: "889ddb0f1a4fa5f839fd4ea0c0017a3c181aa0c1"
  fuel-mirror_sha: "8adb10618bb72bb36bb018386d329b494b036573"
  fuelmenu_sha: "824f6d3ebdc10daf2f7195c82a8ca66da5abee99"
  shotgun_sha: "63645dea384a37dde5c01d4f8905566978e5d906"
  network-checker_sha: "9f0ba4577915ce1e77f5dc9c639a5ef66ca45896"
  fuel-upgrade_sha: "616a7490ec7199f69759e97e42f9b97dfc87e85b"
  fuelmain_sha: "07d5f1c3e1b352cb713852a3a96022ddb8fe2676"

Changed in fuel:
status: Fix Committed → Fix Released
tags: removed: on-verification

Reviewed: https://review.openstack.org/261355
Committed: https://git.openstack.org/cgit/openstack/fuel-qa/commit/?id=c9a5aad1caa9d2b7f89ede6782cec72502841cf1
Submitter: Jenkins
Branch: stable/8.0

commit c9a5aad1caa9d2b7f89ede6782cec72502841cf1
Author: Artem Panchenko <email address hidden>
Date: Wed Dec 23 23:29:28 2015 +0200

    Check that snapshot is 'ready' before download

    Tests must skip snapshot downloading if the task
    for its generation failed.

    Change-Id: Ib8f0d47bd748415f3a1bcfa0b1c2217963519423
    Related-bug: #1528815

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments