Nailgun python requirements conflict with python-novaclient dependencies

Bug #1528149 reported by Artem Roma on 2015-12-21
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Fuel for OpenStack
Critical
Artem Roma

Bug Description

Nailgun package cannot be used because of conflict with requirements of the python-novaclient.

Nailgun unit tests 'test_check_requirements_conflicts' fails with following message:
ContextualVersionConflict: (requests 2.9.0 (/home/aroma/.virtualenvs/fuel-web/lib/python2.7/site-packages), Requirement.parse('requests!=2.9.0,>=2.8.1'), set(['python-novaclient']))

There is difference between 'requests' package requirement for Nailgun [1] and OpenStack global requirements [2]. Hence we must update former to eliminate the issue.

[1]: https://github.com/openstack/fuel-web/blob/master/nailgun/requirements.txt#l25
[2]: https://github.com/openstack/requirements/blame/stable/liberty/global-requirements.txt#l185-l186

Fix proposed to branch: master
Review: https://review.openstack.org/259919

Changed in fuel:
status: Confirmed → In Progress

Reviewed: https://review.openstack.org/259919
Committed: https://git.openstack.org/cgit/openstack/fuel-web/commit/?id=e7fa62d6a220301f16d52d34541b7e8a334c9784
Submitter: Jenkins
Branch: master

commit e7fa62d6a220301f16d52d34541b7e8a334c9784
Author: Artem Roma <email address hidden>
Date: Mon Dec 21 12:06:08 2015 +0200

    Update Nailgun python requirements

    Synchronize 'requests' requirement with OpenStack global requirements.

    Change-Id: Ie556a2ed224963a3e99ce1c54455c1f8921d5909
    Closes-Bug: #1528149

Changed in fuel:
status: In Progress → Fix Committed
Tatyanka (tatyana-leontovich) wrote :

all ok on rev f81311bbd6fee2665e3f96dcac55f72889b2f38

Changed in fuel:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers