fuelmenu fails to run due to usage of "value" field in UI scheme

Bug #1515530 reported by Vladimir Kozhukalov on 2015-11-12
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Fuel for OpenStack
Critical
Vladimir Kozhukalov

Bug Description

Steps to reproduce:
1. Launch fuelmenu with cmd: `fuelmenu`

Expected behavior:
fuelmenu launched

Actual result:
[root@fuel ~]# fuelmenu
Traceback (most recent call last):
  File "/usr/bin/fuelmenu", line 9, in <module>
    load_entry_point('fuelmenu==8.0.0', 'console_scripts', 'fuelmenu')()
  File "/usr/lib/python2.6/site-packages/fuelmenu/fuelmenu.py", line 470, in main
    setup()
  File "/usr/lib/python2.6/site-packages/fuelmenu/fuelmenu.py", line 328, in setup
    FuelSetup()
  File "/usr/lib/python2.6/site-packages/fuelmenu/fuelmenu.py", line 92, in __init__
    self.main()
  File "/usr/lib/python2.6/site-packages/fuelmenu/fuelmenu.py", line 255, in main
    self.setChildScreen(name=child.name)
  File "/usr/lib/python2.6/site-packages/fuelmenu/fuelmenu.py", line 142, in setChildScreen
    self.child.screen = self.child.screenUI()
  File "/usr/lib/python2.6/site-packages/fuelmenu/modules/feature_groups.py", line 128, in screenUI
    self.defaults, showallbuttons=True)
  File "/usr/lib/python2.6/site-packages/fuelmenu/common/modulehelper.py", line 223, in screenUI
    toolbar))
  File "/usr/lib/python2.6/site-packages/fuelmenu/common/modulehelper.py", line 203, in _create_widget
    ispassword=ispassword)
  File "/usr/lib/python2.6/site-packages/fuelmenu/common/urwidwrapper.py", line 35, in TextField
    mask=mask, wrap='clip')
  File "/usr/lib/python2.6/site-packages/fuelmenu/common/urwidwrapper.py", line 207, in __init__
    mask=mask, wrap=wrap)
  File "/usr/lib64/python2.6/site-packages/urwid/widget.py", line 1162, in __init__
    self.set_edit_text(edit_text)
  File "/usr/lib64/python2.6/site-packages/urwid/widget.py", line 1358, in set_edit_text
    if self.edit_pos > len(text):
TypeError: object of type 'int' has no len()

This patch uses old defaults field names while they were renamed recently.

Fix proposed to branch: master
Review: https://review.openstack.org/244511

Changed in fuel:
status: Confirmed → In Progress
summary: - fuelmenu fails to run due to https://review.openstack.org/#/c/241970/
+ fuelmenu fails to run due to usage of "value" field in UI scheme
description: updated

Reviewed: https://review.openstack.org/244511
Committed: https://git.openstack.org/cgit/openstack/fuel-menu/commit/?id=85801f65eb046d946a074fb60a760f574077de29
Submitter: Jenkins
Branch: master

commit 85801f65eb046d946a074fb60a760f574077de29
Author: Vladimir Kozhukalov <email address hidden>
Date: Thu Nov 12 12:08:39 2015 +0300

    Fix wrong defaults data structure in feature_groups module

    Change-Id: I7dce3e300ee6772b563ea7f78cf0b32f69a46eb8
    Closes-Bug: #1515530

Changed in fuel:
status: In Progress → Fix Committed
tags: added: area-python module-fuelmenu regression-8.0
Dmitry Pyzhov (dpyzhov) on 2015-11-12
Changed in fuel:
milestone: none → 8.0
Dmitry Kalashnik (dkalashnik) wrote :

Verified on ISO#152

Changed in fuel:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers