[ISO build] Dependency issue with installing npm in chroot

Bug #1515219 reported by Sergey Kulanov on 2015-11-11
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Fuel for OpenStack
High
Artem Silenkov

Bug Description

We have an issue while building ISO and installing npm package in chroot (used for building RPM packages):
Please check the log from community ISO [1]:
Package nodejs-rimraf is obsoleted by nodejs-nailgun, but obsoleting package does not provide for requirements
--> Processing Dependency: npm(glob) >= 3.2.3 for package: npm-1.3.6-5.el6.noarch
Package nodejs-glob is obsoleted by nodejs-nailgun, but obsoleting package does not provide for requirements
--> Finished Dependency Resolution
Error: Package: npm-1.3.6-5.el6.noarch (epel)
           Requires: npm(glob) < 3.3
           Available: nodejs-glob-3.2.6-1.el6.noarch (epel)
               npm(glob) = 3.2.6
Error: Package: nodejs-read-package-json-1.1.3-1.el6.noarch (epel)
           Requires: npm(glob) >= 3.2.1
           Available: nodejs-glob-3.2.6-1.el6.noarch (epel)
               npm(glob) = 3.2.6
Error: Package: nodejs-read-package-json-1.1.3-1.el6.noarch (epel)
           Requires: npm(glob) < 3.3
           Available: nodejs-glob-3.2.6-1.el6.noarch (epel)
               npm(glob) = 3.2.6
Error: Package: node-gyp-0.10.6-2.el6.noarch (epel)
           Requires: npm(glob) < 4
           Available: nodejs-glob-3.2.6-1.el6.noarch (epel)
               npm(glob) = 3.2.6
Error: Package: nodejs-fstream-0.1.24-1.el6.noarch (epel)
           Requires: npm(rimraf) >= 2
           Available: nodejs-rimraf-2.2.2-1.el6.noarch (epel)
               npm(rimraf) = 2.2.2
Error: Package: npm-1.3.6-5.el6.noarch (epel)
           Requires: npm(rimraf) < 2.3
           Available: nodejs-rimraf-2.2.2-1.el6.noarch (epel)
               npm(rimraf) = 2.2.2
Error: Package: node-gyp-0.10.6-2.el6.noarch (epel)
           Requires: npm(rimraf) >= 2
           Available: nodejs-rimraf-2.2.2-1.el6.noarch (epel)
               npm(rimraf) = 2.2.2
Error: Package: node-gyp-0.10.6-2.el6.noarch (epel)
           Requires: npm(glob) >= 3
           Available: nodejs-glob-3.2.6-1.el6.noarch (epel)
               npm(glob) = 3.2.6
Error: Package: node-gyp-0.10.6-2.el6.noarch (epel)
           Requires: npm(rimraf) < 3
           Available: nodejs-rimraf-2.2.2-1.el6.noarch (epel)
               npm(rimraf) = 2.2.2
Error: Package: nodejs-npm-registry-client-0.2.28-3.el6.noarch (epel)
           Requires: npm(rimraf) >= 2
           Available: nodejs-rimraf-2.2.2-1.el6.noarch (epel)
               npm(rimraf) = 2.2.2
Error: Package: npm-1.3.6-5.el6.noarch (epel)
           Requires: npm(glob) >= 3.2.3
           Available: nodejs-glob-3.2.6-1.el6.noarch (epel)
               npm(glob) = 3.2.6
Error: Package: nodejs-fstream-0.1.24-1.el6.noarch (epel)
           Requires: npm(rimraf) < 3
           Available: nodejs-rimraf-2.2.2-1.el6.noarch (epel)
               npm(rimraf) = 2.2.2
Error: Package: npm-1.3.6-5.el6.noarch (epel)
           Requires: npm(rimraf) >= 2.2.0
           Available: nodejs-rimraf-2.2.2-1.el6.noarch (epel)
               npm(rimraf) = 2.2.2
Error: Package: nodejs-npm-registry-client-0.2.28-3.el6.noarch (epel)
           Requires: npm(rimraf) < 3
           Available: nodejs-rimraf-2.2.2-1.el6.noarch (epel)
               npm(rimraf) = 2.2.2
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
Loaded plugins: priorities
566 packages excluded due to repository priority protections
Setting up Install Process

https://ci.fuel-infra.org/view/ISO/job/8.0-community.all/93/consoleText

Changed in fuel:
assignee: nobody → Artem Silenkov (asilenkov)
Changed in fuel:
status: New → Confirmed
Artem Silenkov (asilenkov) wrote :

This issue is fixed by nodejs-nailgun >= ~mos8.0.5

Changed in fuel:
status: Confirmed → Fix Committed

On MOS 8.0 569 build:

[root@fuel ~]# yum info nodejs-nailgun
Loaded plugins: fastestmirror, priorities
Loading mirror speeds from cached hostfile
Available Packages
Name : nodejs-nailgun
Arch : x86_64
Version : 1
Release : 1.el7~mos7
Size : 60 M
Repo : mos
Summary : Automatically generated package for nailgun node_modules
License : Copyright Joyent, Inc. and other Node contributors.
Description : Automatically generated package for nailgun node_modules+

Changed in fuel:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers