[Openstack] [Fuel] Building ISO from 8.0 master branch fails

Bug #1511696 reported by Sergey Kulanov on 2015-10-30
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Fuel for OpenStack
High
Sergey Kulanov

Bug Description

I am trying to build Fuel 8.0 ISO from github repository, following the
https://docs.fuel-infra.org/fuel-dev/buildsystem.html documentation:

git clone https://github.com/openstack/fuel-main.git cd fuel-main
./prepare-build-env.sh
make iso

I get the following error:

Unable to resolve packages dependencies
http://mirror.fuel-infra.org/fwm/8.0/centos/os/x86_64/repodata/repomd.xml:
[Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 404 Not
Found"
Trying other mirror.
Cannot retrieve repository metadata (repomd.xml) for repository:
proprietary. Please verify its path and try again
make: *** [/home/stan/fuel-main/build/mirror/centos/urls.list] Error 1

The Mirantis repository http://mirror.fuel-infra.org doesn't include a
/fwm/8.0/ path. I tried to change the path to fwm/7.0 in config.mk, but
I kept getting other errors (No Match for argument nodejs-backbone make:
*** [/home/stan/fuel-main/build/mirror/centos/urls.list] Error 1). I
also tried with other repositories (ex. usa) - same result. I had no
problem building from 7.0 sources on the same machine so it's definitely
not a network related problem.

My building machine runs Ubuntu 14.04.3 LTS

Did anybody try to build Fuel 8.0 from source?
Am I doing something wrong?

Thanks for Your feedback!

-
Stanisław Dałek
CloudFerro Sp. z o.o.
ul. Nowogrodzka 31
02-511 Warszawa,
tel: 223546573
NIP: 7010468205

Biuro Handlowe:
ul. Wielicka 38 U4
02-657 Warszawa

-------------- next part --------------
A non-text attachment was scrubbed...
Name: sdalek.vcf
Type: text/x-vcard
Size: 199 bytes
Desc: not available
URL: <http://lists.openstack.org/pipermail/openstack/attachments/20151030/db78e6f9/attachment.vcf>

Sergey Kulanov (skulanov) wrote :

While fixing as a workaround is:

# export values
export MIRROR_FUEL=http://mirror.fuel-infra.org/mos-repos/centos/mos8.0-centos6-fuel/os/x86_64/
export SANDBOX_MIRROR_CENTOS_UPSTREAM=http://vault.centos.org/6.6/
export MIRROR_CENTOS=http://vault.centos.org/6.6/
export MIRROR_MOS_UBUNTU=mirror.fuel-infra.org
export MIRROR_UBUNTU=mirror.fuel-infra.org
export USE_MIRROR=none

# run make iso
make iso

or one liner
MIRROR_FUEL=http://mirror.fuel-infra.org/mos-repos/centos/mos8.0-centos6-fuel/os/x86_64/ SANDBOX_MIRROR_CENTOS_UPSTREAM=http://vault.centos.org/6.6/ MIRROR_CENTOS=http://vault.centos.org/6.6/ MIRROR_MOS_UBUNTU=mirror.fuel-infra.org MIRROR_UBUNTU=mirror.fuel-infra.org USE_MIRROR=none make iso

Changed in fuel:
assignee: nobody → Sergey Kulanov (skulanov)
status: New → In Progress

Reviewed: https://review.openstack.org/240524
Committed: https://git.openstack.org/cgit/openstack/fuel-main/commit/?id=4b1f91ad496c571e4cbc5931134db6479e582c8b
Submitter: Jenkins
Branch: master

commit 4b1f91ad496c571e4cbc5931134db6479e582c8b
Author: Sergey Kulanov <email address hidden>
Date: Fri Oct 30 14:18:20 2015 +0200

    Update mirror list for ISO build

    Since we don't have staging mirror process we need to update
    mirror lists

    Closes-bug: #1511696

    Change-Id: I2b1027255c655d51578b0b3ab58189dced911aa7

Changed in fuel:
status: In Progress → Fix Committed
Roman Vyalov (r0mikiam) on 2015-11-05
tags: added: area-build
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers