[docs] Create docs for seed server installation

Bug #1510551 reported by Artur Kaszuba on 2015-10-27
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Fuel for OpenStack
Medium
Mateusz Matuszkowiak

Bug Description

We need to describe how to install seed server from puppet manifests.
This server store iso files which are used by systest jobs, it is required by CI.

Please describe:
- system requirements for seed
- how to install seed server from puppet manifests, describe changes required in hiera and on puppet server
- other changes required to use it

Igor Shishkin (teran) wrote :

The same as here: https://bugs.launchpad.net/fuel/+bug/1510556
Please provide more details.

Changed in fuel:
status: New → Incomplete
importance: Undecided → Medium
milestone: none → 8.0
tags: added: area-devops devops
Artur Kaszuba (akaszuba) wrote :

In scenario with basic CI i need only shared place for builded ISO, with upload access from slaves.

I dont check how exactly seed works and where it is used, sorry if my description is not precise :)
That what i test already requires:
- allow ISO upload from slave (i set it in fuel_project::apps::seed::vhost_acl_allow)
- allow download ISO from torrent (i assume there should be torrent tracker installed on seed server)

For my tests i took hiera role example and remove from there partnershare and partnerappliance. Probably we can remove more but i dont had time to test it more accurately. My hiera for seed.test.local looks like this:
---
classes:
  - '::fuel_project::common'
  - '::fuel_project::apps::seed'
  - '::fuel_project::apps::mirror'
  - '::fuel_project::apps::plugins'
  - '::fuel_project::apps::updates'
# - '::fuel_project::apps::partnerappliance'
# - '::fuel_project::apps::partnershare'

#fuel_project::common::external_host: true

fuel_project::apps::seed::vhost_acl_allow:
  - 127.0.0.1
  - 10.0.0.0/8

fuel_project::apps::seed::external_host: true
fuel_project::apps::seed::apply_firewall_rules: true
fuel_project::apps::seed::tracker_apply_firewall_rules: true
fuel_project::apps::seed::seed_cleanup_dirs:
  -
    dir: '/var/www/seed/fuelweb-iso'
    ttl: 10
    pattern: 'fuel-*'

fuel_project::apps::mirror::apply_firewall_rules: true
fuel_project::apps::plugins::apply_firewall_rules: true
fuel_project::apps::updates::apply_firewall_rules: true

Artur Kaszuba (akaszuba) on 2015-11-18
description: updated
information type: Private → Public
Artur Kaszuba (akaszuba) wrote :

@Igor, do you need some additional informations about this bug? It still have Incomplete status.

Igor Shishkin (teran) wrote :

@Artur, no, everything is good now. Confirmed state set.

Changed in fuel:
status: Incomplete → Confirmed
Changed in fuel:
assignee: Fuel DevOps (fuel-devops) → Mateusz Matuszkowiak (mmatuszkowiak)
status: Confirmed → In Progress

Reviewed: https://review.openstack.org/259962
Committed: https://git.openstack.org/cgit/openstack/fuel-web/commit/?id=cb22d7d6913bc999e892237cd6e313dd6c198801
Submitter: Jenkins
Branch: master

commit cb22d7d6913bc999e892237cd6e313dd6c198801
Author: Mateusz Matuszkowiak <email address hidden>
Date: Wed Dec 30 10:48:50 2015 +0100

    seed server deployment docs related to Fuels infra

    Change-Id: Ic891b69cda21fdaadfb63bd6d04eadfe8422de73
    Related-Bug: #1510551

Changed in fuel:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers