Activity log for bug #1504572

Date Who What changed Old value New value Message
2015-10-09 14:40:28 Ihor Kalnytskyi bug added bug
2015-10-16 13:09:01 Aleksey Kasatkin tags feature-advanced-networking module-nailgun tricky feature-validation module-nailgun tricky
2015-10-22 03:11:33 Dmitry Pyzhov tags feature-validation module-nailgun tricky area-python feature-validation module-nailgun tricky
2015-11-20 19:51:06 Dmitry Pyzhov tags area-python feature-validation module-nailgun tricky area-python feature-validation module-nailgun team-bugfix tricky
2015-12-08 14:03:36 Dmitry Pyzhov fuel: assignee Fuel Python Team (fuel-python) Roman Prykhodchenko (romcheg)
2015-12-22 11:52:32 OpenStack Infra fuel: status Confirmed In Progress
2015-12-22 11:52:32 OpenStack Infra fuel: assignee Roman Prykhodchenko (romcheg) Maciej Kwiek (maciej-iai)
2015-12-28 17:08:10 OpenStack Infra fuel: assignee Maciej Kwiek (maciej-iai) Roman Prykhodchenko (romcheg)
2016-01-19 13:54:04 Dmitry Pyzhov nominated for series fuel/8.0.x
2016-01-19 13:54:04 Dmitry Pyzhov bug task added fuel/8.0.x
2016-01-19 13:54:10 Dmitry Pyzhov fuel/8.0.x: milestone 8.0
2016-01-19 13:54:12 Dmitry Pyzhov fuel: milestone 8.0 9.0
2016-01-19 13:54:18 Dmitry Pyzhov fuel/8.0.x: assignee Roman Prykhodchenko (romcheg)
2016-01-19 13:54:20 Dmitry Pyzhov fuel/8.0.x: status New In Progress
2016-01-19 13:54:22 Dmitry Pyzhov fuel/8.0.x: importance Undecided High
2016-01-25 12:46:55 Roman Prykhodchenko fuel: status In Progress Fix Committed
2016-01-26 10:33:04 Dmitry Pyzhov fuel: status Fix Committed In Progress
2016-01-28 14:12:14 Aleksandr Didenko description Well, the story is huge and requires some explanations. We *do* have a network_configuration handler that returns (surprise-surprise) network configuration of the cluster. The configuration includes information about networks and VIPs, and it's used on UI on Network tab, so user can change network settings and re-submit it. The problem occurs when we need to allocate VIPs more than we have free IPs in network pool. Since information how many VIPs we need is dynamic and is depended on plugins (since plugins may export network roles), we can't *validate* it on the first place. Moreover, it's depended on which network some netrole is assigned, so we can't and shouldn't forbid user to enable plugin. Still, when new plugin is enabled, and we have not enough free IP addresses for VIPs the errors will be raised. If it's the case, the network_configuration handler will return an HTTP error and UI is unable to handle this case properly. In fact, it looks like user just unable to open some cluster.. and no way to change network settings (except fuel cli). Unfortunately, there's no easy fix for UI.. since they don't know what's wrong. I have no idea how to fix it. Perhaps we should start with removing VIP allocation code from serializing network settings for the API handler. Well, the story is huge and requires some explanations. We *do* have a network_configuration handler that returns (surprise-surprise) network configuration of the cluster. The configuration includes information about networks and VIPs, and it's used on UI on Network tab, so user can change network settings and re-submit it. The problem occurs when we need to allocate VIPs more than we have free IPs in network pool. Since information how many VIPs we need is dynamic and is depended on plugins (since plugins may export network roles), we can't *validate* it on the first place. Moreover, it's depended on which network some netrole is assigned, so we can't and shouldn't forbid user to enable plugin. Still, when new plugin is enabled, and we have not enough free IP addresses for VIPs the errors will be raised. If it's the case, the network_configuration handler will return an HTTP error and UI is unable to handle this case properly. In fact, it looks like user just unable to open some cluster.. and no way to change network settings (except fuel cli). Another way to hit this bug is to move controllers (or other roles that have VIP assigned to them) to different network node groups. In this case Nailgun will try to calculate common node group for VIPs allocation and throw an error because it will find more than 1 common group. Unfortunately, there's no easy fix for UI.. since they don't know what's wrong. I have no idea how to fix it. Perhaps we should start with removing VIP allocation code from serializing network settings for the API handler.
2016-02-01 13:54:15 Ihor Kalnytskyi nominated for series fuel/mitaka
2016-02-01 13:54:15 Ihor Kalnytskyi bug task added fuel/mitaka
2016-02-01 21:21:55 Sergii Golovatiuk bug added subscriber Sergii Golovatiuk
2016-02-02 14:19:38 OpenStack Infra fuel: status In Progress Fix Committed
2016-02-02 15:37:12 Andrew Maksimov tags area-python feature-validation module-nailgun team-bugfix tricky area-python feature-validation hit-hcf module-nailgun team-bugfix tricky
2016-02-03 08:30:48 Sylwester Brzeczkowski fuel/8.0.x: status In Progress Fix Committed
2016-02-11 09:41:53 Mikhail Samoylov tags area-python feature-validation hit-hcf module-nailgun team-bugfix tricky area-python feature-validation hit-hcf module-nailgun on-verification team-bugfix tricky
2016-02-11 11:02:00 Mikhail Samoylov tags area-python feature-validation hit-hcf module-nailgun on-verification team-bugfix tricky area-python feature-validation hit-hcf module-nailgun team-bugfix tricky
2016-02-11 11:02:05 Mikhail Samoylov fuel/8.0.x: status Fix Committed Fix Released
2016-03-29 08:10:01 ElenaRossokhina attachment added fuel_version https://bugs.launchpad.net/fuel/mitaka/+bug/1504572/+attachment/4615650/+files/fuel_version
2016-03-29 08:10:15 ElenaRossokhina fuel/mitaka: status Fix Committed Fix Released