fuel 8.0 with Liberty Openstack provides Kilo as choice of Openstack

Bug #1503663 reported by Igor Marnat on 2015-10-07
24
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Fuel for OpenStack
Critical
Alex Schultz
7.0.x
Undecided
Unassigned

Bug Description

Fuel 8.0 with liberty shows Kilo as Openstack version to install (see screenshots).

Expected behavior: show Liberty

iso: fuel-8.0-6-2015-10-06_18-07-48.iso

fuel version:
{"build_id": "6", "openstack_version": "2015.1.0-8.0", "build_number": "6", "release_versions": {"2015.1.0-8.0": {"VERSION": {"build_id": "6", "openstack_version": "2015.1.0-8.0", "build_number": "6", "api": "1.0", "fuel-library_sha": "e3d2905b9dd2cc7b4d46201ca9816dd320868917", "feature_groups": ["mirantis"], "fuel-nailgun-agent_sha": "d66f188a1832a9c23b04884a14ef00fc5605ec6d", "fuel-nailgun_sha": "70d8b7e80573728e04ac5478c112850afcfa9802", "fuel-agent_sha": "e881f0dabd09af4be4f3e22768b02fe76278e20e", "production": "docker", "python-fuelclient_sha": "56fbd6bad7f60f0944b3845c2db14d0b8cabd4d3", "astute_sha": "0f753467a3f16e4d46e7e9f1979905fb178e4d5b", "fuel-ostf_sha": "41aa5059243cbb25d7a80b97f8e1060a502b99dd", "release": "8.0", "fuelmain_sha": "51614465980e5f62a5796779d3f6c3305c1d5739"}}}, "auth_required": true, "api": "1.0", "fuel-library_sha": "e3d2905b9dd2cc7b4d46201ca9816dd320868917", "feature_groups": ["mirantis"], "fuel-nailgun-agent_sha": "d66f188a1832a9c23b04884a14ef00fc5605ec6d", "fuel-nailgun_sha": "70d8b7e80573728e04ac5478c112850afcfa9802", "fuel-agent_sha": "e881f0dabd09af4be4f3e22768b02fe76278e20e", "production": "docker", "python-fuelclient_sha": "56fbd6bad7f60f0944b3845c2db14d0b8cabd4d3", "astute_sha": "0f753467a3f16e4d46e7e9f1979905fb178e4d5b", "fuel-ostf_sha": "41aa5059243cbb25d7a80b97f8e1060a502b99dd", "release": "8.0", "fuelmain_sha": "51614465980e5f62a5796779d3f6c3305c1d5739"}

Igor Marnat (imarnat) wrote :
Changed in fuel:
status: New → Confirmed
Changed in fuel:
assignee: Fuel UI Team (fuel-ui) → Fuel Library Team (fuel-library)
assignee: Fuel Library Team (fuel-library) → Fuel UI Team (fuel-ui)
assignee: Fuel UI Team (fuel-ui) → Fuel Library Team (fuel-library)
Matthew Mosesohn (raytrac3r) wrote :
Changed in fuel:
assignee: Fuel Library Team (fuel-library) → Fuel Python Team (fuel-python)
tags: added: low-hanging-fruit
Dmitry Pyzhov (dpyzhov) on 2015-10-07
tags: added: regression-8.0
Oleg S. Gelbukh (gelbuhos) wrote :

The interesting question is which version we should specify for Liberty? According to Big Tent policy decision [1], every component in Liberty has it's own version, and there is technically no 2015.2.0 version of OpenStack released.

[1] http://ttx.re/new-versioning.html

Fix proposed to branch: master
Review: https://review.openstack.org/234296

Changed in fuel:
assignee: Fuel Python Team (fuel-python) → Oleg S. Gelbukh (gelbuhos)
status: Confirmed → In Progress

Reviewed: https://review.openstack.org/234296
Committed: https://git.openstack.org/cgit/openstack/fuel-web/commit/?id=3ccba7c2a9e3fc7a9fd7cd1ae4b0d92f4a3cc2f4
Submitter: Jenkins
Branch: master

commit 3ccba7c2a9e3fc7a9fd7cd1ae4b0d92f4a3cc2f4
Author: Oleg Gelbukh <email address hidden>
Date: Tue Oct 13 15:27:42 2015 +0000

    Change release version to Liberty in openstack.yaml

    Set release version name to 'Liberty' in openstack.yaml fixture.
    Set openstack_version to 8.0-liberty

    Closes-bug: 1503663
    Change-Id: I8349dc1d779551cabb5b5c0c0e89934578d9bd2a

Changed in fuel:
status: In Progress → Fix Committed
Dmitry Pyzhov (dpyzhov) on 2015-10-21
tags: added: area-python
Changed in fuel:
status: Fix Committed → In Progress
Dmitry Pyzhov (dpyzhov) on 2015-11-20
tags: added: team-upgrades
Dmitry Pyzhov (dpyzhov) on 2015-11-21
tags: added: blocked
Oleg S. Gelbukh (gelbuhos) wrote :

This change requires 3 coordinated actions:

1. merge patch to nailgun
2. merge patch to fuel-library
3. replace ISO image in fuel infra with an image with new nailgun and fuel-library packages

We need to bring down infra for the duration of this change, as far as I understand.

Oleg S. Gelbukh (gelbuhos) wrote :

For the seamless merge of patches related to this change without introducing new ISO to Fuel CI, I suggest to submit and merge CRs in the following order:

1. Change rules of comparing the OpenStack release version in fuel-ostf to support non-numeric release version ('liberty'): https://review.openstack.org/#/c/251260/
2. Change RPM spec in fuel-library to fetch openstack_version from fuel-openstack-metadata package to dynamically construct the path to Puppet modules. Also copy Puppet modules to /etc/puppet/2015.1.0-8.0/ directory temporary, for backwards compat with the current version of fuel-web. It allows this change to pass Fuel CI check and gate: https://review.openstack.org/#/c/237217/
3. Change openstack_version value in openstack.yaml in fuel-web repo to 'liberty-8.0'. Change display name of release to 'Liberty', update functional tests. This change should pass Fuel CI gate after the previous CR (#2) merged: https://review.openstack.org/#/c/238846/5
4. Delete code that copies Puppet modules to /etc/puppet/2015.1.0-8.0/ dir from fuel-library RPM spec, since it's no longer needed to pass Fuel CI: https://review.openstack.org/#/c/252556/

Reviewed: https://review.openstack.org/251260
Committed: https://git.openstack.org/cgit/openstack/fuel-ostf/commit/?id=9243eab196db78d1a401f7309ba624f125f509ff
Submitter: Jenkins
Branch: master

commit 9243eab196db78d1a401f7309ba624f125f509ff
Author: Oleg Gelbukh <email address hidden>
Date: Mon Nov 30 09:25:52 2015 +0000

    Compare versions of OpenStack with LooseVersion

    Since release Liberty, OpenStack doesn't have common release version
    (like 2015.1.0). If we use release codename to identify the version
    instead (like 'liberty'), it cannot be compared to previous numeric
    versions with distutils.version.StrictVersion.

    Use of LooseVersion instead ensures that alphabetic version will always
    be considered 'newer' than numeric version.

    Change-Id: Ifefc4fab56993ed369a92804b1a866e766b2ec0b
    Related-bug: 1503663

Nastya Urlapova (aurlapova) wrote :

Folks, could you fix it asap.

Changed in fuel:
importance: High → Critical
Nastya Urlapova (aurlapova) wrote :

SCF was announced but we still see Kilo as choice.

Changed in fuel:
assignee: Oleg S. Gelbukh (gelbuhos) → Alex Schultz (alex-schultz)

Change abandoned by Oleg Gelbukh (<email address hidden>) on branch: master
Review: https://review.openstack.org/238846

Change abandoned by Oleg Gelbukh (<email address hidden>) on branch: master
Review: https://review.openstack.org/235254

Dmitry Pyzhov (dpyzhov) on 2015-12-25
tags: removed: blocked

Reviewed: https://review.openstack.org/261075
Committed: https://git.openstack.org/cgit/openstack/fuel-web/commit/?id=e568369a18836cc13c24406f7f24b59fe18ac2cb
Submitter: Jenkins
Branch: master

commit e568369a18836cc13c24406f7f24b59fe18ac2cb
Author: Alex Schultz <email address hidden>
Date: Wed Dec 23 11:35:40 2015 -0700

    Correct Openstack version text for release

    This change updates the Openstack names for the releases for 8.0.

    Change-Id: I8f870462a8f3d8e11f79d680408777c89c8e2aa7
    Closes-Bug: #1503663

Changed in fuel:
status: In Progress → Fix Committed
tags: added: on-verification
Igor Marnat (imarnat) wrote :

ISO #368 still provides Kilo.

Changed in fuel:
status: Fix Committed → Confirmed
tags: removed: on-verification
Alex Schultz (alex-schultz) wrote :

Reviewed: https://review.openstack.org/261390
Committed: https://git.openstack.org/cgit/openstack/fuel-web/commit/?id=1f711f0a98748d7573c818ad1c1f97ca381e1510
Submitter: Jenkins
Branch: stable/8.0

commit 1f711f0a98748d7573c818ad1c1f97ca381e1510
Author: Alex Schultz <email address hidden>
Date: Wed Dec 23 11:35:40 2015 -0700

    Correct Openstack version text for release

    This change updates the Openstack names for the releases for 8.0.

    Change-Id: I8f870462a8f3d8e11f79d680408777c89c8e2aa7
    Closes-Bug: #1503663
    (cherry picked from commit e568369a18836cc13c24406f7f24b59fe18ac2cb)

Changed in fuel:
status: Confirmed → Fix Committed
tags: added: on-verification
Dmitriy Kruglov (dkruglov) wrote :

Verified on MOS 8.0, build 405. The issue is fixed.

ISO details:
VERSION:
  feature_groups:
    - mirantis
  production: "docker"
  release: "8.0"
  api: "1.0"
  build_number: "405"
  build_id: "405"
  fuel-nailgun_sha: "9ebbaa0473effafa5adee40270da96acf9c7d58a"
  python-fuelclient_sha: "4f234669cfe88a9406f4e438b1e1f74f1ef484a5"
  fuel-agent_sha: "df16d41cd7a9445cf82ad9fd8f0d53824711fcd8"
  fuel-nailgun-agent_sha: "92ebd5ade6fab60897761bfa084aefc320bff246"
  astute_sha: "c7ca63a49216744e0bfdfff5cb527556aad2e2a5"
  fuel-library_sha: "037ca95820aac8214fe65e7e0461074e1cf6891c"
  fuel-ostf_sha: "214e794835acc7aa0c1c5de936e93696a90bb57a"
  fuel-mirror_sha: "8bb8c70efc61bcf633e02d6054dbf5ec8dcf6699"
  fuelmenu_sha: "2a0def56276f0fc30fd949605eeefc43e5d7cc6c"
  shotgun_sha: "63645dea384a37dde5c01d4f8905566978e5d906"
  network-checker_sha: "9f0ba4577915ce1e77f5dc9c639a5ef66ca45896"
  fuel-upgrade_sha: "616a7490ec7199f69759e97e42f9b97dfc87e85b"
  fuelmain_sha: "62573cb2a8aa54845de9303b4a30935a90e1db61"

Changed in fuel:
status: Fix Committed → Fix Released
tags: removed: on-verification

Reviewed: https://review.openstack.org/238846
Committed: https://git.openstack.org/cgit/openstack/fuel-web/commit/?id=9c8cd9196df72360668d7feca1b7d6e8af49fad5
Submitter: Jenkins
Branch: master

commit 9c8cd9196df72360668d7feca1b7d6e8af49fad5
Author: Oleg Gelbukh <email address hidden>
Date: Thu Oct 22 17:57:23 2015 +0000

    Change openstack_version to liberty-9.0 in openstack.yaml

    Set release name to 'Liberty' in display name and description of new release.
    Set openstack_version setting to 'liberty-9.0' to comply with the existing
    versions schema.
    Set opesntack_version to 'liberty-9.0' in tests.

    Closes-bug: 1503663
    Change-Id: Ifef952e18f08b98c430bbff9434984deaa68df81

Reviewed: https://review.openstack.org/235254
Committed: https://git.openstack.org/cgit/openstack/fuel-library/commit/?id=8e24554e6d85b95e981cad9eb076ef8f8a2d443c
Submitter: Jenkins
Branch: master

commit 8e24554e6d85b95e981cad9eb076ef8f8a2d443c
Author: Oleg Gelbukh <email address hidden>
Date: Thu Oct 15 10:41:41 2015 +0000

    Change openstack_version to liberty-9.0

    Since there is no coordinated release version anymore, use Fuel version number
    and OpenStack release name to construct path to Fuel Library modules for the
    current release.

    Fuel-CI: disable

    Change-Id: I13a78d5ea6d9e1b04fe835fcc4d0c22625efb7a3
    Related-bug: 1503663
    Depends-on: Ifef952e18f08b98c430bbff9434984deaa68df81

Reviewed: https://review.openstack.org/262303
Committed: https://git.openstack.org/cgit/openstack/fuel-web/commit/?id=b35cc11a8d8e6c384a196c4903eb09cc580ca14b
Submitter: Jenkins
Branch: stable/8.0

commit b35cc11a8d8e6c384a196c4903eb09cc580ca14b
Author: Oleg Gelbukh <email address hidden>
Date: Thu Oct 22 17:57:23 2015 +0000

    Change openstack_version to liberty-8.0 in openstack.yaml

    Set release name to 'Liberty' in display name and description of new release.
    Set openstack_version setting to 'liberty-8.0' to comply with the existing
    versions schema.
    Set opesntack_version to 'liberty-8.0' in tests.

    Change-Id: I5bdabcf921ccda53b672d3f535238cd4c8c184fc
    Closes-bug: 1503663

Reviewed: https://review.openstack.org/262300
Committed: https://git.openstack.org/cgit/openstack/fuel-library/commit/?id=13baabc61f826d1563486a5100c6fe033f2f26ad
Submitter: Jenkins
Branch: stable/8.0

commit 13baabc61f826d1563486a5100c6fe033f2f26ad
Author: Oleg Gelbukh <email address hidden>
Date: Thu Oct 15 10:41:41 2015 +0000

    Change openstack_version to liberty-8.0

    Since there is no coordinated release version anymore, use Fuel version number
    and OpenStack release name to construct path to Fuel Library modules for the
    current release.

    Fuel-CI: disable
    Change-Id: Ibcb9866f9bd26fb00eb214e8a54765ad047f9293
    Related-bug: 1503663

Download full text (21.0 KiB)

Reviewed: https://review.openstack.org/360086
Committed: https://git.openstack.org/cgit/openstack/fuel-nailgun-extension-cluster-upgrade/commit/?id=40dd411fe461441e943de806f5de632eeb64dc4a
Submitter: Jenkins
Branch: stable/mitaka

commit 17ab5a3aaa7d2c4ae4652d1a4dc0410b31e7c47d
Author: Sergey Abramov <email address hidden>
Date: Wed Aug 24 18:32:39 2016 +0300

    Add create upgrade release handler

    Required for create new release just for upgrade, that have overwrited
    params. This params are valid for orig cluster release.

    Change-Id: Ib2387b9c2b74902c7289ee8f69a5f5d323ec82ca

commit 8de47e0dbf5955b3cbe59a3956e1ca1f4d8679ef
Author: Nikita Zubkov <email address hidden>
Date: Wed Aug 24 15:42:32 2016 +0300

    Add VIPs transformer

    Move upgrade vips code to the transformer

    Change-Id: Ia6935521b8b90b73fb74ba92859e7febf74c4ced

commit b54f9d4c29808c4561b20af508b85b9e40fa72b6
Author: Nikita Zubkov <email address hidden>
Date: Wed Aug 24 17:51:39 2016 +0300

    Move partition info transformation to extension

    octane have some dirty hacks to change volumes attributes using nailgun
    as a library, such modifications should be done in a extension

    Change-Id: I422bb368916f3a319e286edcc6103a2834097a87

commit b3ce0d348cc20ed988b5adf66474836f631eb12d
Author: Anastasiya <email address hidden>
Date: Mon Aug 1 15:47:13 2016 +0300

    Add tests for assign_node_to_cluster

    Change-Id: Iafa1baa6a1ca4d701ec89e49dd9d6f969804c82e

commit a764ba306dcd0cfb65a82c89f07ec0f3d129c66b
Author: Nikita Zubkov <email address hidden>
Date: Tue Aug 23 14:05:16 2016 +0300

    Update README

    Add instalation section

    Change-Id: Ib16132ab9c18d757e96e98304fdd8339ddf5497a

commit 95ff3a3598397bb6e3c68793051298aaa006d163
Author: Yuriy Taraday <email address hidden>
Date: Tue Aug 23 23:01:16 2016 +0300

    Add cluster transformations

    Implement transformations that are applied to cluster attributes during
    environment cloning.

    Conversion from text to text_list type has been limited to dns_list and
    ntp_list keys only to keep predictable behavior.

    Change-Id: I1ff596f850bd42243697cad1c1c35f0cf1386376

commit 163ce243fbade3dac05eb535ad2987687a57f87d
Author: Yuriy Taraday <email address hidden>
Date: Tue Aug 23 22:51:19 2016 +0300

    Add pluggable transformations for data migration

    This change introduces new transformation mechanism:
    - all available transformations are listed in setuptools entry points
      under namespace like this (for cluster transformations):

        nailgun.cluster_upgrade.transformations.cluster.9.0 =
            dns_list = ...
            ntp_list = ...
        nailgun.cluster_upgrade.transformations.cluster.8.0 =
            ...
        <etc>

    - config file will include section that specifies enabled
      transformations like this:

        CLUSTER_UPGRADE_TRANSFORMATIONS:
          cluster:
            9.0: dns_list ntp_list ...
            8.0: ...
            7.0: ...

      (only default values are implemented here, actual config support will
      follow)

    - when transformations...

tags: added: in-stable-mitaka

Change abandoned by Ilya Kharin (<email address hidden>) on branch: master
Review: https://review.openstack.org/367019

Change abandoned by Ilya Kharin (<email address hidden>) on branch: master
Review: https://review.openstack.org/367419

Download full text (14.8 KiB)

Reviewed: https://review.openstack.org/367019
Committed: https://git.openstack.org/cgit/openstack/fuel-nailgun-extension-cluster-upgrade/commit/?id=e38d48cbc5d216ac0f853466ab48e5d6d9687521
Submitter: Jenkins
Branch: master

commit a4e2a67e3e5024b0ae65f445355965a1263fef73
Author: Ilya Kharin <email address hidden>
Date: Sat Sep 3 02:42:07 2016 +0300

    Add support to re-assign a set of nodes

    This patch adds an ability to re-assign a set of the given nodes at
    once. This feature was technically available but not exposed to the
    client. A groupped re-assigning allows to effectively re-provision nodes
    by creating an atomic task in Astute.

    Change-Id: I4a7c7e35d844683ef73ad7f8459d1892e80e0a64
    Related-Bug: #1616925

commit d87125662f2f55204244e43ec6522fe36c6bf21e
Author: Nikita Zubkov <email address hidden>
Date: Mon Aug 29 17:56:09 2016 +0300

    Add test for vip transformer

    Change-Id: I65124237604fe6718ad6c351825f192a98d470fb
    (cherry picked from commit 55422ddce7b0e9e1b9976504500de8a1688a99d7)

commit 3cac9b551cdecaf9148800cc6fd9b81fbb3149c5
Author: Nikita Zubkov <email address hidden>
Date: Tue Jul 19 18:24:42 2016 +0300

    Switch to upstream fuel-web repository

    Change-Id: I994304bdc8eaf7e4da175981cb721d41a286fed0
    Depends-On: Id0bc78478cf3f40767fed760cd54e487a934fa10

commit a78f4348f84dd470ba1f3b99d2c751fa2dd12d7a
Author: Anastasiya <email address hidden>
Date: Mon Aug 1 14:39:35 2016 +0300

    Move change_env_settings function from octane to cluster upgrade extension

    * change_env_settings function was moved to cluster upgrade extention
    * merge generated attributes code was written

    Change-Id: I6d1e27b8b0c01f3251067bc88931cd2354feb5ce
    Partial-Bug: #1602587
    (cherry picked from commit dc2e3f930957b2c8af2d6c6a60bfcc6c5e6bb061)

commit 280fc4f08258f1e85ba099f74c4956233652e9a2
Author: Ilya Kharin <email address hidden>
Date: Wed Aug 10 17:28:17 2016 +0300

    Add absent __init__.py to migrations/versions

    Without the versions/__init__.py file versions was not identified as
    a package and was not included in a distribution.

    Change-Id: I67f152ebb9234df880c61d79d154b1aabc8828c6
    Closes-Bug: #1611793

commit f7ebb08b46f5beb13701f7a6a71a1f4fea05f451
Author: Alexander Tsamutali <email address hidden>
Date: Mon Aug 1 15:47:58 2016 +0300

    Add package spec

    Change-Id: Id71764dff07a4b32851eb8ccf69c66dca4a7b6ab
    Related-Bug: #1604492

commit b93ebedc49f79f6ba4a710a9d1715c9f965b3081
Author: Anastasiya <email address hidden>
Date: Fri Jul 15 10:24:11 2016 +0300

    Correction of transformation for text_list

    * added removing of space in text_list
    * added test for merge_attributes

    Change-Id: I5582878fc7c524551593abf21dfd4ea45cd430c9
    Closes-bug: 1602607
    (cherry picked from commit fdd2a6226483c67ce8bc7adc8b2d354862125bac)

commit d4db5ba78ccefd08e465cd30116094678c5cb35f
Author: Nikita Zubkov <email address hidden>
Date: Wed Jul 13 13:43:58 2016 +0300

    Fix package namespace

commit 443fc43da6e963cd0825880a80678e8e385c0a3a
Author: Nikita Zubkov <email address hidden>
Date: Wed J...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers