nova-network - cannot untick "Use VLAN tagging for fixed networks"

Bug #1503638 reported by Dmitry Sutyagin on 2015-10-07
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Fuel for OpenStack
High
Alexander Kislitsky
7.0.x
High
Alexander Kislitsky

Bug Description

Fuel 7.0

Steps to reproduce:

1. Create a new environemnt:
 - VMWare
 - legacy (nova-network)

2. Navigate to Networks tab
3. Untick "Use VLAN tagging for fixed networks"
4. Click "Save Settings"

Expected result:
Changes are saved successfully.

Actual result:
Verification failed.
None is not of type 'integer' Failed validating 'type' in schema['properties']['networking_parameters']['properties']['fixed_networks_vlan_start']: {'minValue': 0, 'type': 'integer'} On instance['networking_parameters']['fixed_networks_vlan_start']: None

Also see attached screenshot.

Dmitry Sutyagin (dsutyagin) wrote :
Dmitry Sutyagin (dsutyagin) wrote :

Same behavior if YAML file is edited (changed 'fixed_networks_vlan_start' to 'null'):

[root@fuel ~]# fuel --env 2 network upload
Error uploading configuration: None is not of type 'integer'

Failed validating 'type' in schema['properties']['networking_parameters']['properties']['fixed_networks_vlan_start']:
    {'minValue': 0, 'type': 'integer'}

On instance['networking_parameters']['fixed_networks_vlan_start']:
    None

Changed in fuel:
assignee: Fuel UI Team (fuel-ui) → Fuel Library Team (fuel-library)
Vitaly Kramskikh (vkramskikh) wrote :

Seems to be JSON schema issue in nailgun

Changed in fuel:
assignee: Fuel Library Team (fuel-library) → Fuel Python Team (fuel-python)
Changed in fuel:
milestone: 7.0-updates → 8.0
Changed in fuel:
assignee: Fuel Python Team (fuel-python) → Alexander Kislitsky (akislitsky)
status: New → Confirmed

Fix proposed to branch: master
Review: https://review.openstack.org/232568

Changed in fuel:
status: Confirmed → In Progress
Dmitry Pyzhov (dpyzhov) on 2015-10-09
no longer affects: fuel/8.0.x

Reviewed: https://review.openstack.org/232568
Committed: https://git.openstack.org/cgit/stackforge/fuel-web/commit/?id=c06de58cab70d4f7e94dc825723d8886e199d87d
Submitter: Jenkins
Branch: master

commit c06de58cab70d4f7e94dc825723d8886e199d87d
Author: Alexander Kislitsky <email address hidden>
Date: Thu Oct 8 17:35:22 2015 +0300

    Fix for nova networking schema validation

    The nullable value is valid value for fixed_networks_vlan_start.
    Restriction removed from API validation schema.

    Change-Id: I8e13716954d5607a7d7fd0ce10f7d55b9dd2a8ed
    Closes-Bug: #1503638

Changed in fuel:
status: In Progress → Fix Committed

Reviewed: https://review.openstack.org/233541
Committed: https://git.openstack.org/cgit/stackforge/fuel-web/commit/?id=aa3c5d2e7df73030d3b9997d7c89460c2ff19fe5
Submitter: Jenkins
Branch: stable/7.0

commit aa3c5d2e7df73030d3b9997d7c89460c2ff19fe5
Author: Alexander Kislitsky <email address hidden>
Date: Thu Oct 8 17:35:22 2015 +0300

    Fix for nova networking schema validation

    The nullable value is valid value for fixed_networks_vlan_start.
    Restriction removed from API validation schema.

    Change-Id: I8e13716954d5607a7d7fd0ce10f7d55b9dd2a8ed
    Closes-Bug: #1503638

Anastasia Palkina (apalkina) wrote :

Verified on ISO #151

"fuel-createmirror_sha": "fe81731b76071dc0a4ffdf039080732243f5a871", "api": "1.0", "fuelmain_sha": "f5b83e3f0ccfce90b9ca797bc039c9ab50b5ee55", "astute_sha": "a090546d43c770ac27ca81c6f8c78ff0ba4a93e0", "fuel-ostf_sha": "e308a7ad68838f6e012d6d80243eb32b4f7e6c18", "openstack_version": "2015.1.0-8.0", "build_id": "151", "build_number": "151", "auth_required": true, "fuel-library_sha": "d4b67bca618c48332486339f8342413ea9b4bc3b", "fuel-nailgun-agent_sha": "08e0a11cf1f29b705e4b910d9b9db5e9b708b6e3", "fuel-nailgun_sha": "56a1ca6c1889ae5a8378198db65c0168c8c06484", "fuel-agent_sha": "5d2d5e2e9ad4f8bb01e450240d85447608d84b92", "production": "docker", "python-fuelclient_sha": "655db5e96282bbafc4dae54462a01823b6b464cb", "feature_groups": ["mirantis"], "release": "8.0", "release_versions": {"2015.1.0-8.0": {"VERSION": {"fuel-createmirror_sha": "fe81731b76071dc0a4ffdf039080732243f5a871", "api": "1.0", "fuelmain_sha": "f5b83e3f0ccfce90b9ca797bc039c9ab50b5ee55", "astute_sha": "a090546d43c770ac27ca81c6f8c78ff0ba4a93e0", "fuel-ostf_sha": "e308a7ad68838f6e012d6d80243eb32b4f7e6c18", "openstack_version": "2015.1.0-8.0", "build_id": "151", "build_number": "151", "fuel-library_sha": "d4b67bca618c48332486339f8342413ea9b4bc3b", "fuel-nailgun-agent_sha": "08e0a11cf1f29b705e4b910d9b9db5e9b708b6e3", "fuel-nailgun_sha": "56a1ca6c1889ae5a8378198db65c0168c8c06484", "fuel-agent_sha": "5d2d5e2e9ad4f8bb01e450240d85447608d84b92", "production": "docker", "python-fuelclient_sha": "655db5e96282bbafc4dae54462a01823b6b464cb", "feature_groups": ["mirantis"], "release": "8.0"}}}

Changed in fuel:
status: Fix Committed → Fix Released
tags: added: on-verification
Dmitriy Kruglov (dkruglov) wrote :

Verified on MOS 7.0, custom ISO (19 Oct build). The issue is not reproduced.

ISO info:
VERSION:
  feature_groups:
    - mirantis
  production: "docker"
  release: "7.0"
  openstack_version: "2015.1.0-7.0"
  api: "1.0"
  build_number: "17"
  build_id: "17"
  nailgun_sha: "b43ba03685dff284d77aa05f480cde4ce2a5cca8"
  python-fuelclient_sha: "486bde57cda1badb68f915f66c61b544108606f3"
  fuel-agent_sha: "50e90af6e3d560e9085ff71d2950cfbcca91af67"
  fuel-nailgun-agent_sha: "d7027952870a35db8dc52f185bb1158cdd3d1ebd"
  astute_sha: "4703e7333c89116f4cc0b2ccee5f981683825c54"
  fuel-library_sha: "ba38e4116c23a4b76c826221872d8bd614ea455b"
  fuel-ostf_sha: "b33e3950fda73f5fd8ebe0453121ca7cc0137c40"
  fuelmain_sha: "8ac0749d30aab906282361f2e6daa0a961a0bf6a"

tags: removed: on-verification
Dmitry Pyzhov (dpyzhov) on 2015-10-22
tags: added: area-python
Dmitriy Kruglov (dkruglov) wrote :

Verified on MOS 7.0 GA with maintenance update 1 applied. The issue is not reproduced.

ISO info:
VERSION:
  feature_groups:
    - mirantis
  production: "docker"
  release: "7.0"
  openstack_version: "2015.1.0-7.0"
  api: "1.0"
  build_number: "301"
  build_id: "301"
  nailgun_sha: "4162b0c15adb425b37608c787944d1983f543aa8"
  python-fuelclient_sha: "486bde57cda1badb68f915f66c61b544108606f3"
  fuel-agent_sha: "50e90af6e3d560e9085ff71d2950cfbcca91af67"
  fuel-nailgun-agent_sha: "d7027952870a35db8dc52f185bb1158cdd3d1ebd"
  astute_sha: "6c5b73f93e24cc781c809db9159927655ced5012"
  fuel-library_sha: "5d50055aeca1dd0dc53b43825dc4c8f7780be9dd"
  fuel-ostf_sha: "2cd967dccd66cfc3a0abd6af9f31e5b4d150a11c"
  fuelmain_sha: "a65d453215edb0284a2e4761be7a156bb5627677"

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers