[8.0-kilo] fa_build_image command failed

Bug #1502780 reported by Sergey Kulanov on 2015-10-05
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Fuel for OpenStack
Critical
Vladimir Kozhukalov
7.0.x
Undecided
Unassigned

Bug Description

Failed to run command cd / && fa_build_image

https://product-ci.infra.mirantis.net/job/8.0-kilo.test_all/

2015-10-04 11:38:14,193 - DEBUG __init__.py:60 -- Done: get_task with result: {u'status': u'error', u'name': u'deploy', u'cluster': 1, u'result': {}, u'progress': 100, u'message': u'Failed to execute hook \'shell\' Failed to run command cd / && fa_build_image --image_build_dir /var/lib/fuel/ibp --log-file /var/log/fuel-agent-env-1.log --data_driver nailgun_build_image --input_data \'{"image_data": {"/boot": {"container": "gzip", "uri": "http://10.109.30.2:8080/targetimages/env_1_ubuntu_1404_amd64-boot.img.gz", "format": "ext2"},

2015-10-04 12:47:44.854 INFO [7f5f8262e700] (receiver) RPC method provision_resp received: {"status": "error", "progress": 100, "task_uuid": "56469ab8-2615-437d-b7c1-43a59457c506", "nodes": [{"status": "error", "progress": 100, "error_type": "provision", "uid": "6", "error_msg": "Failed to provision"}, {"status": "error", "progress": 100, "error_type": "provision", "uid": "5", "error_msg": "Failed to provision"}, {"status": "error", "progress": 100, "error_type": "provision", "uid": "4", "error_msg": "Failed to provision"}, {"status": "error", "progress": 100, "error_type": "provision", "uid": "3", "error_msg": "Failed to provision"}, {"status": "error", "progress": 100, "error_type": "provision", "uid": "2", "error_msg": "Failed to provision"}, {"status": "error", "progress": 100, "error_type": "provision", "uid": "1", "error_msg": "Failed to provision"}], "error": "Too many nodes failed to provision"}

node-1.test.domain.local/bootstrap/fuel-agent.log:
2015-10-04T12:47:42.447309+00:00 info: 2015-10-04 12:47:41.987 5528 DEBUG fuel_agent.utils.artifact [-] Expected content length 27151123 for http://10.109.25.2:8080/targetimages/env_1_ubuntu_1404_amd64-boot.img.gz
2015-10-04T12:47:42.447732+00:00 info: 2015-10-04 12:47:41.988 5528 DEBUG fuel_agent.utils.artifact [-] Processor target: /dev/vda3
2015-10-04T12:47:42.448065+00:00 info: 2015-10-04 12:47:41.988 5528 DEBUG fuel_agent.utils.artifact [-] Opening file: /dev/vda3 for write
2015-10-04T12:47:42.448397+00:00 info: 2015-10-04 12:47:42.071 5528 DEBUG fuel_agent.utils.artifact [-] Next chunk: 0
2015-10-04T12:47:42.448778+00:00 info: 2015-10-04 12:47:42.094 5528 DEBUG fuel_agent.utils.artifact [-] Next chunk: 1
2015-10-04T12:47:42.449106+00:00 info: 2015-10-04 12:47:42.112 5528 DEBUG fuel_agent.utils.artifact [-] Next chunk: 2
2015-10-04T12:47:42.449488+00:00 info: 2015-10-04 12:47:42.128 5528 DEBUG fuel_agent.utils.artifact [-] Next chunk: 3
2015-10-04T12:47:42.449830+00:00 info: 2015-10-04 12:47:42.142 5528 DEBUG fuel_agent.utils.artifact [-] Next chunk: 4
2015-10-04T12:47:42.450146+00:00 info: 2015-10-04 12:47:42.171 5528 ERROR fuel_agent.cmd.agent [-] Error -3 while decompressing: invalid stored block lengths
2015-10-04T12:47:42.450520+00:00 info: 2015-10-04 12:47:42.171 5528 TRACE fuel_agent.cmd.agent Traceback (most recent call last):
2015-10-04T12:47:42.450854+00:00 info: 2015-10-04 12:47:42.171 5528 TRACE fuel_agent.cmd.agent File "/usr/lib/python2.6/site-packages/fuel_agent/cmd/agent.py", line 97, in main
2015-10-04T12:47:42.451161+00:00 info: 2015-10-04 12:47:42.171 5528 TRACE fuel_agent.cmd.agent getattr(mgr, action)()
2015-10-04T12:47:42.451548+00:00 info: 2015-10-04 12:47:42.171 5528 TRACE fuel_agent.cmd.agent File "/usr/lib/python2.6/site-packages/fuel_agent/manager.py", line 512, in do_provisioning
2015-10-04T12:47:42.452002+00:00 info: 2015-10-04 12:47:42.171 5528 TRACE fuel_agent.cmd.agent self.do_copyimage()
2015-10-04T12:47:42.452543+00:00 info: 2015-10-04 12:47:42.171 5528 TRACE fuel_agent.cmd.agent File "/usr/lib/python2.6/site-packages/fuel_agent/manager.py", line 328, in do_copyimage
2015-10-04T12:47:42.453039+00:00 info: 2015-10-04 12:47:42.171 5528 TRACE fuel_agent.cmd.agent processing.process()
2015-10-04T12:47:42.453544+00:00 info: 2015-10-04 12:47:42.171 5528 TRACE fuel_agent.cmd.agent File "/usr/lib/python2.6/site-packages/fuel_agent/utils/artifact.py", line 228, in process
2015-10-04T12:47:42.454118+00:00 info: 2015-10-04 12:47:42.171 5528 TRACE fuel_agent.cmd.agent return reduce(jump, self.processors)
2015-10-04T12:47:42.454580+00:00 info: 2015-10-04 12:47:42.171 5528 TRACE fuel_agent.cmd.agent File "/usr/lib/python2.6/site-packages/fuel_agent/utils/artifact.py", line 222, in jump
2015-10-04T12:47:42.454886+00:00 info: 2015-10-04 12:47:42.171 5528 TRACE fuel_agent.cmd.agent proc.target(next_proc)
2015-10-04T12:47:42.455480+00:00 info: 2015-10-04 12:47:42.171 5528 TRACE fuel_agent.cmd.agent File "/usr/lib/python2.6/site-packages/fuel_agent/utils/artifact.py", line 55, in target
2015-10-04T12:47:42.455798+00:00 info: 2015-10-04 12:47:42.171 5528 TRACE fuel_agent.cmd.agent for chunk in self:
2015-10-04T12:47:42.456204+00:00 info: 2015-10-04 12:47:42.171 5528 TRACE fuel_agent.cmd.agent File "/usr/lib/python2.6/site-packages/fuel_agent/utils/artifact.py", line 126, in next
2015-10-04T12:47:42.456664+00:00 info: 2015-10-04 12:47:42.171 5528 TRACE fuel_agent.cmd.agent return self.decompressor.decompress(self.stream.next())
2015-10-04T12:47:42.456925+00:00 info: 2015-10-04 12:47:42.171 5528 TRACE fuel_agent.cmd.agent error: Error -3 while decompressing: invalid stored block lengths
2015-10-04T12:47:42.457246+00:00 info: 2015-10-04 12:47:42.171 5528 TRACE fuel_agent.cmd.agent

Changed in fuel:
assignee: nobody → Fuel Python Team (fuel-python)
status: New → Confirmed
Nastya Urlapova (aurlapova) wrote :
summary: - fa_build_image command failed
+ [8.0-kilo] fa_build_image command failed
Changed in fuel:
assignee: Fuel Python Team (fuel-python) → Vladimir Kozhukalov (kozhukalov)
Changed in fuel:
status: Confirmed → In Progress
Matthew Mosesohn (raytrac3r) wrote :

https://review.openstack.org/#/c/231007/2 looks like we are reverting this because it's related. Let's confirm the issue disappears by reverting...

Reviewed: https://review.openstack.org/231007
Committed: https://git.openstack.org/cgit/stackforge/fuel-main/commit/?id=2499db9077ca1fe99b0944543e791337b6d55910
Submitter: Jenkins
Branch: master

commit 2499db9077ca1fe99b0944543e791337b6d55910
Author: Vladimir Kozhukalov <email address hidden>
Date: Mon Oct 5 14:05:32 2015 +0000

    Revert "Improve readability of dockerfiles and cleanup"

    This reverts commit 16eac32808bcb0429923a1e82a2460c073080955.

    Closes-Bug: #1502780
    Change-Id: Ib192dc04bbf78500de9385f5926efaba5ee3d81e

Changed in fuel:
status: In Progress → Fix Committed
Vasily Gorin (vgorin) wrote :

Verified on build #140

Changed in fuel:
status: Fix Committed → Fix Released
Dmitry Pyzhov (dpyzhov) on 2015-10-21
tags: added: area-python
Dmitry Pyzhov (dpyzhov) on 2015-10-27
tags: added: regression-8.0
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers