Unexpected collector answer due to re-naming nailgun to fuel-nailgun

Bug #1500470 reported by Vasily Gorin on 2015-09-28
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Fuel for OpenStack
Critical
Alexander Kislitsky
7.0.x
High
Alexander Kislitsky

Bug Description

CI: https://product-ci.infra.mirantis.net/job/8.0.system_test.ubuntu.thread_non_func_1/3/testReport/junit/(root)/external_ntp_ha/external_ntp_ha/

Build #3

Exception in /var/log/nailgun/statsenderd.log :

2015-09-28 02:28:52.546 ERROR [7f0e8dc7e700] (statsenderd) Unexpected collector answer: {
  "message": "u'nailgun_sha' is a required property\n\nFailed validating u'required' in schema[u'properties'][u'installation_structure'][u'properties'][u'fuel_release']:\n {u'oneOf': [{u'required': [u'fuel-ostf_sha',\n u'python-fuelclient_sha',\n u'fuel-library_sha']},\n {u'required': [u'ostf_sha', u'fuellib_sha']}],\n u'properties': {u'api': {u'type': u'string'},\n u'astute_sha': {u'type': u'string'},\n u'build_id': {u'type': u'string'},\n u'feature_groups': {u'items': {u'type': u'string'},\n u'type': u'array'},\n u'fuel-library_sha': {u'type': u'string'},\n u'fuel-ostf_sha': {u'type': u'string'},\n u'fuellib_sha': {u'type': u'string'},\n u'fuelmain_sha': {u'type': u'string'},\n u'nailgun_sha': {u'type': u'string'},\n u'ostf_sha': {u'type': u'string'},\n u'python-fuelclient_sha': {u'type': u'string'},\n u'release': {u'type': u'string'}},\n u'required': [u'release',\n u'astute_sha',\n u'nailgun_sha',\n u'api',\n u'feature_groups'],\n u'type': u'object'}\n\nOn instance[u'installation_structure'][u'fuel_release']:\n {u'api': u'1.0',\n u'astute_sha': u'0f753467a3f16e4d46e7e9f1979905fb178e4d5b',\n u'build_id': u'87',\n u'build_number': u'87',\n u'feature_groups': [u'mirantis'],\n u'fuel-agent_sha': u'bfaf7fb856762d36c3ec6413b909b636f2906853',\n u'fuel-library_sha': u'd3d4cbde0480b12a81a88892e9128e1232fb2010',\n u'fuel-nailgun-agent_sha': u'd66f188a1832a9c23b04884a14ef00fc5605ec6d',\n u'fuel-nailgun_sha': u'5b2dd58594daf3ff492be0b0cc0d2de289cc2bc9',\n u'fuel-ostf_sha': u'92935ca61afb5bbefe886a36d29fc458fc419d1f',\n u'fuelmain_sha': u'8eddd7a62ee942f09f8f66059b4d24a25de8fe33',\n u'openstack_version': u'2015.1.0-8.0',\n u'production': u'docker',\n u'python-fuelclient_sha': u'4ede2b4d774240fa9cbffef2cbbf75203eb5a025',\n u'release': u'8.0'}",
  "status": "error"
}

Vasily Gorin (vgorin) on 2015-09-29
Changed in fuel:
importance: High → Critical
Tatyanka (tatyana-leontovich) wrote :
summary: - Unexpected collector answer
+ Unexpected collector answer due to re-naming nailgun to fuel-nailgun
tags: added: swarm-blocker
Changed in fuel:
assignee: Fuel Python Team (fuel-python) → Alexander Kislitsky (akislitsky)
status: New → Confirmed

Fix proposed to branch: master
Review: https://review.openstack.org/228810

Changed in fuel:
status: Confirmed → In Progress

This issue doesn't affect 7.0 release. Thus it is invalid for 7.0

Reviewed: https://review.openstack.org/228810
Committed: https://git.openstack.org/cgit/stackforge/fuel-stats/commit/?id=13593e77ef53f76e9656166d3fff16900e5962da
Submitter: Jenkins
Branch: master

commit 13593e77ef53f76e9656166d3fff16900e5962da
Author: Alexander Kislitsky <email address hidden>
Date: Tue Sep 29 12:26:38 2015 +0300

    Field 'fuel-nailgun_sha' added to collector protocol

    In FUEL 8.0 release info data structure was changed. Field 'fuel-nailgun_sha'
    was used instead 'nailgun_sha'. Information about nailgun build is
    required for stats, so we change required fields list for FUEL 8.0

    Change-Id: Ib37502663c0dd05a2ec1cc3df182cdb87c400059
    Closes-Bug: #1500470

Changed in fuel:
status: In Progress → Fix Committed
Vasily Gorin (vgorin) wrote :
Changed in fuel:
status: Fix Committed → Fix Released
Dmitry Pyzhov (dpyzhov) on 2015-10-22
tags: added: area-python
Dmitry Pyzhov (dpyzhov) on 2015-10-27
tags: added: regression-8.0
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers